• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

DComLaunch and WmiPrvSE.exe, DComLaunch and WmiPrvSE.exe makes CPU running high

termin

New Member
Messages
2
#1
My laptop's, with Vista 64-bit business, CPU is running high constant. And when I analyzed this with ProcessExplorer I see that its the SvcHost (DComLaunch which I believe trigged by WmiPrvSE.exe) the the process thats running high. About 30-50% CPU.

I've read other forums about other ppl with same problems but non of their solutions helps. Their problems has been:
Some HP driver for printer (dont own anything related to HP)
Sound enhancement (have disable the sound enhancements)
Realtek Audio (have updated the drivers)

The threads i get for SvcHost (DComLaunch) from ProcessExplorer (PE) are:
ntoskrnl.exe!KiSwapContext+0x7f
...
RPCRT4.dll!COMMON_ProcessCalls+0x80
...

I have tried to turn off every services (non-microsoft) and every autostart programs. (I've also have debug-files WmiPrvSE.pdb and no idea what i can do with it)

When I close the application I get an error message saying the DComLaunch has stopped working and windows has to reboot (something like that)

And when i run it in safemode the error is still there only taking 15-25% CPU...
One other thing i realized that the two services that are grouped to DcomLaunch: Plug and Play and DcomLaunch.

Would appreciate some help since this is driving me crazy...
 

My Computer

Leahcim

New Member
Messages
3
#2
For me it was Waypoint Maploader delivered with my SonyEricsson Xperia X1 that caused this.
It did not help to uninstall Maploader, i had to do a rollback.
/Mike
 

My Computer

termin

New Member
Messages
2
#3
Wow..I think you nailed it :). i had just bought a X1 and installed wayfinder...but I reinstalled Windows.. but thanks for the help, from now on I can sleep better at nights

btw..what is a rollback??
 

My Computer

Leahcim

New Member
Messages
3
#4
Wow..I think you nailed it :). i had just bought a X1 and installed wayfinder...but I reinstalled Windows.. but thanks for the help, from now on I can sleep better at nights

btw..what is a rollback??
Just run "C:\Windows\System32\rstrui.exe"

I think it is bad that Sony Eriksson supply a software with the phone that makes your computer unusable.

/Mike
 

My Computer

Messages
1
#5
Hi,
I have the same problem with cpu usage due to this wayfinder on xperia1.
I just wanted to know is there any other way of getting off this high cpu usage except windows reinstalling or rollback (i can't rollback so long, so it's not working for me anymore)?
Any ideas?
Thanx for advance!
 

My Computer

Leahcim

New Member
Messages
3
#6
Hi,
I have the same problem with cpu usage due to this wayfinder on xperia1.
I just wanted to know is there any other way of getting off this high cpu usage except windows reinstalling or rollback (i can't rollback so long, so it's not working for me anymore)?
Any ideas?
Thanx for advance!
Sorry but I have not find any other solution than rollback.

/Mike
 

My Computer

murof

New Member
Messages
1
#7
Hi
Just to let you know I also had this problem and after seeing your post, removed the Wayfinder application, but that had no effect. In the end I rolled back changes to before the Wayfinder was installed and this seems to have sorted the problem. The Xperia is a fantastic piece of kit, shame the software screws up the PC.
 

My Computer

Messages
2,049
#11
If you have sometimes this messagge

DComLaunch has stopped working and windows has to reboot (something like that)
this kind of errors should be visible in Event Viewer;You have to find in Application and System section all errors concern DComLaunch or svchost.exe,you should also check in Problem reports and solutions
 

My Computer

Messages
2,049
#14
Probably many GPS navigators cause this - for example I've just found accidents where Wayfinder cause these things - even more:It modify settings of service Windows Management Instrumentation Settings so even in safe mode you have high CPU Usage,uninstalling this program is not enough to resolve this trouble.

May this anyone help:
Sysinternals Forums - Services.exe and wmiprvse.exe consume 25% CPU - Page 4

But it not always work also :(
 

My Computer

Anjin

New Member
Messages
2
#15
Hi Flavius. I think you my have misunderstood me. My English is not native so maybe I was unclear. I had Wayfinder installed and then uninstalled and still had the CPU Usage problem. But then after downloading a new version of Wayfinader, released 20 february, and installing it. The problem with CPU usage dissapeared. Maybe the same thing can help others with the same problem.
 

My Computer

Messages
2,049
#16
Hi Flavius. I think you my have misunderstood me. My English is not native so maybe I was unclear. I had Wayfinder installed and then uninstalled and still had the CPU Usage problem. But then after downloading a new version of Wayfinader, released 20 february, and installing it. The problem with CPU usage dissapeared. Maybe the same thing can help others with the same problem.
Interesting what you said...I just trying to help any guy on one polish forum with fighting high CPU usage due to Wayfinder.Of course we'll try your advice and let you know about results.Thanks ;)
 

My Computer

bolun

New Member
Messages
1
#18
Hi Anjin, the same happened to my PC after I have installed my X1 software.
I can not find the updated software. Could you please let me know where I can get the updated Map Loader? May be you can send it to me by mail or give me the link?
My mail is andreybol_at_yahoo.com.

THANKS A LOT!
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)