• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved DHCP Client/Diagnostics Policy Service not running

Messages
213
#1
Running 32 bit Vista Home Basic SP1.

I cannot get online. When I hover the mouse over the network icon in the notification area, it reads, "Connection status unknown. The dependency service or group failed to start". When I try to diagnose the problem, I can't because the Diagnostics Policy Service is not running. When I try to Start the service, access is denied (Error 5). Same scenario for the service DHCP Client.

Meanwhile, I keep getting warnings that my firewall is not enabled. When I try to enable it, I get a message that the Security Center can't turn it on. Windows Firewall is not listed in services.msc.

I ran a full Malwarebytes scan and it found nothing wrong.

I did a system restore to several days before the problem, but even though the restore completed successfully, it didn't change my (non)results.

The Network and Sharing Center does not display the familiar PC monitor icon with a line to the Network and another line going from the Network to the Internet. Instead it just has the word Unknown with the caption the depencency or groiup failed to start

I am at a loss. How could a PC that was working just fine all of a sudden turn to sh*t?

I have heard that this might be due to a permissions issue, but when I use regedit and navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services and right click on Dhcp, select Permissions, I get an error when I try to add anything (either Local Service or Network Service). The msg is
c:\Windows\system32\adsldp.dll is either not designed to run on Windows or it contains an error. Try installing the program again... yadda yadda yadda.

I have run sfc /scannow as well as chkdsk /f. Scannow reported that it found some problems but was unable to fix all of them. Chkdsk found and corrected about 10 errors, but neither of these programs helped with the issue.

Additionally I have downloaded and installed Process Monitor on the PC, but the amount of information displayed is overwhelming, and I'm not sure what to check. Every time I try to start DHCP I get about 200 lines of info on the screen.
 
Last edited:

My Computer

Messages
213
#2
I think 29 hours without a response means that nobody has any more of a clue than me about this. Here is some additional information if it helps a lightbulb to go off in ANYONE's head (my light bulb has been merely flickering for days):

When I open a command prompt and run ipconfig /all, I get what is in the attachment. As you can hopefully see DHCP is enabled. So why isn't it running? And why can't I start it? Is there anything else you see on the attachment that looks like it would prevent me from connecting to the internet?


I realize, of course, that the ip address of 169.254. isn't really going to get me anywhere, but I assumed that was a function of DHCP not being started. Ditto for the default gateway of all zeroes.

Is it possible that this behavior could simply be the result of a bad NIC card?

Can I possibly run an in-place upgrade from Vista Home Basic to Vista Home Premium? If it's a Dell PC and I have the Dell Premium CD will it ask me for the product key? If so, will the key on the Basic PC work?
 
Last edited:

My Computer

Messages
213
#3
I was really hoping to get to 200 reads without a response... And I think it's been close to a week since I originally posted, but I got the answer.

Two little commands, run as an administrator
net localgroup administrators localservice /add
net localgroup administrators networkservice /add

Took a lot of work, and a lot of searching, a lot of trial and error, but I finally stumbled on these commands. Exactly the kind of help I would have expected from a forum like this. Sigh...
 

My Computer

Casey04

New Member
Messages
1
#4
I am running Windows 7 x64 Pro. I came back today after leaving my computer on the entire weekend and I was experiencing the exact same problem with not being able to turn on that service even though I was administrator and the only user of this computer.

I still have no idea how this happened over the weekend while I was not home. No one was using my computer. My wireless network was functioning just fine, and yet my wired connection was unavailable and "unknown".

Anyhow, those commands worked like a charm.

I just want to say that you helped me a lot. Thank you very much for your time and effort in solving this infuriatingly random error.
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)