• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Different Warcraft 3 Frozen Throne Problem in Windows 7

jalf

New Member
#1
Okay, the problem is, after installing my Warcraft 3 Frozen Throne on my Windows 7 beta, 7000build. I can run War3.exe after the installation. When I restarted my computer, the problem starts here.

Every time I open my War3, It minimizes on my task bar. When I click it again, it maximizes for around 1 second then minimizes again. I know its running fine because I can hear the sounds of the program and I can see the menu for 1 second.

I'm wondering if this is fixable. I search the internet for similar problem but it looks like I'm the only one having this kind of problem.


I tried Updating my Video Card driver, I think I have the latest.


Thanks in advance whoever can fix this problem.

Tried system restore, no result.

Reinstalling my War3, it works. But, whenever I restart my computer, the problem appear again. I need to shutdown my computer.


Here is my Computer specification.

System Information
Operating System: Windows 7 Ultimate 32-bit (6.1, Build 7000) (7000.winmain_win7beta.081212-1400)
Processor: Intel(R) Core(TM)2 Quad CPU Q9300 @ 2.50GHz (4 CPUs), ~2.3GHz
DirectX Version: DirectX 11
Physical RAM: 3581MB
Virtual Memory: 2047MB

Video Information
Video Card: NVIDIA NVIDIA GeForce 9600 GT (Prerelease - WDDM 1.1)
Video Memory: 2035 MB
Chip Type: GeForce 9600 GT
Driver Filename: nvd3dum.dll,nvwgf2um.dll
Driver Version: 7.15.0011.7923 | 11/20/2008 21:25:00
Disp Settings: Generic PnP Monitor | 1024 x 768 (32 bit) (75Hz)

Audio Information
Audio Device: Speakers (High Definition Audio Device)
Driver Name: HdAudio.sys
Driver Version: 6.01.7000.0000 | 12/13/2008 10:47:51
Default Sound Playback: true
Default Voice Playback: true
 

jalf

New Member
#2
Done. I fixed it.

The problem is, with the windows 7 desktop Composition.

Here's the solution.

Go to the warcraft installation folder.
Select War3.exe then, right click it, properties.

Compatibility -> check disable desktop composition.

And no more, minimizing problem.
 
#3
jalf <guest@xxxxxx-email.com> wrote in
news:9f9e4cbc8bb584a47e5db8873828ee10@xxxxxx-gateway.com:

> Go to the warcraft installation folder.
> Select War3.exe then, right click it, properties.
>
> Compatibility -> check -disable desktop composition.-
>
> And no more, minimizing problem.
Good find, did you send feedback to Microsoft?

--
Joe
 

jalf

New Member
#4
No. And I think, Microsoft intentionally added that option because, it can't be fixed on their side. So, I think, it's up to the game producer to add some compatibility in their program.

It's just a thought anyway.
 
#5
jalf <guest@xxxxxx-email.com> wrote in
news:b2a216454dbce3db8d0ef9b5a4c5f815@xxxxxx-gateway.com:

>
> No. And I think, Microsoft intentionally added that option because, it
> can't be fixed on their side. So, I think, it's up to the game producer
> to add some compatibility in their program.
>
> It's just a thought anyway.
Vista has the same "feature", Desktop Composition, but WC3:FT works just
fine on Vista, so this is probably a bug introduced in Windows 7, could be
based on your hardware or something else, but either way when you observe
something click the send feedback link.

Just my thought anyway.

--
Joe
 
A
#6
not necessarily. I run TFT in Vista and i have the same problem. The
solutuion is the same turn off desktop composition.

"Joe" wrote:

> jalf <guest@xxxxxx-email.com> wrote in
> news:b2a216454dbce3db8d0ef9b5a4c5f815@xxxxxx-gateway.com:
>

> >
> > No. And I think, Microsoft intentionally added that option because, it
> > can't be fixed on their side. So, I think, it's up to the game producer
> > to add some compatibility in their program.
> >
> > It's just a thought anyway.
>
> Vista has the same "feature", Desktop Composition, but WC3:FT works just
> fine on Vista, so this is probably a bug introduced in Windows 7, could be
> based on your hardware or something else, but either way when you observe
> something click the send feedback link.
>
> Just my thought anyway.
>
> --
> Joe
>
 
#7
*bump*
guys please help me i got the same problem...
it doesnt work with "disable desktop composition"

Is there anyone who solute the prob in another way?
 

karam

New Member
#8
i need some help plz i have everything exactly like u all the computer information and stuff like windows ultimate and 32 bit and everything but when i click on frozen throne it stops responding and it freezes. ive tried running as adminstator and compatibilty windows xp(2) and windows xp(3) but no use it just stops responding when i try to open it. plz help me
 
#9
I'm having a problem except Im using windows 7(Signed up on the wrong forum) I will be playing a game on battle.net(warcraft 3 TFT) I will for no reason lose my connection to battle.net,And when I try to go back on it will say "This cd key is currently in use by sheldon on warcraft 3 reign of chaos" I am sheldon and I'm playing battle.net through the frozen throne,I've run it in compatibility mode for vista sp2(isnt a windows 7) and disabled desktop composition,Should I try running as an administrator?I'm getting discouraged.Please help me Obi Wan Kenobi.