Disable Security Settings Check Feature && GPEdit

mousetopher

New Member
Hello everyone. I just got a new laptop running Vista Home Premium x64, and it's my first experience with both Vista and an x64 OS.

I've changed the security settings in IE7 to a custom level, and now I get the notification bar saying "Your current security settings put your computer at risk. etc." I know this can be disabled via gpedit.mcs but of course Vista Home doesn't include that feature. So, a couple questions.

Nobody here seems to know much about getting GPedit to work in Vista Home, so I won't even touch that. However, I did see mention of the Microsoft speadsheet that lists all the various group policy settings and their corresponding registry entries. I found the "Disable Security Settings Check Feature" entry, but now I'm not sure what to do with it.

HKLM\Software\Policies\Microsoft\Internet Explorer\Security!DisableSecuritySettingsCheck
HKCU\Software\Policies\Microsoft\Internet Explorer\Security!DisableSecuritySettingsCheck

I can navigate to the Microsoft folder in regedit, but that's where the trail ends. Do I need to create a key or something? I don't have much experience with the registry, and I really want this notification bar gone. Help please? :)


cheers everyone!
 

joel406

Senior Member
Vista Guru
Hello mousetopher. You probably allowed something in the security settings that you should have just set to prompt. Scripts, Activex, something that will tolerate nothing beyond prompt. Allowing anything unsigned more permissions then prompt will set off that warning. Reset them to default and then your security warnings should disappear.

Hope it helped. If not I probably read it wrong.
 

mousetopher

New Member
*Sigh* I knew I should've added:

Please don't advise me to reset Internet Explorer's security settings to default... I changed them for a reason.

Thank you for your reply, Joel, but no, that's not what I want to accomplish. I just want help understanding how to implement the group policy setting "Disable Security Check Feature" via the registry.
 

sclancy

New Member
Hello everyone. I just got a new laptop running Vista Home Premium x64, and it's my first experience with both Vista and an x64 OS.

I've changed the security settings in IE7 to a custom level, and now I get the notification bar saying "Your current security settings put your computer at risk. etc." I know this can be disabled via gpedit.mcs but of course Vista Home doesn't include that feature. So, a couple questions.

Nobody here seems to know much about getting GPedit to work in Vista Home, so I won't even touch that. However, I did see mention of the Microsoft speadsheet that lists all the various group policy settings and their corresponding registry entries. I found the "Disable Security Settings Check Feature" entry, but now I'm not sure what to do with it.

HKLM\Software\Policies\Microsoft\Internet Explorer\Security!DisableSecuritySettingsCheck
HKCU\Software\Policies\Microsoft\Internet Explorer\Security!DisableSecuritySettingsCheck

I can navigate to the Microsoft folder in regedit, but that's where the trail ends. Do I need to create a key or something? I don't have much experience with the registry, and I really want this notification bar gone. Help please? :)


cheers everyone!

Mousetopher your a GENIUS!!!!
You answered the question and didn't even know it.
The regeistry string you posted is it. BUT,, you have to creat a new "DWORD" that is called "DisableSecuritySettingsCheck" then set the value=1

BANG WAM!!! Problem solved, information bar is TOAST for good.

So here is the run down thanks to mousetopher;
Follow this string: HKLM\Software\Policies\Microsoft\Internet Explorer\Security
Right click on security and select Creat new DWORD;
Type DisableSecuritySettingsCheck
Now Change the value to equal 1 instead of 0
Problem gone. I have investigated this for 2 hours now and no luck but mousetophers post of a script line gave it away, the STRING does not exist, You have to create it, then set it to active witch is denoted by a value of 1

You may want to do it for
HKCU as well though I didn't have to .

And also, This is for Vista Home useless version.
If the String exists then you must have Vista Pro in witch just set the value to 1
What a joke , Microsoft "in the head" rides again.

I am going to post this on a separate thread but will give credits to mousetpher if you guys don't mind. Seriosly this is the only fix out on the net for this.
 
Last edited:
Top