domain account user vs local account user in vista

pbodavula

New Member
Hi,

We are creating a PDF file in login user's local application folder (C:\Users\%username%\AppData\Local\folder1) through a custom .Net application and displaying the created pdf file in application.

The above functionality is working for users who are part of domain and added to local vista machine as users (both for administrator and standard user accounts).
The same is not working for local users (both administrator and standard user accounts created in vista box).

File is getting created for any user under their local appdata folder and can able to open from that location, but not displaying from app in case of local system users (admin or standard type).

Can anyone help me what security settings differ between domain users vs local users in vista business 32 bit OS?

Thanks
Padmaja
 

pbodavula

New Member
Policy that is actually causing the problem (or lack thereof) is corresponds to Internet Options control panel, Connections tab, Lan Settings button: Use Automatic Configuration settings.
Having this turned on causes IE to load a configuration file prepared by IT department which makes a whole lot of configuration changes to IE, including remapping the security zones. We can test this by unchecking this option (the default state).
Since the machine is in domain and since we are testing with domain users accounts, I have monitored domain controller pushing down a bunch of policy settings which relax the IE security settings, causing the reports to display.
First, domain settings will resync over time and this checkbox will keep getting turned back on automatically. So you can’t really turn this off, it won’t stay off. I would feel better just testing local accounts, but since the computer is also a member of the domain, machine-specific policies are applied by the domain as well.
 
Top