dual-monitor: apps starting in secondary screen instead of primary

anfrey

New Member
i've got a minor issue where some apps choose to launch on the secondary screen, rather than my primary. i believe it is because my secondary is actually to the left of the primary (it is a TV that is physically to the left of me). is there a way to tell apps which screen to launch in? i'd rather have all my apps launch on the primary display.
 

My Computer

johngalt

Antidisestablishmentarianist
Vista Guru
Vista goes screwy with this sometimes - but mostly, I have noticed, when I run WMC and it opens in the window that the app is in.

Try running WMC on your TV so that it forces the app to the other 'monitor' and then hit the start button on your KB, freeing your mouse from WMC, and then go to the other monitor and close the app(s). Then close WMC and see if the app opens back on the TV or in the monitor.
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro X64 Insider Preview (Skip Ahead) latest build
    Manufacturer/Model
    The Beast Model V (homebrew)
    CPU
    Intel Core i7 965 EE @ 3.6 GHz
    Motherboard
    eVGA X58 Classified 3 (141-GT-E770-A1)
    Memory
    3 * Mushkin 998981 Redline Enhanced triple channel DDR3 4 GB CL7 DDR3 1600 MHz (PC3-12800)
    Graphics Card(s)
    eVGA GeForce GTX 970 SSC ACX 2.0 (04G-P4-3979-KB)
    Sound Card
    Realtek HD Audio (onboard)
    Monitor(s) Displays
    2 * Lenovo LT2323pwA Widescreeen
    Screen Resolution
    2 * 1920 x 1080
    Hard Drives
    SanDisk Ultra SDSSDHII-960G-G25 960 GB SATA III SSD (System)
    Crucial MX100 CT256MX100SSD1 256GB SATA III SSD (User Tree)
    2 * Seagate Barracuda 7200.12 ST31000528AS 1TB 7200 RPM SATA II Mech. HD
    Seagate ST1500DL001-9VT15L Barracuda 7200.12 1.5 TB S
    PSU
    Thermaltake Black Widow TX TR2 850W 80+ Bronze Semi-Mod ATX
    Case
    ThermalTake Level 10 GT (Black)
    Cooling
    Corsair H100 (CPU, dual 140 mm fans on radiator) + Air (2 *
    Mouse
    Logitech MX Master (shared)
    Keyboard
    Logitech G15 (gen 2)
    Internet Speed
    AT&T Lightspeed Gigabit duplex
  • Operating System
    Sabayon Linux (current, weekly updates, 5.1.x kernel)
    Manufacturer/Model
    Lenovo ThinkPad E545
    CPU
    AMD A6-5350M APU
    Motherboard
    Lenovo
    Memory
    8 GB
    Graphics card(s)
    Radeon HD (Embedded)
    Sound Card
    Conextant 20671 SmartAudio HD
    Monitor(s) Displays
    Lenovo 15" Matte
    Screen Resolution
    1680 * 1050
    Hard Drives
    INTEL Cherryvill 520 Series SSDSC2CW180A 180 GB SSD
    PSU
    Lenovo
    Case
    Lenovo
    Cooling
    Lenovo
    Mouse
    Logitech MX Master (shared) | Synaptics TouchPad
    Keyboard
    Lenovo
    Internet Speed
    AT&T LightSpeed Gigabit Duplex

Kotuku

Power User
i've got a minor issue where some apps choose to launch on the secondary screen, rather than my primary. i believe it is because my secondary is actually to the left of the primary (it is a TV that is physically to the left of me). is there a way to tell apps which screen to launch in? i'd rather have all my apps launch on the primary display.
If you right click on desktop and select DISPLAY SETTINGS, you can drag the visible screens around to match your Left Right combination (I have 2 screens with primary as the #1 on the right). This should be set as the Main Monitor and Extend the desktop onto this monitor, both those options are greyed out on the #1 monitor. In the drop down box, bring up the #2 monitor or just click its icon. That should have only the "Extend the desktop to this monitor" ticked.

If an app opens on the wrong screen, drag it to the correct screen and close it down. Then when it opens again, it should open on the one you dragged it to
 
Last edited:

My Computer

System One

  • CPU
    Intel Core2 Extreme Quad Core
    Motherboard
    XFX MB-N790-IUL9 NFORCE 790 U
    Memory
    4 Gb (2x2) Gskill DD3 1600
    Graphics Card(s)
    XFX 9800GX2 Black Ed. 1Gb DD3
    Hard Drives
    2x WD Raptor 150 Gb SATA 10000rpm in Raid0 plus 500 Gb Seagate 7200rpm SATA2
Top