Error 1935 when installing Visual C++ 2008

davehem

Member
I have just bought NFS Hot Pursuit and it needs to install Visual C++ 2008 Redistributable with service pack 1. When tyring to install i get the error which i have added as an attachment.
I have tried removing bits from COMPONENTS on regedit but that didn't work.

Really need some help, this is driving me nuts!!
 

Attachments

My Computer

davehem

Member
Just thought i would add the errors shown in the cbs.log file as well:

2011-01-05 22:43:43, Error CSI 00000030 (F) STATUS_SXS_TRANSACTION_CLOSURE_INCOMPLETE #7260# from CCSDirectTransaction::PerformChangeAnalysis(...)[gle=0xd0150024]
2011-01-05 22:43:43, Error CSI 00000031 (F) STATUS_SXS_TRANSACTION_CLOSURE_INCOMPLETE #7259# from CCSDirectTransaction::PrepareForCommit(...)[gle=0xd0150024]
2011-01-05 22:43:43, Error CSI 00000032 (F) STATUS_SXS_TRANSACTION_CLOSURE_INCOMPLETE #7258# from CCSDirectTransaction::ExamineTransaction(...)[gle=0xd0150024]
2011-01-05 22:43:43, Error CSI 00000033 (F) STATUS_SXS_TRANSACTION_CLOSURE_INCOMPLETE #7257# from CCSDirectTransaction_IRtlTransaction::ExamineTransaction(...)[gle=0xd0150024]
2011-01-05 22:43:43, Info CSI 00000034 Changelist shadowed missing its manifest - policy.9.0.Microsoft.VC90.MFC, Version = 9.0.21022.8, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope neutral, PublicKeyToken = {l:8 b:1fc8b3b9a1e18e3b}, Type = [l:24{12}]"win32-policy", TypeName neutral, PublicKey neutral
2011-01-05 22:43:43, Error CSI [email protected]/1/5:22:43:43.998 (F) d:\longhorn\base\wcp\componentstore\csd_winners.cpp(953): Error STATUS_SXS_TRANSACTION_CLOSURE_INCOMPLETE originated in function OriginateManifestsMissingError expression: (null)
[gle=0x80004005]
2011-01-05 22:43:46, Error CSI 00000036 (F) STATUS_SXS_TRANSACTION_CLOSURE_INCOMPLETE #7404# from CCSDirectTransaction::PerformChangeAnalysis(...)[gle=0xd0150024]
2011-01-05 22:43:46, Error CSI 00000037 (F) STATUS_SXS_TRANSACTION_CLOSURE_INCOMPLETE #7403# from CCSDirectTransaction::PrepareForCommit(...)[gle=0xd0150024]
2011-01-05 22:43:46, Error CSI 00000038 (F) STATUS_SXS_TRANSACTION_CLOSURE_INCOMPLETE #7402# from CCSDirectTransaction::GenerateComponentChangeList(...)[gle=0xd0150024]
2011-01-05 22:43:46, Error CSI 00000039 (F) STATUS_SXS_TRANSACTION_CLOSURE_INCOMPLETE #7401# from Windows::COM::CPendingTransaction::ExtractInformationFromRtlTransaction(...)[gle=0xd0150024]
2011-01-05 22:43:46, Error CSI 0000003a (F) HRESULT_FROM_WIN32(ERROR_SXS_TRANSACTION_CLOSURE_INCOMPLETE) #7149# from Windows::COM::CPendingTransaction::IStorePendingTransaction_Analyze(...)[gle=0x8007371b]
2011-01-05 22:43:46, Error SXS Analyze Transaction failed with 0x8007371b
 

My Computer

Lottiemansion

Vista Guru
Gold Member

My Computer

System One

  • Manufacturer/Model
    HP-Pavilion m9280.uk-a
    CPU
    2.30 gigahertz AMD Phenom 9600 Quad-Core
    Motherboard
    ASUSTek Computer INC. NARRA3 3.02
    Memory
    3582 Megabytes Usable Installed Memory (4 Gig)
    Graphics Card(s)
    ASUS NVIDIA Geforce GTS450
    Sound Card
    Realtek High Definition 7.1 Audio (HP drivers)
    Monitor(s) Displays
    HP w2408 24.0" (Dual monitor)
    Screen Resolution
    1920 * 1200, 1920 * 1200
    Hard Drives
    3*500 Gigabytes Usable Hard Drive Capacity
    Plus 2x USB (160Gig each) external HDD
    BluRay & DVD Weiters
    HL-DT-ST BD-RE GGW-H20L SCSI CdRom (Bluray RW) Device
    AlViDrv BDDVDROM SCSI CdRom (Blueray) Device
    TSSTcorp CDDVDW TS-H653N SCSI CdRom
    Internet Speed
    40 Meg

davehem

Member
I have tried installing x64 package and SP1 and feature pack for it was well and these install fine its just just seems to be the x86 version. i have uninstalled all traces of it and reinstalled it straight from microsoft but with no luck.
i really don't want to do a repair install as my pc has vista sp2 and my vista cd is sp1. which means me uninstalling sp2 then doing repair install. i dont know a lot about this so i'd rather avoid it if i can.
 

My Computer

Lottiemansion

Vista Guru
Gold Member

My Computer

System One

  • Manufacturer/Model
    HP-Pavilion m9280.uk-a
    CPU
    2.30 gigahertz AMD Phenom 9600 Quad-Core
    Motherboard
    ASUSTek Computer INC. NARRA3 3.02
    Memory
    3582 Megabytes Usable Installed Memory (4 Gig)
    Graphics Card(s)
    ASUS NVIDIA Geforce GTS450
    Sound Card
    Realtek High Definition 7.1 Audio (HP drivers)
    Monitor(s) Displays
    HP w2408 24.0" (Dual monitor)
    Screen Resolution
    1920 * 1200, 1920 * 1200
    Hard Drives
    3*500 Gigabytes Usable Hard Drive Capacity
    Plus 2x USB (160Gig each) external HDD
    BluRay & DVD Weiters
    HL-DT-ST BD-RE GGW-H20L SCSI CdRom (Bluray RW) Device
    AlViDrv BDDVDROM SCSI CdRom (Blueray) Device
    TSSTcorp CDDVDW TS-H653N SCSI CdRom
    Internet Speed
    40 Meg

niemiro

Banned
Hello!

I will try my very best to fix this error, but I tell you now that it won't be easy, if we ever get it fixed, as there is actually no specific fix yet. Please try to install VC++ 2008 SP1 now, and note down the approximate time you started the install (to the nearest 5 minutes or so, if you can, so I can easily find it in the log, after the rest of this post)

First please run the System Update Readiness Tool. This usually takes 15-30 minutes to complete. See here, download it, and install it. Description of the System Update Readiness Tool for Windows Vista, for Windows Server 2008, for Windows 7, and for Windows Server 2008 R2

Right, now please run steps 1, 2A, 3 (about 15 minutes), 4, 5, and then Step 1 from the top yellow box, but only follow this last one if Integrity Violations were found. Please upload the new sfcdetails.txt from your Desktop. System Files - SFC Command

Now please navigate to C:\Windows\Logs, and copy the CBS folder to your Desktop. Right click on it > Send to > Compressed (zipped) archive. Upload that zip file here please.

Thanks!

Richard
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS 420
    CPU
    Intel Core 2 Quad Q9300 2.50GHz
    Motherboard
    Stock Dell 0TP406
    Memory
    4 gb (DDR2 800) 400MHz
    Graphics Card(s)
    ATI Radeon HD 3870 (512 MBytes)
    Sound Card
    Onboard
    Monitor(s) Displays
    1 x Dell 2007FP and 1 x (old) Sonic flat screen
    Screen Resolution
    1600 x 1200 and 1280 x 1204
    Hard Drives
    1 x 640Gb (SATA 300)
    Western Digital: WDC WD6400AAKS-75A7B0

    1 x 1Tb (SATA 600)
    Western Digital: Caviar Black, SATA 6GB/S, 64Mb cache, 8ms
    Western Digital: WDC WD1002FAEX-00Z3A0 ATA Device
    PSU
    Stock PSU - 375W
    Case
    Dell XPS 420
    Cooling
    Stock Fan
    Mouse
    Advent Optical ADE-WG01 (colour change light up)
    Keyboard
    Dell Bluetooth
    Internet Speed
    120 kb/s
    Other Info
    ASUS USB 3.0 5Gbps/SATA 6Gbps - PCI-Express Combo Controller Card (U3S6)

davehem

Member
Sorry might be being thick here but i have done 1, 2a then 3 is press enter which might take time to finish. Pressing enter just brings up a new command line. have i done something wrong??
 

My Computer

niemiro

Banned
Hello!

No worries!

You want to run scannow to scan all files. Have you typed in sfc /scannow before pressing enter? Your Command Line should look exactly like this:

Code:
Microsoft Windows [Version 6.0.6002]
Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

C:\Users\Richard>sfc /scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 25% complete.
Good luck!

Richard
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS 420
    CPU
    Intel Core 2 Quad Q9300 2.50GHz
    Motherboard
    Stock Dell 0TP406
    Memory
    4 gb (DDR2 800) 400MHz
    Graphics Card(s)
    ATI Radeon HD 3870 (512 MBytes)
    Sound Card
    Onboard
    Monitor(s) Displays
    1 x Dell 2007FP and 1 x (old) Sonic flat screen
    Screen Resolution
    1600 x 1200 and 1280 x 1204
    Hard Drives
    1 x 640Gb (SATA 300)
    Western Digital: WDC WD6400AAKS-75A7B0

    1 x 1Tb (SATA 600)
    Western Digital: Caviar Black, SATA 6GB/S, 64Mb cache, 8ms
    Western Digital: WDC WD1002FAEX-00Z3A0 ATA Device
    PSU
    Stock PSU - 375W
    Case
    Dell XPS 420
    Cooling
    Stock Fan
    Mouse
    Advent Optical ADE-WG01 (colour change light up)
    Keyboard
    Dell Bluetooth
    Internet Speed
    120 kb/s
    Other Info
    ASUS USB 3.0 5Gbps/SATA 6Gbps - PCI-Express Combo Controller Card (U3S6)

niemiro

Banned
I have run sfc /scannow but it took about 2 seconds to complete with no violations found. should this have taken longer??
Hello!

Yes, it should have taken much longer. This sounds like it is not your fault in any way, but you have some very bad corruption, which we may/may not be able to fix. Please continue onto the LOGS step.

Thanks!

Richard

P.S. I am going to do a little bit of work, and then bed now. I will look at your logs tomorrow. Thanks for your patience!
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS 420
    CPU
    Intel Core 2 Quad Q9300 2.50GHz
    Motherboard
    Stock Dell 0TP406
    Memory
    4 gb (DDR2 800) 400MHz
    Graphics Card(s)
    ATI Radeon HD 3870 (512 MBytes)
    Sound Card
    Onboard
    Monitor(s) Displays
    1 x Dell 2007FP and 1 x (old) Sonic flat screen
    Screen Resolution
    1600 x 1200 and 1280 x 1204
    Hard Drives
    1 x 640Gb (SATA 300)
    Western Digital: WDC WD6400AAKS-75A7B0

    1 x 1Tb (SATA 600)
    Western Digital: Caviar Black, SATA 6GB/S, 64Mb cache, 8ms
    Western Digital: WDC WD1002FAEX-00Z3A0 ATA Device
    PSU
    Stock PSU - 375W
    Case
    Dell XPS 420
    Cooling
    Stock Fan
    Mouse
    Advent Optical ADE-WG01 (colour change light up)
    Keyboard
    Dell Bluetooth
    Internet Speed
    120 kb/s
    Other Info
    ASUS USB 3.0 5Gbps/SATA 6Gbps - PCI-Express Combo Controller Card (U3S6)

davehem

Member
Here are the logs. 2011-01-07 20:15:04 should be the start.

Thanks a lot for your help with this. looking forward to hearing your thoughts (good or bad)

Dave
 

Attachments

My Computer

niemiro

Banned
Hello Dave!

Sorry for the delay, normal life got in the way.

You certainly have some sort of bad corruption there. Error 1935 is very often caused by anti-malware software preventing the install. Please temporarily disable all real-time anti-malware tools, in particular Tea-Timer and Webroot.

Good luck!

Richard
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS 420
    CPU
    Intel Core 2 Quad Q9300 2.50GHz
    Motherboard
    Stock Dell 0TP406
    Memory
    4 gb (DDR2 800) 400MHz
    Graphics Card(s)
    ATI Radeon HD 3870 (512 MBytes)
    Sound Card
    Onboard
    Monitor(s) Displays
    1 x Dell 2007FP and 1 x (old) Sonic flat screen
    Screen Resolution
    1600 x 1200 and 1280 x 1204
    Hard Drives
    1 x 640Gb (SATA 300)
    Western Digital: WDC WD6400AAKS-75A7B0

    1 x 1Tb (SATA 600)
    Western Digital: Caviar Black, SATA 6GB/S, 64Mb cache, 8ms
    Western Digital: WDC WD1002FAEX-00Z3A0 ATA Device
    PSU
    Stock PSU - 375W
    Case
    Dell XPS 420
    Cooling
    Stock Fan
    Mouse
    Advent Optical ADE-WG01 (colour change light up)
    Keyboard
    Dell Bluetooth
    Internet Speed
    120 kb/s
    Other Info
    ASUS USB 3.0 5Gbps/SATA 6Gbps - PCI-Express Combo Controller Card (U3S6)
Top