Error 5: Access is denied (when starting services)

hsrstud

New Member
Recently, I started have trouble with my Internet-related system services. I'm able to connect to the Internet fine, but my Internet connection icon in the system tray has a big red X. When I hover over the icon, I see the following notice:

"Connection status: unknown

The dependency service or group failed to start."

When I go into Services, I see that a bunch of the Internet-related services have not been started, even though some of them are set to Automatic. For instance, the DHCP Client service is not running, but it is set to Automatic. The same holds true for the Diagnostic Policy Service listed below the DHCP Client service. If I try to start either of these service, I receive the following notice:

"Windows could not start the DHCP Client (or DPS) service on Local Computer.

Error 5: Access is denied."

My user account has administrative rights. I've search around the Internet for a resolution to this issue. A lot of people seem to have encountered this situation, but I haven't found anyone who has been able to resolve the problem. Hopefully, someone in this forum can help.

Thanks!
 

My Computer

mblack

Member
Hi there it sounds as though you may have something nasty lurking from within and you may need to run some malware programs and anti spyware, but first of all if you go to the site that i have shown here Black Viper's Web Site it shows you a full list of all services that you have rtunning in what ever OS you have, it lists from default right through to the tweaked versions, it also tells you how to stop and restart your services if your having problems, so give it a go failing that pop back to the forums and see if there's any other solutions to help you. But i would also like to point out that if BV's site does help after doing everything and resetting your services i would still run some malware and anti spyware programs aswell to see if your infected in any way. Good Luck mblack
 

My Computer

hsrstud

New Member
Thanks for your help mblack.

I ran some of my anti-spyware programs a few days ago and found one critter that didn't look too good. Some kind of bot, which was successfully removed. I haven't had spyware lodge itself in my computer for years, so it kind of surprised me. Perhaps this caused the problem.

I tried the default Vista SP2 services registry patch on Black Viper's site to no avail. I didn't see any information on how restart services when having problems similar to mine, but there is a lot of information on the site and I could have very well missed this. I posted the same question in BV's forum. Hopefully, someone there will be able to point me in the right direction.
 

My Computer

delphin

Eager to learn
Vista Pro
do u have administrative rights on your computer, are u able to turn of UAC?
 

My Computer

System One

  • Manufacturer/Model
    Wipro
    Motherboard
    Intel dq35j0
    Memory
    8 Gb
    Graphics Card(s)
    inter express chipset
    Sound Card
    Realtek
    Monitor(s) Displays
    Wipro
    Screen Resolution
    1024*768
    Hard Drives
    500 gb
    Mouse
    Dell
    Keyboard
    DELL
    Internet Speed
    100 mbps(office lan)

hsrstud

New Member
Yes, I have administrative rights and am able to turn off UAC. I also tried starting the services when UAC was turned off, but no luck.
 

My Computer

delphin

Eager to learn
Vista Pro

My Computer

System One

  • Manufacturer/Model
    Wipro
    Motherboard
    Intel dq35j0
    Memory
    8 Gb
    Graphics Card(s)
    inter express chipset
    Sound Card
    Realtek
    Monitor(s) Displays
    Wipro
    Screen Resolution
    1024*768
    Hard Drives
    500 gb
    Mouse
    Dell
    Keyboard
    DELL
    Internet Speed
    100 mbps(office lan)

delphin

Eager to learn
Vista Pro
Try this link

Your problem addressed there..:)
 
Last edited:

My Computer

System One

  • Manufacturer/Model
    Wipro
    Motherboard
    Intel dq35j0
    Memory
    8 Gb
    Graphics Card(s)
    inter express chipset
    Sound Card
    Realtek
    Monitor(s) Displays
    Wipro
    Screen Resolution
    1024*768
    Hard Drives
    500 gb
    Mouse
    Dell
    Keyboard
    DELL
    Internet Speed
    100 mbps(office lan)

hsrstud

New Member
The link now leads me to a download page for HijackThis. I'm wondering if you are recommending I run this program on my computer or if my issue is addressed somewhere in the comments.
 

My Computer

delphin

Eager to learn
Vista Pro

My Computer

System One

  • Manufacturer/Model
    Wipro
    Motherboard
    Intel dq35j0
    Memory
    8 Gb
    Graphics Card(s)
    inter express chipset
    Sound Card
    Realtek
    Monitor(s) Displays
    Wipro
    Screen Resolution
    1024*768
    Hard Drives
    500 gb
    Mouse
    Dell
    Keyboard
    DELL
    Internet Speed
    100 mbps(office lan)

hsrstud

New Member
I don't have Windows Server installed, but I tried the suggested solution, and still no go. Other services are having trouble as well, so I'm guessing my problem may be more complicated. Maybe I should just reinstall Vista?
 

My Computer

Try these steps
1. Reboot
2. While booting, keep pressing f8 until a mode screen comes up
3. Select safe mode
4. Once it has finished booting run every fix program
5. Repeat until it works
Dosent work? Your firewall program might be blocking internet actions. Turn off your firewall
Dosent work again? Your computer dosent have a internet service enabled. Enable it
 

My Computer

System One

  • Manufacturer/Model
    Old 2003 Medion computer
    Motherboard
    See "System Manufacturer/Model Number"
    Memory
    2.00 GB
    Hard Drives
    3
    Internet Speed
    Slooooow.

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
Dude this thread hasn't been touched in 5 years.
 

My Computers

System One System Two

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
    Other Info
    N/A
  • Operating System
    Windows 2012 R2 Data center/Linux Mint
    Manufacturer/Model
    Poweredge T140
    CPU
    i3 9100 3.6GHz, 8M cache, 4C/4T
    Memory
    8GB 2666MT/s DDR4 ECC UDIMM
    Screen Resolution
    1440 x 900
    Hard Drives
    1 TB & 360 GB
Top