Extremely slow Internet browsing... Download speeds are fine

AstaLaVista

Lost in Cyberspace
Vista Pro
Guys, is there any way I can help speed up my browsing on the internet? I know some sites are slower than others but, as of late, the internet seems to slow down to a crawl yet, when I do the speed test, I end up scoring higher or just where I am supposed to be at.

I only use Avast as my A.V. & Spyware + Windows Firewall, no proxies. I am also using OpenDNS for my dns address and this has help a bit but still, I will like more from it since when I download a file, it does it fairly quick.

Any ideas?
 

My Computer

System One

  • Manufacturer/Model
    Custom Built
    CPU
    Intel Q9650 w/CM V8 Cooler...
    Motherboard
    EVGA 780i SLI FTW... Latest Bios & Drivers
    Memory
    Corsair Dominator 8GB (4 x 2GB) PC2-8500C5D
    Graphics Card(s)
    EVGA GTX260
    Sound Card
    Realtek High Def Onboard
    Monitor(s) Displays
    Acer 22" LCD Widescreen
    Screen Resolution
    1680 x 1050
    Hard Drives
    WD Velociraptor 160GB
    Samsung Sata 750GB
    Maxtor External 160GB
    PSU
    PC Power & Cooling 750w Silencer
    Case
    Thermaltake Speedo Advance
    Cooling
    Air Cooled... See CPU
    Mouse
    Logitech G7
    Keyboard
    Logitech G15
    Internet Speed
    Comcast 6MB Broadband
    Other Info
    Linksys WRT54G router

dk70

Member
Vista Pro
If we assume you are not hit by evil infection, then it might be relevant that an older post of yours show you have router with firmware not updated since long. Wireless Routers - Linksys Community Forums try search for it here. Lots of problems like this v4.21.1 of Linksys WRT54G Firmware is Bad - Wireless Routers - Linksys Community Forums though you can say the same for many routers.

So why dont you update to Tomato firmware? If it qualifies, Tomato FAQ | polarcloud.com

That way you can let router handle dynamic IP update (Basic, DDNS) and also get a little boost by increasing build in cache. Advanced, DHCP/DNS can be set up like in the pic. In older post I lost url to did you say Opendns ips changed? They should not. Only 208.67.222.222 and 208.67.220.220 are allowed I think, see pic for how it looks in Tomato.

Read up on Tomato site, there should not be a risk by "flashing" - can go back. Also dont wonder where firewall went - it is not possible to turn it off :)

If browsers are hosed by infection good luck :) Opendns can have problems in certain areas but should be temporarily. Infection is more likely than opendns messing up if set up correctly.
 

Attachments

Last edited:

My Computer

System One

  • CPU
    AMD X2 6000
    Motherboard
    Gigabyte GA-MA790FX-DS5
    Memory
    Corsair 4x1gb 6400C4
    Graphics Card(s)
    XFX 8800GTS XT 320mb, Generic Nvidia 6200 PCI 128mb
    Sound Card
    Onboard Realtek ALC889A
    Monitor(s) Displays
    24" Samsung 245b, 20" Dell 2007WFP, 19" Samsung 193P
    Hard Drives
    WD Raptor 74gb, Maxtor 300gb, WD Caviar 16SE 500gb
    PSU
    Corsair 520W
    Case
    Cooler Master Centurion 532
    Mouse
    Logitech MX1100R
    Keyboard
    Logitech G15
    Internet Speed
    20mb down, 1mb up

AstaLaVista

Lost in Cyberspace
Vista Pro
Thanks DK70, I will take a look at that when I get home as here in the office I use a Netopia/Motorola ADSL router but, at the house I use the WRT54G router and I do believe I have that Version of firmware and that has always being my issue, which btw, I discarded because it was happening at the office (NEtopia router) as well .

My LAN settings look just like those on your 2nd pic butthe first pic does not look like anything I have either on the Netopia or Linksys.
 

My Computer

System One

  • Manufacturer/Model
    Custom Built
    CPU
    Intel Q9650 w/CM V8 Cooler...
    Motherboard
    EVGA 780i SLI FTW... Latest Bios & Drivers
    Memory
    Corsair Dominator 8GB (4 x 2GB) PC2-8500C5D
    Graphics Card(s)
    EVGA GTX260
    Sound Card
    Realtek High Def Onboard
    Monitor(s) Displays
    Acer 22" LCD Widescreen
    Screen Resolution
    1680 x 1050
    Hard Drives
    WD Velociraptor 160GB
    Samsung Sata 750GB
    Maxtor External 160GB
    PSU
    PC Power & Cooling 750w Silencer
    Case
    Thermaltake Speedo Advance
    Cooling
    Air Cooled... See CPU
    Mouse
    Logitech G7
    Keyboard
    Logitech G15
    Internet Speed
    Comcast 6MB Broadband
    Other Info
    Linksys WRT54G router

AstaLaVista

Lost in Cyberspace
Vista Pro
Well, I have decided to DISABLE IPv6 first to see if I am succesful, if the problem persists, then I will comeback to this post and try the methods posted here.

Thanks
 

My Computer

System One

  • Manufacturer/Model
    Custom Built
    CPU
    Intel Q9650 w/CM V8 Cooler...
    Motherboard
    EVGA 780i SLI FTW... Latest Bios & Drivers
    Memory
    Corsair Dominator 8GB (4 x 2GB) PC2-8500C5D
    Graphics Card(s)
    EVGA GTX260
    Sound Card
    Realtek High Def Onboard
    Monitor(s) Displays
    Acer 22" LCD Widescreen
    Screen Resolution
    1680 x 1050
    Hard Drives
    WD Velociraptor 160GB
    Samsung Sata 750GB
    Maxtor External 160GB
    PSU
    PC Power & Cooling 750w Silencer
    Case
    Thermaltake Speedo Advance
    Cooling
    Air Cooled... See CPU
    Mouse
    Logitech G7
    Keyboard
    Logitech G15
    Internet Speed
    Comcast 6MB Broadband
    Other Info
    Linksys WRT54G router

dk70

Member
Vista Pro
No Tomato is different, not same setting or terms used.

There must be some network geeks here so if firmware type dont mean a thing I think you should post more details, like all of them. Firmware can give many problems, just look at linksys or netgear forums. The other day I was trying to help someone with a flash chat, could not connect. Everything else was worked. Turned out there was a conflict between routers firewall and Nortons. Had to disable routers and all was fine. Netgear have a page where they recommend turning off other firewalls Answer like they own the house :) So there can be conflict with routers and software firewall. I never knew. Try turn it off for a test. Funny that in order to make same Netgear decent as a wireless router everyone at Netgear suggest to turn off routers firewall! An older Netgear I had was crap at torrents, after 3-4 updates it was flying with no freezes, slowdowns. Firmware can be life or death.

You have this weird problem at home - and same weird problem at the office. Other computer/setup, other network, nothing in common except you? Must be you having bad influence on the internet then ;)

Have you tried stopping Avast Webshield and Netshield? There should not be problems with Windows firewall but easy to try.

You have not been tweaking for more speed? Dont think it is a good idea on Vista. netsh interface tcp show global are defaults?
 

My Computer

System One

  • CPU
    AMD X2 6000
    Motherboard
    Gigabyte GA-MA790FX-DS5
    Memory
    Corsair 4x1gb 6400C4
    Graphics Card(s)
    XFX 8800GTS XT 320mb, Generic Nvidia 6200 PCI 128mb
    Sound Card
    Onboard Realtek ALC889A
    Monitor(s) Displays
    24" Samsung 245b, 20" Dell 2007WFP, 19" Samsung 193P
    Hard Drives
    WD Raptor 74gb, Maxtor 300gb, WD Caviar 16SE 500gb
    PSU
    Corsair 520W
    Case
    Cooler Master Centurion 532
    Mouse
    Logitech MX1100R
    Keyboard
    Logitech G15
    Internet Speed
    20mb down, 1mb up

AstaLaVista

Lost in Cyberspace
Vista Pro
Everything that has to do with Networking is Default on both my Office PCs and Home. I do this because Networking is so GREEK to me.

Well, so far so good, I disabled IPv6 last night, used my PC for a while and left it on all night long, of course it went to sleep (and so did I ;)), this morning, I woke up and after waking up the pc as well, I had internet connectivity so, I am hoping it was not just a fluke.

Thanks for the help
 

My Computer

System One

  • Manufacturer/Model
    Custom Built
    CPU
    Intel Q9650 w/CM V8 Cooler...
    Motherboard
    EVGA 780i SLI FTW... Latest Bios & Drivers
    Memory
    Corsair Dominator 8GB (4 x 2GB) PC2-8500C5D
    Graphics Card(s)
    EVGA GTX260
    Sound Card
    Realtek High Def Onboard
    Monitor(s) Displays
    Acer 22" LCD Widescreen
    Screen Resolution
    1680 x 1050
    Hard Drives
    WD Velociraptor 160GB
    Samsung Sata 750GB
    Maxtor External 160GB
    PSU
    PC Power & Cooling 750w Silencer
    Case
    Thermaltake Speedo Advance
    Cooling
    Air Cooled... See CPU
    Mouse
    Logitech G7
    Keyboard
    Logitech G15
    Internet Speed
    Comcast 6MB Broadband
    Other Info
    Linksys WRT54G router
Top