• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Network & Sharing File Sharing - Turn On or Off

Brink

Staff member
mvp
Messages
32,202
Location
Oklahoma, USA
File Sharing - Turn On or Off How to Turn File Sharing On or Off in Vista
This will show you how to turn file sharing on or off for all people on your network to be able to access the files and printers that you have set to Share on your computer.
Published by Brink Category: Network & Sharing 
#1
ByLine
How to Turn File Sharing On or Off in Vista
Synopsis
This will show you how to turn file sharing on or off for all people on your network to be able to access the files and printers that you have set to Share on your computer.
How to Turn File Sharing On or Off in Vista

information   Information
This will show you how to turn file sharing on or off for all people on your network to be able to access the files and printers that you have set to Share on your computer.
warning   Warning
Check the Network Location Type settings.
  • If your network location type is set to Private (Home or Work), then file sharing is turned on by default.
  • If your network location type is set to Public, then file sharing is turned off by default.





STEP ONE
Network Connection Properties

NOTE: This is your connection properties for your network adapter device.
1. Open the Control Panel (Classic View).​
2. Click on the Networking and Sharing Center icon.​
3. Click on Manage network connections in the upper left corner.​
4. Right click on the Network Connection you want to share the Public folder with, and click on Properties.​
5. Click on Continue in the UAC prompt.​
6. Check File and Printer Sharing for Microsoft Networks and click on OK. (See screenshot below)​
NOTE: This is checked by default. This must be checked to be able to turn on file sharing in STEP TWO below.​
Network_Connection_Properties.jpg





STEP TWO
Turn File Sharing On or Off

1. Open the Control Panel (Classic view).​
A) Click on the Network and Sharing Center icon.​
B) Go to step 3.​

OR
2. Right click on the taskbar Network system tray icon.​
A) Click on Network and Sharing Center.​

3. Click on the down arrow to the right of File sharing to expand it. (See screenshot below)​
NS_Center.jpg

4. To Turn On File Sharing
NOTE: With file sharing on, all people on your network will have access to the files and printers that you have set to Share on your computer.​
A) Select (dot) Turn on file sharing. (See screenshot below step 7)​
B) Go to step 6.​

5. To Turn Off File Sharing
NOTE: With file sharing off, all people on your network will not be able to access the files and printers that you have set to Share on your computer.​
A) Select (dot) Turn off file sharing. (See screenshot below step 7)​

6. Click on the Apply button.​
7. If prompted, click on Continue in the UAC prompt.​
File_Sharing.jpg





STEP THREE
Enable Simple File Sharing

That's it,
Shawn


 
Last edited:

My Computers

System One System Two

  • Show second system?
    Yes
    Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    PSU
    Seasonic Prime Titanium 850W
    Case
    Corsair Air 740
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master
    Keyboard
    Logitech wireless K800
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Creative F200 webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD
Messages
12
Location
galati
#2
Last edited:

My Computer

System One

  • CPU
    e6300
    Motherboard
    asus p5l 1394
    Memory
    4.oo GB
    Graphics Card(s)
    asus EAH 4650
    Sound Card
    audigy soundblaster
    Monitor(s) Displays
    LG L1919s
    Hard Drives
    Western Digital - WDC WD800AAJS-00WAA0 (74 GB)
    Western Digital - WDC WD1600JS-00NCB1 (149 GB)
    Keyboard
    Microsoft

Brink

Staff member
mvp
Messages
32,202
Location
Oklahoma, USA
#3
Hello Giksy,

Sorry it took a bit to get back to you, but I have been doing some research on this. Are you using another firewall other than Windows Firewall? If so, then this may be the issue. If you do, keep Password protected sharing turned on, and see below.



Here are some additional considerations:
  • Firewall software blocks network sharing by default for security. To use file sharing or printer sharing in Windows, you must ensure that your firewall software is configured to allow the appropriate networking protocols to communicate. Consult the documentation that came with your firewall software.
  • Turning on printer sharing automatically turns on file sharing, because printer sharing uses the same protocols as file sharing, and requires the same Windows Firewall rules to be enabled. However, the reverse is not true: turning on file sharing will not automatically turn on printer sharing.
Since you have Vista Ultimate, you might also try disabling file sharing through Group Policy to see if that helps.

Hope this helps some for now.
 

My Computers

System One System Two

  • Show second system?
    Yes
    Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    PSU
    Seasonic Prime Titanium 850W
    Case
    Corsair Air 740
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master
    Keyboard
    Logitech wireless K800
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Creative F200 webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD
Messages
12
Location
galati
#4
:( it din`t work.
anyway thank you again.
and yes i`m using another firewall than vista`s. and that is comodo firewall
 

My Computer

System One

  • CPU
    e6300
    Motherboard
    asus p5l 1394
    Memory
    4.oo GB
    Graphics Card(s)
    asus EAH 4650
    Sound Card
    audigy soundblaster
    Monitor(s) Displays
    LG L1919s
    Hard Drives
    Western Digital - WDC WD800AAJS-00WAA0 (74 GB)
    Western Digital - WDC WD1600JS-00NCB1 (149 GB)
    Keyboard
    Microsoft

Brink

Staff member
mvp
Messages
32,202
Location
Oklahoma, USA
#5
No problem. You should be fine though as long as you have the Password protected sharing option turned on.
 

My Computers

System One System Two

  • Show second system?
    Yes
    Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    PSU
    Seasonic Prime Titanium 850W
    Case
    Corsair Air 740
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master
    Keyboard
    Logitech wireless K800
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Creative F200 webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD

H2SO4

A bit of a numpty
Vista Guru
Messages
1,241
Location
Australia
#7
NET STOP SERVER

That stops the (SMB) server service which will prevent the machine from sharing files (and printers) until the service is restarted.

However, if you reboot, the service will restart again because by default it's set to start automatically. To disable auto-startup, you could use this:

sc config LanmanServer start= auto

You'll need to do it elevated though.
 

My Computer

H2SO4

A bit of a numpty
Vista Guru
Messages
1,241
Location
Australia
#9
What exactly is not working for you? What errors do you see, if any?

If you stop (and disable) the Server service, I can guarantee nobody will be able to access shares on that box. In fact, that's the best way to stop sharing.

I made an obvious mistake with the SC command though. To disable the service, use this syntax:

sc config LanmanServer start= disabled

(Note "disabled", not "auto" as I previously wrote.)
 

My Computer

Messages
23
#10
hi,
the above command which you have mentioned is not working below is the screen shot


i want the uncheck the check box file and printer sharing for network in the properties of network.
 

My Computer

H2SO4

A bit of a numpty
Vista Guru
Messages
1,241
Location
Australia
#11
You didn't leave a space after the equals (=) sign. That's why it's bombing out.


sc config LanmanServer start= disabled


(Note the space after start= )


If you cut 'n' paste my command directly from here, it'll work. The effect is the same as changing the startup type to "disabled" for the Server service in the services.msc applet.
 

My Computer

Messages
23
#12
thanks that command is working now, it has disabled the server services. but the check box of file and printer sharing for network is still showing checked. what should i do for this...
 

My Computer

H2SO4

A bit of a numpty
Vista Guru
Messages
1,241
Location
Australia
#13
Nothing. That's just the binding. Remember your goal is to stop resource sharing, and not specifically to unbind (an otherwise active) Server service from the interface.

There are command-line methods for altering bindings too, but I doubt that's what you're after.
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)