• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Frozen cursor issue

#1
This is my first time venturing into this forum so hopefully I've covered the relevant info. Thanks in advance for any help!

I'm using Windows Vista Home Premium on a HP pavilion slimline s3220n that's about three years old. I had lost mouse and keyboard control the night before I brought it into Staples for an overheating issue and am told both worked fine at the store, but at home, I'm still having the problem. I did switch both the keyboard and mouse out but it made no difference, although after freezing a couple times, the keyboard eventually sorted itself out.

What confuses me is this: At one point, I had to shut down the computer by pressing the power button because everything was frozen. When it started up again, it did an automatic system repair and restored it to an earlier point. On that screen, the keyboard and mouse work perfectly. However, once it boots up, regardless of whether it's in normal mode or safe mode, the cursor is still in the middle of the screen.

The last time everything worked was before the computer shut down after a HP update. I can't remember what it was (want to say it was photo related), but all I can find that was recently installed is a Microsoft Office update. I accessed System Restore through System Tools but I only have four restore points from 9/16 to choose from, starting with when I turned it on upon bringing it home and three more for each time it restarted.

I would bring it back to Staples but I'm not too thrilled with the work they've done on a seperate issue, plus they insist it worked perfectly there. It's been suggested I press F11 before it starts up for more restore points, but I vaguely remember F11 doing a system recovery only and not giving me a system restore option. I only want to wipe it completely as a last resort.

So, is there a really simple fix I'm missing? I'm kind of at a loss here and can't find this exact problem elsewhere. It just doesn't make sense to me that the mouse works on the restore screen but not once it starts up. Any help is much appreciated!
 

richc46

Staff member
Vista Guru
Gold Member
#2
Welcome
First make full anti virus scan
Download the free malwarebytes and make a full scan. If negative this may help.
Here are my solutions to freezing, and an excellent article, which I hope is of some help
Go to search type device manager and look for any yellow warning markers
Download and run malwarebytes, a full scan after you update
Run antivirus scan
Check memory with memtest86
Make sure that you are not over heating.
Try in safe mode; report back if it works properly.
Try a clean boot
Make sure PSU is working properly
If overclocking, restore to original
Test hard drive at company website.
Test in safe mode, does it still happen?
Try with clean boot..
http://support.microsoft.com/kb/929135
http://support.microsoft.com/kb/929135
http://malwarebytes.org/
http://www.almico.com/speedfan.php
http://www.geekstogo.com/forum/topic...ing-memtest86/
http://ezinearticles.com/?Troublesho...blems&id=39981

If the freeze is in safe mode too can be hardware, I would guess memory. Make sure that you have enough free memory and then test it.
Guide to using Memtest86+ - Geeks to Go Forums
 
#3
thank you so much for responding.

i can't believe i forgot to check device manager. sometimes i overlook the obvious things.

i do have exclamation points besides the following:
PS/2 Compatible Mouse
Windows cannot load the device driver for this hardware. The driver may be corrupted or missing (code 39)

NVIDIA GeFroce 6150SE nForce 430
Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged (code 19)

I selected 'check for solutions' for both but all I got was a window that said 'windows is checking for a solution to the problem.' Both are updated. I rolled back the driver for NVIDIA with no change.

I always have Malware running and a complete scan found no viruses. I have the same issues in safe mode and while it's not currently overheating (CPU is low), that is a major problem I have with this computer. I have no idea what memtest86, PSU, or overclocking means, or how to do a clean boot, though I guess I could figure it out if I need to (i know you linked to a few of them, but then i need to select things i just can't get to), but I figured the problem is with the exclamation points.

I'm trying to google how to fix that but the frustration factor is sky high. I have absolutely no idea how to navigate with only the keyboard so everything's trial and error, and more error than anything else. Does anyone know what steps I need to take next?