• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Google is the only site I can connect to

#1
Hi
I just bought a laptop with vista home on it. I turned it on and mostly everything worked right away. Except the internet. I have a wireless network, so I logged into that and it says its working fine. I can turn on internet explorer and the default home page (google) turns on fine. I can search on google, I can go to google images, and I can do anything else google-related. But when I try to go to any other site, it first takes about five minutes to load then says "page cannot be displayed." I searched all over the internet for a solution but I can't find anything. At this point I think I can rule out a hardware issue because this computer is completely new, and I can also rule out the network not working properly because I can actually connect to the internet and do searches, I'm just limited to google.


Any help would be greatly appreciated,
Thanks

Edit: Okay, I tried to transfer a file from my other computer through the network (which the computer says is working fine) and it sees my other computer, I can double click the computer's icon and open up a page that shows me folders like "my documents". However, when I try to select one of the folders it takes a long time to load, then gives me an error message.

This doesn't make any sense to me. It seems like the entire network is not working except for allowing me to use the internet and then only to go onto google.

Anybody have any ideas?
 
Last edited:
#2
I know this was an old thread, but I am having the same problem this user was having: I can load only sites run by Google. Through many searches, I've found other people who described this same problem dating back three years ago, but though it's an old issue, I can't find any fixes for it. Either the user's post goes unanswered (as the previous one seems to be) or people offer all kinds of things to check and try to no avail.

I have three computers. My newer laptop is running Vista Home Premium 32-bit. My desktop also has VHP32, but is not experiencing this problem. I'm on my old laptop now (XP), which also has no problem. I used my newer laptop last night and everything was fine. The sites I visited were the ones I'm often on. I shut down and went to bed. This morning I discovered I could fully access only Google sites -- I found two other sites (nothing to do with Google) that would load halfway (missing most graphics, functions). All three computers use the same router, a Comcast-issued Netgear.

Anyone know what's going on? I hadn't messed with any settings or anything like that.
 
#3
check your DNS settings and make sure that they are set to automatic . try to flush the DNS cache by typing ipconfig /flushdns in the command prompt and reboot your computer. Try to goto internet properties and make sure that you are not using any proxy settings. You can try downloading Firefox as a last resort.
 
#4
I tried flushing dns. Nothing. Everyone else who tried that said it didn't work, either.

People with Firefox have experienced this same thing, so even if I could get to mozilla.com to download it, which I can't :(, I doubt it would help. This problem is happening with both my browsers: Google Chrome and Internet Explorer.

It's happened to so many people of different circumstances: they have different operating systems, use mac and windows, use various browsers, have different kinds of routers, live in different countries, and on and on. And it seems everyone's tried everything they can think of. They say that they touched nothing - one minute everything's fine, the next, this. It seems no one is immune and everyone is susceptible. I've been through so many help forums (but this is only one I've posted to), and no one has been able to say that they recognize this problem and know how to fix it.
 
#5
to make sure it is indeed a DNS issue, try typing the following address into your browser:

EDIT --- WHOOPS. TRY CLICKING ON EACH LINK BELOW

  1. http:// www.google.com
  2. Google
  3. Adobe
  4. Adobe - Error page
did you get a web page for all numbers? If not, which ones (by number) showed anything?

Finally, open a command prompt

START-->ALL PROGRAMS-->ACCESSORIES-->COMMAND PROMPT

and type:

1. ping msn.com
2. ping 207.68.172.246

Did you get the same response from both? If not, which one worked?

Good luck!
 
#6
Of the four links, the 2 Google ones work fine. The two Adobe ones simply never loaded.

The ping results were the same. Four lines of "Request timed out." Four packets sent, none received. (100% loss)

I found one person in my many searches of this weird problem who said they updated their router's firmware and this fixed the problem. (but others have said this didn't work for them) Is this something that's easy to do? Like simply downloading and installing an update? Or do you think I should get a Comcast tech to come take a look since it's their router? (IF that's even the problem)

edit: I just read that I cannot update my router's firmware, if that's one of the things I end up having to try. It has to be done by Comcast.
 
Last edited:

delphin

Eager to learn
Vista Pro
#7
Hi,

Open ur command prompt by typing cmd in run.

In the command prompt type the following

ping 4.2.2.1
ping 4.2.2.2
ping 4.2.2.3

if these ip adresses are pinging the problem is not with ur dns settings.

Let me know the result
 
#10
Hi,

Open ur command prompt by typing cmd in run.

In the command prompt type the following

ping 4.2.2.1
ping 4.2.2.2
ping 4.2.2.3

if these ip adresses are pinging the problem is not with ur dns settings.

Let me know the result
Worked fine. They took between 30-33ms round trip with 0% loss.
 
#11
I had the same problem. It's your drivers. Install windows xp drivers and your computer will be FINE.
Drivers for what exactly, though? I have Vista on the problem laptop.

I've pretty much come to the conclusion that it's a router driver/firmware that I'd have to get Comcast to update (since I'm renting the router).
 
#12
I mean download Windows XP drivers. They say they aren't compatible with vista, but they are the complete opposite apparently. I had the same problem, pages would say they couldn't be displayed. See if you only have local access too. I spent about 7 days trying to figure out the problem, was in contact with vista support constantly, and I couldn't get a straight answer. Finally, a comcast guy came down but he didn't even know what the problem was either, so he had to get a higher up to come down here. He tried EVERYTHING. He was at the point where he didn't even know what to do until he tried to install Windows XP drivers. Once they were installed the internet magically worked. Wierd, I know. But it's the only solution we came up with.
 
#13
No, it's not just local access. I can bring up anything recent on a Google site.

But can you tell me specifically what XP driver worked for you? What was it called, precisely? I don't want to guess and be installing a lot of different XP drivers onto my laptop that has Vista. I just don't feel comfortable with that thought. But I don't mind experimenting with one driver that worked for someone else. :)
 
#14
Try my instructions ref: nslookup at this thread: http://www.vistax64.com/network-internet/218107-vista-connections-issues.html#post1000154

Also check your browser to ensure you aren't using a proxy.

AFTER running a virus scan, disable your internet firewall and try it. Quite a few folks have clicked on BLOCK when asked to allow a DNS access (of course, the s/w didn't say DNS, just the port :) )

You may also check out your localhost files, as some redirectors use this trick.

- JC
 
#15
I have this same problem, wondering if you were able to resolve it?

My other laptop is wireless (macbook OSX) and it works fine. The new Vista laptop works on other wireless networks but not on our home Comcast network. I can access Google and Google related sites only from home, but no other sites. Netgear router is on a desktop that has Windows XP, the desktop works fine as well.
 
#16
Well, as a temporary fix (since my desktop and other laptop are still working, and it was no emergency), I got a wireless adapter to plug in to the side, which communicates with my Comcast Netgear router just fine. I just disabled the laptop's built-in wireless and plugged in an adapter stick. Full access now. Sucks that I have to have that extra little bit of hardware, but I can deal. :huh:
 
#17
ASUS support sent me a zip file w/ new drivers for Intel Proset/Wifi Software and hopefully this will work. If not, I'll try the adapter (luckily I have one already). I'll let you know the outcome. Thank you so much for replying.
 
#18
I hope it works. And I hope it may be something that I could try. Out of all the reports of this problem, reported fixes are almost non-existent. One person got a Comcast tech to fix it, and he had to get a second tech to help because the problem baffled him. One person, out of many who tried, claimed he fixed his with system restore. So, yeah, a real fix would be great.
 
#20
So, I woke up this morning, went to my desk and was unable to connect to the internet. Same problem that everyone else is talking about, able to connect to Google and nowhere else. Strangely, I thought I'd see if it was somehow related to my IP address so I logged into a proxy server application that I use...and problem fixed. Very strange, if I log out of the proxy the problem reappears but while surfing with the proxy everything works fine. Can anyone explain what I have to do to be able to surf again without the proxy? Not sure if it helps but I have a fixed IP address assigned by my ISP.