• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

google maps won't show map, some buttons don't work on other sites

#1
after reload of win Vista everything works fine. but in about 3 months time I start to loose browser functionality. When I go to google maps it will start to load a very small portion of the map at the top of the screen and stop. no error messages. On other webpages the buttons that use to work no longer work. This happens for all browsers. I reloaded once to solve this problem. I would like to know what might be the cause. Has anyone else experienced this?

on a side note: is there anyway to change which mail application is used when clicking within the browser? Like when you click to email someone from a form.
 

My Computer

richc46

Staff member
Vista Guru
Gold Member
#2
Welcome
I can answer the second part of your post
Go to search, by the start button
Type the word default
When you see default programs, click on it
Check the program that you want to be the default.
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

Users Who Are Viewing This Thread (Users: 1, Guests: 0)