Hello team! Driver assitance if possible needed.

Hi everyone. After much time i decided to set aside the software part of my hobby until i have gone through most of the hardware issues. So now that i have finished most of that ii have again installed some drivers in this laptop Sony Viao VGN-CR220e from Snappy Drivers and have this to ask: Are all this drivers necessary? I will attack a screenshot from my other laptop since i don't want to access my email from this Vista system. I would have done it from this system but the key commands don't work as some might now but that's a separate topic. The reason i ask is because as you can see the same exact drivers are repeated 2 or more times. I'm anxious to hear back. Thanks all.
 

My Computer

System One

  • Operating System
    Win10
    Manufacturer/Model
    Toshiba C55-B5256
    CPU
    • Intel® Core™ i5-4210U Processor @ 1.70 GHz.
    Motherboard
    ^3M Cache, up to 2.70GHz with Intel® Turbo Boost Technology
    Memory
    8 GB DDR3
Ok, i learned about a way of saving the screenshots to the pc which is very different from my modern laptop which automatically saves your screenshots. Anyway here are the screenshots.
1.jpg2.jpg3.jpg4.jpg4.jpg
 

My Computer

System One

  • Operating System
    Win10
    Manufacturer/Model
    Toshiba C55-B5256
    CPU
    • Intel® Core™ i5-4210U Processor @ 1.70 GHz.
    Motherboard
    ^3M Cache, up to 2.70GHz with Intel® Turbo Boost Technology
    Memory
    8 GB DDR3

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
Don't uninstall anything. You don't know what it'll break and you have no reason to remove them.
 

My Computers

System One System Two

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
    Other Info
    N/A
  • Operating System
    Windows 2012 R2 Data center/Linux Mint
    Manufacturer/Model
    Poweredge T140
    CPU
    i3 9100 3.6GHz, 8M cache, 4C/4T
    Memory
    8GB 2666MT/s DDR4 ECC UDIMM
    Screen Resolution
    1440 x 900
    Hard Drives
    1 TB & 360 GB

wither 3

Vista Guru
Gold Member
I don't see any repetitious drivers. For example, in Processors, there are two entries. That just means you have a duo core CPU. The USB drivers all address different ports on your system. You have 7 controllers and 7 USB Root Hubs.
 

My Computer

System One

  • Operating System
    Vista Home Premium 64 bit SP2
    Manufacturer/Model
    Cyberpower
    CPU
    Intel Quad CPU Q6700 2.67 GHZ
    Motherboard
    NVIDIA 780i
    Memory
    4 GB
    Graphics Card(s)
    MSI GTX 560 TI Twin Frozr
    Sound Card
    Sound Blaster SB Audigy
    Monitor(s) Displays
    Viewsonic VG2436
    Screen Resolution
    1920x1080p
    Hard Drives
    Samsung HD 105SI
    WDC WD20
    Case
    Apevia XJupiter
    Cooling
    air
    Mouse
    Logitech MX 600
    Keyboard
    Logitech MX 3200
    Internet Speed
    30 Mbps

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
Something like that is normal.
 

My Computers

System One System Two

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
    Other Info
    N/A
  • Operating System
    Windows 2012 R2 Data center/Linux Mint
    Manufacturer/Model
    Poweredge T140
    CPU
    i3 9100 3.6GHz, 8M cache, 4C/4T
    Memory
    8GB 2666MT/s DDR4 ECC UDIMM
    Screen Resolution
    1440 x 900
    Hard Drives
    1 TB & 360 GB

SIW2

Vista Guru
Gold Member
Looks normal to me.
 

My Computer

System One

  • Operating System
    Vista
    CPU
    Intel E8400
    Motherboard
    ASRock1333-GLAN R2.0
    Memory
    4gb DDR2 800
    Graphics Card(s)
    nvidia 9500GT 1gb
Don't uninstall anything. You don't know what it'll break and you have no reason to remove them.
Completely understand but i was thinking that maybe Snappy downloaded the same driver a few time because there were a couple of instances in which it would tell me that a certain driver was successfully installed but the driver link in Snappy would wouldn't disappear. They normally disappear after you get the successfully installed message but in those couple of cases i mentioned the link wouldn't go away so i downloaded it a couple of times.
 

My Computer

System One

  • Operating System
    Win10
    Manufacturer/Model
    Toshiba C55-B5256
    CPU
    • Intel® Core™ i5-4210U Processor @ 1.70 GHz.
    Motherboard
    ^3M Cache, up to 2.70GHz with Intel® Turbo Boost Technology
    Memory
    8 GB DDR3
I don't see any repetitious drivers. For example, in Processors, there are two entries. That just means you have a duo core CPU. The USB drivers all address different ports on your system. You have 7 controllers and 7 USB Root Hubs.
the controllers are the so called driver chips in the motherboard correct? the brain of each specific function like reading flashdrives?
 

My Computer

System One

  • Operating System
    Win10
    Manufacturer/Model
    Toshiba C55-B5256
    CPU
    • Intel® Core™ i5-4210U Processor @ 1.70 GHz.
    Motherboard
    ^3M Cache, up to 2.70GHz with Intel® Turbo Boost Technology
    Memory
    8 GB DDR3
Looks normal to me.
What about the usb root hubs? My failrly modern toshiba has only two usb root hubs, one of which is 3.0. It also has 3 usb ports which is the same as the Viao yet the Viao has 7 root hubs for USBs?
 

My Computer

System One

  • Operating System
    Win10
    Manufacturer/Model
    Toshiba C55-B5256
    CPU
    • Intel® Core™ i5-4210U Processor @ 1.70 GHz.
    Motherboard
    ^3M Cache, up to 2.70GHz with Intel® Turbo Boost Technology
    Memory
    8 GB DDR3

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
Those aren't drivers but devices which is why it's called device manager. I won't claim to understand why it's all there but I wouldn't touch it. What are you hoping to gain? Maybe save a few hundred kb of space?
 

My Computers

System One System Two

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
    Other Info
    N/A
  • Operating System
    Windows 2012 R2 Data center/Linux Mint
    Manufacturer/Model
    Poweredge T140
    CPU
    i3 9100 3.6GHz, 8M cache, 4C/4T
    Memory
    8GB 2666MT/s DDR4 ECC UDIMM
    Screen Resolution
    1440 x 900
    Hard Drives
    1 TB & 360 GB

ilikefree

Vista Guru
Gold Member
There are no exclamation marks next to anything in device manager so nothing is wrong.
Windows will show a warning exclamation mark next to any problems
 

My Computer

System One

  • Manufacturer/Model
    Lenovo Thinkpad T400
    CPU
    Intel Mobile Core 2 Duo P8700 @ 2.53GHz
    Motherboard
    LENOVO 64734VM
    Memory
    2.00GB Single-Channel DDR3 @ 531MHz
    Graphics Card(s)
    Intel Mobile Intel 4 Series Express Chipset Family
    Sound Card
    Conexant 20561 SmartAudio HD
    Monitor(s) Displays
    15 inch
    Screen Resolution
    1280 x 800
    Hard Drives
    1x 180GB Intel 530 series SSD
    1 x 120GB Hitachi 5400rmp
    1 x 650GB Western Digital Elements 5400rpm
    1x 1Tb Western Digital Elements 5400rpm
    Internet Speed
    Medium for New Zealand
    Other Info
    Weakest part of my computer is the graphics chipset.
    Only ever used a laptop.
    Also use USB Freeview TV Card
    Lenovo Docking Station
    External Speakers
    Other bits a pieces as needed
Top