• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Help with scheduling Disk defrag please

#1
Hi

Firstly I have checked this forum (and others) for the solution finding similar problems but still no joy.

I am trying to schedule Vista defrag to run at night. However it doesn't run (or at least says it doesn't run) when scheduled to - in fact I don't think it runs at all(it says "never" in the defrag control panel against "last run"). I tested to see if the schedule works however in Task Scheduler it says that the task failed. I have tried deleting / disabling task in TS (but it reappears on reboot) and making sure that the properties in the TS task are ok, as well as "running" the task in TS all to no avail.

I've seen this but all the talk of "command lines" etc baffles me!

Anyone got any thoughts?

Thanks in advance :D
 
#2
Hello rgsoton and welcome to vista forums! :party::party:

Here are a couple of Brinks tutorials that should hopefully be able to help you:

1. http://www.vistax64.com/tutorials/81786-disk-defragmenter-command-prompt.html?filter
2. http://www.vistax64.com/tutorials/72832-disk-defragmenter.html
3. http://www.vistax64.com/tutorials/157357-defragment-boot-files-create-shortcut.html

If those fail or dont help your problem, try doing a defrag using Auslogics Disk Defrag.

Let us know if those helpped you at all and if you need anymore help! :)

Thanks,
Ben
 
#5
Hi Ben

Thanks for the suggestions...I looked at the three tutorials...don't think these will help. So tried "Auslogics" and opened up the schedule (the most important thing for me is to be able to schedule successfully as opposedto having a really good defragger). I set a schedule to run in a couple of minutes, looked in Task Scheduler and saw the task appear. Rebooted. However opened up the Auslogics Control Panel and nothing. It didnt run (although TS says it did). In the TS settings under "General" tab in "configure for" it doesn't default to "Vista". I even changed this but no good as well as "running" the task manually in TS. Also when I went into the settings of Auslogics the box had been unticked for automatic scheduling...I'd been nowhere near it! I'm sure it's the interaction with TS that's the problem. Any programs (e.g. MalwareBytes) that within which one can schedule and then it automatically creates that same task in TS doesn't run properly. If there was someway that when I schedule in a program a Task isn't created in TS that would might be the answer. This is why I wondered if the solution might be the link in my first post?

Thanks :D
 
#6
I understand your problem but i cant think of too many solutions. Try manually running a malwarebytes scan and also a spybot S&D scan. What Anti-Virus program do you have?

Let me know,
Ben