Hidden Files and Folders Option - Add or Remove

ByLine
How to Add or Remove "Hidden Files and Folders" from Folder Options in Vista and Windows 7
Synopsis
This will show you how to Add or Remove the Hidden Files and Folders options in Folder Options for all user accounts on the computer.
How to Add or Remove "Hidden Files and Folders" from Folder Options in Vista and Windows 7

information   Information
This will show you how to Add or Remove the Hidden Files and Folders options in Folder Options for all user account on the computer.
Note   Note
The Hidden Files and Folders option is added to Folder Options by default.

EXAMPLE: Hidden Files and Folders Option Added and Removed
NOTE:
You will need to close and reopen Folder Options to see the changes made below.

Add.jpg Remove.jpg



OPTION ONE
Using a REG File Download

1. To Add "Hidden Files and Folders" to Folder Options
NOTE: This reg download containd the entire contents of the Hidden key, including the NOHIDDEN and SHOWALL subkeys, for a full restore of the Hidden files and folders option.​
WARNING: If you have get a black square(s) instead of the check box next to Hidden files and folders, then use Radio instead of Group in the OPTION TWO (step 6) below to not have the black square.​
A) Click on the download button below to download the file below.​
Add_Hidden_Files_Folder.reg
download

B) Go to step 3.​

2. To Remove "Hidden Files and Folders" from Folder Options
A) Click on the download button below to download the file below.​
Remove_Hidden_Files_Folder.reg
download

3. Click on Save, and save the .reg file to the Desktop.​
4. Right click on the downloaded .reg file and click on Merge.​
5. Click on Run, Continue (UAC-Vista) or Yes (UAC-Windows 7), Yes, and then OK when prompted.​
6. When done, you can delete the downloaded .reg file if you like.​
7. Close and reopen Folder Options to see the change.​




OPTION TWO
Using Registry Editor

NOTE: For a full restore of the Hidden files and folders option that includes the entire contents of the Hidden key with the NOHIDDEN and SHOWALL subkeys, see Option One.
1. Open the Start Menu.​
2. In the white line (Start Search) area, type regedit and press Enter.​
3. If prompted by UAC, then click on Continue (Vista) or Yes (Windows 7)​
4. In regedit, navigate to the location below. (See screenshot below step 5)​
Code:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\Folder\Hidden
5. In the right pane, right click on Type and click on Modify.​
NOTE: If Type is not there, then right click on a empty area of the right pane and click on New and String Value, then type Type and press Enter.​
Registry.jpg

6. To Add "Hidden Files and Folders" to Folder Options
A) Type group and click on OK. (See screenshot below)​
WARNING: If you get or have a black square(s) instead of the check box for the Hidden files and folders option, then type Radio instead and click on OK.​
Modify2.jpg

7. To Remove "Hidden Files and Folders" from Folder Options
A) Clear group and leave the field empty. (See screenshot below)​
B) Click on OK.​
Modify1.jpg

8. Close regedit.​
9. Close and reopen Folder Options to see the change.​
That's it,
Shawn


 
Last edited:
Shawn Brink

Comments

i did all the steps but still not working... and i made sure that the registery key is there but with still not working
 
There was a missing key and cause that things happen. By using the manual method, follow the step above until step 4, then click to SHOWALL.

(if you compare between SHOWALL and NOHIDDEN right pane, SHOWALL had missing CheckedValue key)

You can create that key by right click on the right pane(on SHOWALL right pane) > New > select DWORD (32-bit) value, then rename it as CheckedValue, then modify the value data to "1" (right click then choose modify).

Close regedit.

Check whether your Show hidden files is there or not.

Give your comment ok....
 
HELLOOO im new!! i came across this site looking for help on this topic, all the information is very helpfull and it work, except now i have 2 dark squares infront of the options to hidde and unhidde and it's not allowing me to select either one of the, i have some important information on a couple of hidden folders that i need for finals and im desperate, thankssss
 
Hi Dopolina, and welcome to Vista Forums.

Can you post a screenshot of this to help narrow down the possibilities?

Do you know the name and full path of the hidden file? If so, post it back, and I will post back a command that you can use the command prompt to manually unhide that file.

Thank you,
Shawn
 
those 2 dark squares happen if you try to change the value for Type key.. don't change it to group and don't leave it blank. Just set it as radio because radio was a default setting.
 
Hi Al Firdauz,

Strange, I have group as the default value for Type, not radio. Anyone else?

Thank you,
Shawn
 
Did you have any problem with the options for "hidden files" and "show hidden files" at folder option? The dark squares did not appear? My default is radio. If I try to change it to group the selection for "Do not show hidden files and folders" become a dark square.
 
I did not have any problems with dark squares in Folder Options with it set as group. When it was set as blank, I just did not have the options in Folder Options.
 
Thank you for the help, restored my hidden folders option with the download.
got the two black boxes. I managed to correct the problem by removing "group" and replacing it with "radio" as instructed.
:party:
 
Thank you for also confirming this Ian. I will add it to the tutorial to help others with the same problem.

Shawn
 
Hi y'all!


For me it all didn't help. When applying the .reg file from here I only got one black square followed by "Hidden" (although I have a german version of vista where it should be "Versteckte Dateien und Ordner").

I saw the key "hidden" and it's subkeys "showall" and "nohidden" were completely blank and so I asked a friend to export his settings (from a XP client lol) including the subkeys and it worked! I found a thousand pages handling this but no one had the regfile with the subkeys included.

I hope this will help anyone, please post if it worked (when none of the other patches helped)

Thanks in advance!
 
Hi Genius777, and welcome to Vista Forums.

Some folks would just need to use Radio instead of Group in the Manual Section (step 6) to not have the black square.

Hope this helps,
Shawn
 
I have already tried that, I just forgot to mention. When I changed it to "Radio" it was completely gone - just like if set to "".

Thanks for helping even users that don't read whole threads. :geek:
Great support here!
 
I have already tried that, I just forgot to mention. When I changed it to "Radio" it was completely gone - just like if set to "".

Thanks for helping even users that don't read whole threads. :geek:
Great support here!
Well actually I did read the whole thread :o The problem persisted since months, so a system restore was not applicable. Again, when I changed "Type"to "radio" the option was completely gone. Just the same as if "Type" is set blank.

When I changed it to "group" it was only one black square followed by "Hidden" (not "Hidden Files and Folders" or "Versteckte Dateien und Ordner" as it should be in my german vista version.)

The reason was that the subkeys "SHOWALL" and "NOHIDDEN" were also blanked on my system. If I could have downloaded a .reg file including these subkeys from here it would have helped me instantly, thats why I posted a .reg file including these subkeys.

I hope it's now clearer, sorry if my explanations were (are?! :p) too weird.
 
No problem Genius. I updated the tutorial to incuded the entire Hidden hey with the subkeys SHOWALL and NOHIDDEN with the reg file now.

Thank you,
Shawn
 
Top