How to disable "select entire field" when clicking with mouse?

ZPM

New Member
When clicking in a field with the mouse, it likes to select all the contents. Like this:
vista no highlight.pngvista yes highlight.png

To edit some part of the field, I then have to click again to clear the highlight, then click on the spot where I want the cursor to be. Is it possible to turn off this highlighting/select-all feature so I can just place the cursor where I want it on the first click?
 

My Computer

Ztruker

Vista Guru
Don't think so. About the best you can do is place the pointer where you want it and double click.
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro X64
    Manufacturer/Model
    Lenovo IdeaCenter K450
    CPU
    Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz, 3401 Mhz, 4 Core(s)
    Memory
    16GB
    Graphics Card(s)
    NVIDIA GeForce GTX 750, Intel(R) HD Graphics 4600
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    Samsung 27" C27F398 Curved Monitor
    Screen Resolution
    1920 x 1080 (HDMI)
    Hard Drives
    Samsung SSD 840 EVO 250GB
    Seagate ST2000NM001 2TB
    Seagate ST31500341AS 1.5TB
    PSU
    500W
    Mouse
    Lenovo USB
    Keyboard
    Dell USB
    Internet Speed
    50MB Down, 10MB Up
  • Operating System
    Windows 7 Pro X64
    Manufacturer/Model
    HP xw4400 Workstation
    CPU
    Intel Pentium D Dual 3.4Ghz
    Motherboard
    HP 0A68h
    Memory
    5GB
    Graphics card(s)
    ATI FireGL V3300
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    Acer KN242HYL 24" (KVMS)
    Screen Resolution
    1920X1080
    Hard Drives
    Seagate ST3120026As 120GB SATA (boot)
    Toshiba DT01ACA200 2TB SATA
    Mouse
    Logitech via KVMS switch
    Keyboard
    Dell USB via KVMS switch
    Internet Speed
    50 Down, 10 Up
    Other Info
    Apache Web Server since 2001

virtual6

Vista Pro
If you're referring to a Firefox address bar, this is more of a browser question rather than a Vista question.

Anyway, this "select entire field" behavior can be changed with a "about:config" setting.
Search for the two "SelectsAll" settings, and toggle the values as needed.
 

My Computer

Ztruker

Vista Guru
I didn't know that, works as you said, thanks.

Any way with IE?
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro X64
    Manufacturer/Model
    Lenovo IdeaCenter K450
    CPU
    Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz, 3401 Mhz, 4 Core(s)
    Memory
    16GB
    Graphics Card(s)
    NVIDIA GeForce GTX 750, Intel(R) HD Graphics 4600
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    Samsung 27" C27F398 Curved Monitor
    Screen Resolution
    1920 x 1080 (HDMI)
    Hard Drives
    Samsung SSD 840 EVO 250GB
    Seagate ST2000NM001 2TB
    Seagate ST31500341AS 1.5TB
    PSU
    500W
    Mouse
    Lenovo USB
    Keyboard
    Dell USB
    Internet Speed
    50MB Down, 10MB Up
  • Operating System
    Windows 7 Pro X64
    Manufacturer/Model
    HP xw4400 Workstation
    CPU
    Intel Pentium D Dual 3.4Ghz
    Motherboard
    HP 0A68h
    Memory
    5GB
    Graphics card(s)
    ATI FireGL V3300
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    Acer KN242HYL 24" (KVMS)
    Screen Resolution
    1920X1080
    Hard Drives
    Seagate ST3120026As 120GB SATA (boot)
    Toshiba DT01ACA200 2TB SATA
    Mouse
    Logitech via KVMS switch
    Keyboard
    Dell USB via KVMS switch
    Internet Speed
    50 Down, 10 Up
    Other Info
    Apache Web Server since 2001
Top