imageres.dll contains no icons

Wartarkus

New Member
Ok, I was recently doing some long need maintenance on my laptop and I fear I went to far on accident. Ok so I noticed after doing my work that all my folder icons are gone! So for example if I go to username/downloads and look there I should have some folders, a picture, a wave file and a .exe but there are no icons at all! It just shows the file name and has space where a icon should be but there is no one. Also if I right click on a link in my favorites in windows exporer and go to chance icon it says "imageres.dll contains no icons" so I figure that's the problem, but how can I fix it? Thanks!
 

My Computer

System One

  • CPU
    Intel T9300 2.5 GHz
    Memory
    4GB RAM
    Graphics Card(s)
    Nvidia 8600GTM
    Hard Drives
    7200 RPM 160GB Main Drive
    Country Flag
    usa
    State/Region Flag
    us nebraska

niemiro

Banned
Hi,

Two things: I have uploaded a new imageres.dll for you to replace your .dll with in case all else fails. You will probably need to take ownership of the old imageres.dll first, here is how:

  • Navigate to the old imageres.dll and right click on it and select Properties.
  • Under the Security tab, click Advanced.
  • Under the Owner tab, click Edit.
  • Click "Other Users and Groups".
  • Click Advanced.
  • Click "Find Now".
  • Scroll down and double click on Everyone.
  • Click OK THREE times.
  • Click Edit (now on the standard file Property window under the Security tab).
  • Click Add.
  • Click Advanced.
  • Click "Find Now".
  • Scroll down and double click on Everyone.
  • Click OK.
  • Single click on Everyone and then tick the "Full Control" box under Allow.
  • Click OK TWO times.
However, try this first. Press the Windows Key + R to open the Run dialogue. Type "cmd" and press enter. Go past the UAC prompt if necessary. In Command Prompt, type "sfc /scannow" and press enter. Let this scan finish (it will take about 15 minutes) See if this fixes the problem. Upload sfcdetails.txt so I can have a look at it for you. See full details here: http://www.vistax64.com/tutorials/66978-system-files-sfc-command.html If this does not solve the problem, try the method above.

After one of these has repaired imageres.dll, follow METHOD 1 here: http://www.vistax64.com/tutorials/117229-icon-cache-rebuild.html

Good luck,

Richard

EDIT: Forgot to upload the .dll, sorry! Will do so in a few minutes.
 

My Computer

System One

  • Name
    Richard
    Manufacturer/Model
    Dell XPS 420
    CPU
    Intel Core 2 Quad Q9300 2.50GHz
    Motherboard
    Stock Dell 0TP406
    Memory
    4 gb (DDR2 800) 400MHz
    Graphics Card(s)
    ATI Radeon HD 3870 (512 MBytes)
    Sound Card
    Onboard
    Monitor(s) Displays
    1 x Dell 2007FP and 1 x (old) Sonic flat screen
    Screen Resolution
    1600 x 1200 and 1280 x 1204
    Hard Drives
    1 x 640Gb (SATA 300)
    Western Digital: WDC WD6400AAKS-75A7B0

    1 x 1Tb (SATA 600)
    Western Digital: Caviar Black, SATA 6GB/S, 64Mb cache, 8ms
    Western Digital: WDC WD1002FAEX-00Z3A0 ATA Device
    PSU
    Stock PSU - 375W
    Case
    Dell XPS 420
    Cooling
    Stock Fan
    Mouse
    Advent Optical ADE-WG01 (colour change light up)
    Keyboard
    Dell Bluetooth
    Internet Speed
    120 kb/s
    Other Info
    ASUS USB 3.0 5Gbps/SATA 6Gbps - PCI-Express Combo Controller Card (U3S6)
    Country Flag
    uk
    State/Region Flag
    european union

niemiro

Banned

My Computer

System One

  • Name
    Richard
    Manufacturer/Model
    Dell XPS 420
    CPU
    Intel Core 2 Quad Q9300 2.50GHz
    Motherboard
    Stock Dell 0TP406
    Memory
    4 gb (DDR2 800) 400MHz
    Graphics Card(s)
    ATI Radeon HD 3870 (512 MBytes)
    Sound Card
    Onboard
    Monitor(s) Displays
    1 x Dell 2007FP and 1 x (old) Sonic flat screen
    Screen Resolution
    1600 x 1200 and 1280 x 1204
    Hard Drives
    1 x 640Gb (SATA 300)
    Western Digital: WDC WD6400AAKS-75A7B0

    1 x 1Tb (SATA 600)
    Western Digital: Caviar Black, SATA 6GB/S, 64Mb cache, 8ms
    Western Digital: WDC WD1002FAEX-00Z3A0 ATA Device
    PSU
    Stock PSU - 375W
    Case
    Dell XPS 420
    Cooling
    Stock Fan
    Mouse
    Advent Optical ADE-WG01 (colour change light up)
    Keyboard
    Dell Bluetooth
    Internet Speed
    120 kb/s
    Other Info
    ASUS USB 3.0 5Gbps/SATA 6Gbps - PCI-Express Combo Controller Card (U3S6)
    Country Flag
    uk
    State/Region Flag
    european union

Imperfect1

Vista Guru
Wow! Richard, Thanks so much. You've gone to a lot of trouble for a fellow poster. Good for you! Tried to give you a Rep+ but the system won't let me. I'll keep trying, cause you've earned it.
 

My Computer

System One

  • Name
    Sue
    Manufacturer/Model
    HP Pavillion dv5t (Gen. 1)
    CPU
    Intel(R) Core(TM)2 Duo Processor T9400 (2.53 GHz)
    Memory
    4GB DDR2 System Memory (2 Dimm)
    Graphics Card(s)
    512 MB NVIDIA GeForce 9600M GT
    Monitor(s) Displays
    15.4" diagonal WSXGA+ High-Definition HP BrightView Widescreen Display
    Screen Resolution
    1680 x 1050
    Hard Drives
    320GB 5400RPM SATA Hard Drive with HP ProtectSmart Hard Drive Protection
    Mouse
    built in - Synaptics TouchPad V6.5 on PS/2 Port
    Keyboard
    built in - HP
    Internet Speed
    max
    Occupation
    Professional
    Other Info
    ~ Intel Next-Gen Wireless-N Mini-card w/Bluetooth ~ Blu-Ray ROM DVD+/-R/RW ~ Integ. HDTV Hybrid Tuner ~ 12 Cell Battery ~ MS Office (Home Premium) 2007 ~
    Country Flag
    usa
Top