Intel Turbo Memory will not function

MackM

New Member
I have a new notebook computer - Sager NP 2096 = P8400, 4 GB RAM, 250 GB 7200rpm HD. I bought the Intel Turbo Drive option with 4 GB memory. The OS is Vista Home Premium 32-bit
Everything is running fine, except the Turbo Drive. I am well-pleased with the computer and Sager tech support has been great, except they have not been able to solve the Turbo memory problem!
I have loaded the latest driver - 1.8.0.1018 - several times. Turbo Memory Console 1.8 gets loaded, but shows both ReadyBoost and ReadyDrive as disabled. Clicking in the box to enable ReadyDrive, and rebooting, does not change the situation. (The box to enable ReadyBoost is grayed out and canot be checked.) A shortcut icon has been placed on ther desktop labeled "IntelTurbo Memory Dashboard" - clicking on this gets a error message "It apears that the Intel Turbo Memory device is not functioning properly or is not present." (I have tried two different Turbo Memory modules, same results.) Device Manager at "Storage controllers" lists "Intel Turbo Memory Controller" and right-clicking, then left-clicking on "Properties" gets the status report that"This device is working properly."
What am I doing wrong? What can I do to get Intel Turbo Memory functional? :(
 

My Computer

System One

  • Manufacturer/Model
    Sager NP 2096
    CPU
    Intel P8400
    Memory
    4 GB
    Other Info
    Intel Turbo Memory 4GB

shae

New Member
At least from what I can tell, your computer's IDE controller must be functioning in AHCI mode for Intel Turbo Cache to work. Is your computer set in that mode (check bios)?
 

My Computer

System One

  • Manufacturer/Model
    Dell Inspiron 1420
    CPU
    Intel Core 2 Duo Mobile T7500 @ 2.2Ghz
    Motherboard
    Dell Custom Intel 965 Chipset
    Memory
    2GB (2x1GB) Dual Channel DDR2 667
    Graphics Card(s)
    nVidia GeForce 8400M GS 128MB DDR3 @ 400/600

MackM

New Member
At least from what I can tell, your computer's IDE controller must be functioning in AHCI mode for Intel Turbo Cache to work. Is your computer set in that mode (check bios)?
1. Many thanks for your comment and suggestion - please excuse my delay in replying, but I had to do some research before I could make the check. With the help of Sager, I found a procedure to use. It doesn't "check" for AHCI mode, but it provides for enabling or disabling. I ran the enabling file, and then checked Turbo Memory Console = no change. Then to be sure, I ran "disable" then "enable" again = still no change.

2. Any other thoughts? Sager has suggested reinstalling Vista, but I am holding off on that as I have much else on the C drive, and the computer does work, except for ITM.
 

My Computer

System One

  • Manufacturer/Model
    Sager NP 2096
    CPU
    Intel P8400
    Memory
    4 GB
    Other Info
    Intel Turbo Memory 4GB

lordbob75

Lord of Bobs
Vista Pro
Gold Member
MackM,

To check this setting, turn off your computer. When you start up, press either DEL, ESC, F2 (or someother Fkey) that is shown at the bottom of the mobo boot screen (this is the one that says your manufacturer before Vista boots). This will bring you to the BIOS. From here, find your CD drive, and select settings. Make sure that AHCI is the option as opposed to the other one (starts with a P I think).

~Lordbob
 

My Computer

System One

  • Manufacturer/Model
    Custom
    CPU
    Intel Core 2 Quad Q8200 2.33GHz
    Motherboard
    ASUS P5QC
    Memory
    2x2GB
    Graphics Card(s)
    NVidia GeForce 9500GT 1Gb
    Sound Card
    Mobo
    Monitor(s) Displays
    Samsung SyncMaster 206bw
    Screen Resolution
    1680x1050
    Hard Drives
    Samsung SP2514N ATA 250Gb 7200RPM
    Samsung [Model] 1Tb 7200RPM SATA2
    PSU
    Cooler Master Real Power Pro 750W
    Mouse
    Razer Lachesis
    Keyboard
    Razer Tarantula
    Internet Speed
    not fast enough

Malandro

New Member
I had the same problem (again) and once had a solution. Just a minute ago I remembered. A PageFile has to be used by Vista for installing the ReadyDrive option. Don't think the pagefile is needed after ReadyDrive is activated (because I used a Vista installation for several months without the use of a pagefile and ReadyDrive just worked fine - PageFile must have been disabled AFTER installing the Intel Turbo Memory Driver - )
 

My Computer

rkent57

New Member
MALANDRO:

Not to sound stupid but where or how do I DISABLE the page file to find out if this option works?

I have a system simular to the member above and trying to remedy the same problem!!!

Thanks
 

My Computer

The Cool Guy

Power User
The page file settings are here- Navigate to "Control Panel\System and Maintenance\System" (Computer Properties) and click Advanced System Settings to your left. Go to the Advanced tab and then click Performance settings. In performance options navigate to the Advanced tab. You will find the page file settings there, rkent57.
 

My Computer

System One

  • Manufacturer/Model
    Compaq Presario C700
    CPU
    Intel Core 2 Duo 1.67 GHz
    Motherboard
    Intel GM965
    Memory
    2.5 GB (2 GB Transcend + 512MB Hyundai)
    Graphics Card(s)
    Intel Intergrated 965 Express Graphics
    Sound Card
    Conexant High Definition
    Monitor(s) Displays
    Compaq
    Screen Resolution
    1280x800
    Hard Drives
    160 GB Compaq
    Mouse
    Alps Pointing Device Touchpad
    Keyboard
    Compaq
    Internet Speed
    2 Mbps Download, 512 Kbps Upload
    Other Info
    Integrated Web-Camera
    (P.S. Have another custom-built PC with Win7 x64)

rkent57

New Member
Ok, tried what you suggested and still no change...ITM still states the same thing...not there or not working properly.

Strange how the device manager states all is fine but you can't open the dashboard manager up!

I guess MS is not concerned over this either or they would have addressed the problem for so many of us?

Thanks anyhow...
 

My Computer

The Cool Guy

Power User
Your welcome, rknet57
 

My Computer

System One

  • Manufacturer/Model
    Compaq Presario C700
    CPU
    Intel Core 2 Duo 1.67 GHz
    Motherboard
    Intel GM965
    Memory
    2.5 GB (2 GB Transcend + 512MB Hyundai)
    Graphics Card(s)
    Intel Intergrated 965 Express Graphics
    Sound Card
    Conexant High Definition
    Monitor(s) Displays
    Compaq
    Screen Resolution
    1280x800
    Hard Drives
    160 GB Compaq
    Mouse
    Alps Pointing Device Touchpad
    Keyboard
    Compaq
    Internet Speed
    2 Mbps Download, 512 Kbps Upload
    Other Info
    Integrated Web-Camera
    (P.S. Have another custom-built PC with Win7 x64)

Malandro

New Member
Your pagefile was already disabled then? The installation of the latest Intel Turbo Memory drivers have to be done while the pagefile is ENABLED.

Works for me. I disabled the ReadyBoost option though. This option makes my system boottime about 12seconds longer. Somebody knows how to use this readyboost memory for readydrive?
 

My Computer

rkent57

New Member
Malandro:
(Compal T7700 Laptop w/Vista Ultimate 32bit OS, 4gb ram and 4gb ITM chip, SP1 and all drivers/updates installed.)

Tried what you suggested above. Installed the new 1.9 driver WITH page file enabled.

I also went back into where the page file option is located AFTER the install as it still does not work and this time I selected "No Page File" AFTER it was enabled for the installation of 1.9 to see if it would fix the ITM Dashboard problem when I installed the new 1.9 driver.

Rebooted and still no luck. All I get now is a splat mark in the sys tray icon for the dashboard stating the hardware is not configured.

Still I can't open the program to do any pinning as it still states it's not there or not functioning properly. Device manager and all other places to look state the device IS properly installed and no conflicts.

I do have AHCI enabled in my BIOS (regedit also has the proper value set for AHCI to be enabled) and I did install the new 1.9 driver using the -UP extention to ensure pinning. All versions previous versions of 1.6, 1.7, 1.8 and 1.9 installed the same way.

This is an on-going problem since I first started using ITM from 1.6 and up.

When I DID get it to work many moons ago...it worked great!!!

Is there a reg edit I can review to see if anything is not properly set that you may know of? This is the only other thing I can think of? :sarc:
 
Last edited:

My Computer

rkent57

New Member
Update:

Hope I'm posting this in the correct area but for all those with the ITM problem...INSTALL the FREE Win 7 version and this will fix all ITM problems!!! I just did and Win 7 resolved many other issues as well!!! Unbelievable!!!

ITM works great and many other apps open faster and even work better.

Can't go wrong as the free Win 7 with activation code is good for a free year!

Bye-Bye Vista!!!
 

My Computer

The Cool Guy

Power User
Happy to know that your problem has been solved, rknet57. But it's just not vista which had been the problem for you. If you had clean installed vista it might have worked

Cheers..
 

My Computer

System One

  • Manufacturer/Model
    Compaq Presario C700
    CPU
    Intel Core 2 Duo 1.67 GHz
    Motherboard
    Intel GM965
    Memory
    2.5 GB (2 GB Transcend + 512MB Hyundai)
    Graphics Card(s)
    Intel Intergrated 965 Express Graphics
    Sound Card
    Conexant High Definition
    Monitor(s) Displays
    Compaq
    Screen Resolution
    1280x800
    Hard Drives
    160 GB Compaq
    Mouse
    Alps Pointing Device Touchpad
    Keyboard
    Compaq
    Internet Speed
    2 Mbps Download, 512 Kbps Upload
    Other Info
    Integrated Web-Camera
    (P.S. Have another custom-built PC with Win7 x64)

TheBoozer

New Member
PLEASE tell me how to activate ACHI in Sager 2096 laptop. There is no where in the BIOS that gives this option. My problem is that ReadyBoost is enabled but ReadyDrive is disabled and the option is grayed. I have the latest ITM driver installed.

Thank you all.
 

My Computer

System One

  • Manufacturer/Model
    sager NP2096
    CPU
    Intel Duo T9600 (2.8)
    Motherboard
    Intel Catinga PM45 + ICH9-M
    Memory
    4GB RAM + 2GB Turbo memory
    Graphics Card(s)
    Nvidea T9600M GT 512MB
    Hard Drives
    Samsung 256GB SSD Solid State

nuttifeetfirst

New Member
Very strange, firstly your bios must be set to AHCI mode and must support Sata 11 hard drives plus the turbo, the correct drivers must be installed, as at times windows tries to sometimes overide intel drivers. however your computer manufacturer should provide the latest driver
My system is 64 Bit Vista Business on a Dell Latitude D830 and presently running the 2 GB turbo upgrading to 4 GB.:)
 

My Computer

wditters

New Member
If you carfully read the Intel documentation of the Intel 4Gb Turbo Memory modules you will notice:

Intel® Turbo Memory Technology Cards

Designed for easy integration into systems, the PCIe* full-minicard and
half-mini interface card are available in 2 GB and 4 GB capacities. The
PCIe card features: one Intel® Flash Cache Logic chip, two Intel® NAND
Flash memory chips in parallel, and supports Microsoft Windows Vista*
ReadyDrive* and ReadyBoost* technologies for the 2 GB card. The
2 GB card, with a one-time OEM configurable option, can substitute
ReadyBoost for “User Pinning”; while, the 4 GB card supports
ReadyDrive and User Pinning only.

Ergo: On the 4Gb Turbo Memory modules Readyboost is supposed to be grayed out
 

My Computer

Top