issues trying to start Setup Partitions

1COMPWin7

New Member
hi there,

i am trying to boot from one of my Setup Partitions. i am trying to boot from a partition containing Windows Xp 64-bit Install Files and later a partition with Windows 7 Install Files. i have deleted all the Setup Partitions except the Windows Xp one which is being a Bi*ch and won't allow me to delete it.

these are the steps i have done to try and boot

1. Created ISO Image Windows Xp and downloaded Windows 7 build 7100
2. In Disk Management Shrink 2 Volumes on main HDD with OS (Vista) 1 being Setup Files Shrink to 700MB and OS shrink too 7GB
3. Opened cmd and input diskpart, list volume, select volume y (Setup Xp), active, exit, then xcopy... Etc.

when i rebooted i would get a bootmgr missing error and thus using my Windows Vista disc to repair. i have be doing something wrong here as i am still new to this dual booting stuff.

yes, i am trying to triple boot. Vista, Xp and Windows 7. i do know to install Xp first then Windows 7 last or does it matter?
 

My Computer

System One

  • Name
    Joseph
    Manufacturer/Model
    1COMP
    CPU
    AMD Athlon 4850e 2.5GHZ OC'ed @3.1GHZ
    Motherboard
    ASRock A780GXE/128
    Memory
    G.SKILL 4GB (2 x 2GB)
    Graphics Card(s)
    EVGA 512MB 8600GTS 706/1008MHZ (Stock Defualt)
    Sound Card
    Onboard
    Monitor(s) Displays
    19" ENVISION
    Screen Resolution
    1440x900
    Hard Drives
    320GB [OS] | 160GB [Storage] | 80GB [2nd OS] | 40GB [BAD STATUS]
    PSU
    Rosewill 450W 12v @30 Rails
    Case
    COOLER MASTER Centurion 590
    Cooling
    XIGMATEK HDT-S963 | 5 Blue LED 120mm Fans 1 Regular 120mm FA
    Mouse
    logitech 7100X? don't remember actual Model
    Keyboard
    logitech 7100X? don't remember actual Model
    Internet Speed
    DSL 3MB 370kbps Up/70kbps Down
    Occupation
    N/A
    Country Flag
    usa
    State/Region Flag
    us north carolina

rive0108

Vista Guru
Gold Member

My Computer

System One

  • Name
    Chris
    CPU
    T7600G Core2Duo 2.66 Ghz
    Motherboard
    Intel 945PM + ICH7 Chipset
    Memory
    4GB DDR2 PC2-5300 667MHz
    Graphics Card(s)
    Mobility Radeon x1900 256MB
    Sound Card
    Realtek HD
    Monitor(s) Displays
    WUXGA 17"
    Screen Resolution
    1920X1200
    Hard Drives
    640GB 7200RPM SATA/RAID 0 (2x320GB)
    and 320GB 7200RPM External
    Mouse
    Wireless Microsoft 3000
    Internet Speed
    10 mbps/2 mbps
    Occupation
    Fire Protection
    Other Info
    Optical Drive:
    Panasonic UJ-220 DL BD-RE (Blu-Ray)
    Country Flag
    usa
    State/Region Flag
    us virginia

1COMPWin7

New Member
from what i am reading whatever drive is farthest to the left will Boot first?
 

My Computer

System One

  • Name
    Joseph
    Manufacturer/Model
    1COMP
    CPU
    AMD Athlon 4850e 2.5GHZ OC'ed @3.1GHZ
    Motherboard
    ASRock A780GXE/128
    Memory
    G.SKILL 4GB (2 x 2GB)
    Graphics Card(s)
    EVGA 512MB 8600GTS 706/1008MHZ (Stock Defualt)
    Sound Card
    Onboard
    Monitor(s) Displays
    19" ENVISION
    Screen Resolution
    1440x900
    Hard Drives
    320GB [OS] | 160GB [Storage] | 80GB [2nd OS] | 40GB [BAD STATUS]
    PSU
    Rosewill 450W 12v @30 Rails
    Case
    COOLER MASTER Centurion 590
    Cooling
    XIGMATEK HDT-S963 | 5 Blue LED 120mm Fans 1 Regular 120mm FA
    Mouse
    logitech 7100X? don't remember actual Model
    Keyboard
    logitech 7100X? don't remember actual Model
    Internet Speed
    DSL 3MB 370kbps Up/70kbps Down
    Occupation
    N/A
    Country Flag
    usa
    State/Region Flag
    us north carolina

SIW2

Vista Guru
Gold Member
Hi,

It depends which is the System partition. If you had XP installed first that will probably be the System partition (unless you have changed it deliberately).

Post a screenshot of Disk Management like this:

DISKMANAGEMENT2009-02-04_031947.jpg

and of bcdedit, like this:

BCDEDIT2009-03-07_235226.jpg
 

My Computer

System One

  • Operating System
    Vista
    CPU
    Intel E8400
    Motherboard
    ASRock1333-GLAN R2.0
    Memory
    4gb DDR2 800
    Graphics Card(s)
    nvidia 9500GT 1gb

1COMPWin7

New Member
Vista is my main OS and i haven't installed Xp yet. that's what i'm trying to do. i am trying to boot from a Partition with the Setup Files in it.



 
Last edited:

My Computer

System One

  • Name
    Joseph
    Manufacturer/Model
    1COMP
    CPU
    AMD Athlon 4850e 2.5GHZ OC'ed @3.1GHZ
    Motherboard
    ASRock A780GXE/128
    Memory
    G.SKILL 4GB (2 x 2GB)
    Graphics Card(s)
    EVGA 512MB 8600GTS 706/1008MHZ (Stock Defualt)
    Sound Card
    Onboard
    Monitor(s) Displays
    19" ENVISION
    Screen Resolution
    1440x900
    Hard Drives
    320GB [OS] | 160GB [Storage] | 80GB [2nd OS] | 40GB [BAD STATUS]
    PSU
    Rosewill 450W 12v @30 Rails
    Case
    COOLER MASTER Centurion 590
    Cooling
    XIGMATEK HDT-S963 | 5 Blue LED 120mm Fans 1 Regular 120mm FA
    Mouse
    logitech 7100X? don't remember actual Model
    Keyboard
    logitech 7100X? don't remember actual Model
    Internet Speed
    DSL 3MB 370kbps Up/70kbps Down
    Occupation
    N/A
    Country Flag
    usa
    State/Region Flag
    us north carolina

rive0108

Vista Guru
Gold Member
Vista is my msin OS and i haven't installed Xp yet. that's what i'm trying to do. i am trying to boot from a Partition with the Setup Files in it.

Ok.
When you install XP it will require the Boot files be restored to the Vista/7 partition. The walkthrough will explainvhow to do it. [note the red text]
 

My Computer

System One

  • Name
    Chris
    CPU
    T7600G Core2Duo 2.66 Ghz
    Motherboard
    Intel 945PM + ICH7 Chipset
    Memory
    4GB DDR2 PC2-5300 667MHz
    Graphics Card(s)
    Mobility Radeon x1900 256MB
    Sound Card
    Realtek HD
    Monitor(s) Displays
    WUXGA 17"
    Screen Resolution
    1920X1200
    Hard Drives
    640GB 7200RPM SATA/RAID 0 (2x320GB)
    and 320GB 7200RPM External
    Mouse
    Wireless Microsoft 3000
    Internet Speed
    10 mbps/2 mbps
    Occupation
    Fire Protection
    Other Info
    Optical Drive:
    Panasonic UJ-220 DL BD-RE (Blu-Ray)
    Country Flag
    usa
    State/Region Flag
    us virginia

1COMPWin7

New Member
ok, i know all that but how do i boot from the partition to install Xp?
 

My Computer

System One

  • Name
    Joseph
    Manufacturer/Model
    1COMP
    CPU
    AMD Athlon 4850e 2.5GHZ OC'ed @3.1GHZ
    Motherboard
    ASRock A780GXE/128
    Memory
    G.SKILL 4GB (2 x 2GB)
    Graphics Card(s)
    EVGA 512MB 8600GTS 706/1008MHZ (Stock Defualt)
    Sound Card
    Onboard
    Monitor(s) Displays
    19" ENVISION
    Screen Resolution
    1440x900
    Hard Drives
    320GB [OS] | 160GB [Storage] | 80GB [2nd OS] | 40GB [BAD STATUS]
    PSU
    Rosewill 450W 12v @30 Rails
    Case
    COOLER MASTER Centurion 590
    Cooling
    XIGMATEK HDT-S963 | 5 Blue LED 120mm Fans 1 Regular 120mm FA
    Mouse
    logitech 7100X? don't remember actual Model
    Keyboard
    logitech 7100X? don't remember actual Model
    Internet Speed
    DSL 3MB 370kbps Up/70kbps Down
    Occupation
    N/A
    Country Flag
    usa
    State/Region Flag
    us north carolina

rive0108

Vista Guru
Gold Member
ok, i know all that but how do i boot from the partition to install Xp?

You create the Partition with paragon bootable partitioner, then restart, then place XP in, restart, and follow prompts to install. then you boot back into the Vista disk RE, and perform startup repair twice.
 
Last edited:

My Computer

System One

  • Name
    Chris
    CPU
    T7600G Core2Duo 2.66 Ghz
    Motherboard
    Intel 945PM + ICH7 Chipset
    Memory
    4GB DDR2 PC2-5300 667MHz
    Graphics Card(s)
    Mobility Radeon x1900 256MB
    Sound Card
    Realtek HD
    Monitor(s) Displays
    WUXGA 17"
    Screen Resolution
    1920X1200
    Hard Drives
    640GB 7200RPM SATA/RAID 0 (2x320GB)
    and 320GB 7200RPM External
    Mouse
    Wireless Microsoft 3000
    Internet Speed
    10 mbps/2 mbps
    Occupation
    Fire Protection
    Other Info
    Optical Drive:
    Panasonic UJ-220 DL BD-RE (Blu-Ray)
    Country Flag
    usa
    State/Region Flag
    us virginia

1COMPWin7

New Member
couldn't i just use easybcd for that to repair?
 

My Computer

System One

  • Name
    Joseph
    Manufacturer/Model
    1COMP
    CPU
    AMD Athlon 4850e 2.5GHZ OC'ed @3.1GHZ
    Motherboard
    ASRock A780GXE/128
    Memory
    G.SKILL 4GB (2 x 2GB)
    Graphics Card(s)
    EVGA 512MB 8600GTS 706/1008MHZ (Stock Defualt)
    Sound Card
    Onboard
    Monitor(s) Displays
    19" ENVISION
    Screen Resolution
    1440x900
    Hard Drives
    320GB [OS] | 160GB [Storage] | 80GB [2nd OS] | 40GB [BAD STATUS]
    PSU
    Rosewill 450W 12v @30 Rails
    Case
    COOLER MASTER Centurion 590
    Cooling
    XIGMATEK HDT-S963 | 5 Blue LED 120mm Fans 1 Regular 120mm FA
    Mouse
    logitech 7100X? don't remember actual Model
    Keyboard
    logitech 7100X? don't remember actual Model
    Internet Speed
    DSL 3MB 370kbps Up/70kbps Down
    Occupation
    N/A
    Country Flag
    usa
    State/Region Flag
    us north carolina

1COMPWin7

New Member
ok, tried booting from the partition with the Xp 64 Setup Files and it failed. bringing up Bootmgr missing. is this because the setup is re-writting the bootloader or what? i had to repair with the Vista Disc two times (also the Setup Files partition is set as System?!?!?!). i set the partition to active so i thought it would boot but it didn't. if this doesn't work then i'll just use from the CD. i just wanted to try from a partition cause it is faster. i know i did it while installing Windows 7 but it worked but probably because Windows 7 and Vista use the same Boot method.
 

My Computer

System One

  • Name
    Joseph
    Manufacturer/Model
    1COMP
    CPU
    AMD Athlon 4850e 2.5GHZ OC'ed @3.1GHZ
    Motherboard
    ASRock A780GXE/128
    Memory
    G.SKILL 4GB (2 x 2GB)
    Graphics Card(s)
    EVGA 512MB 8600GTS 706/1008MHZ (Stock Defualt)
    Sound Card
    Onboard
    Monitor(s) Displays
    19" ENVISION
    Screen Resolution
    1440x900
    Hard Drives
    320GB [OS] | 160GB [Storage] | 80GB [2nd OS] | 40GB [BAD STATUS]
    PSU
    Rosewill 450W 12v @30 Rails
    Case
    COOLER MASTER Centurion 590
    Cooling
    XIGMATEK HDT-S963 | 5 Blue LED 120mm Fans 1 Regular 120mm FA
    Mouse
    logitech 7100X? don't remember actual Model
    Keyboard
    logitech 7100X? don't remember actual Model
    Internet Speed
    DSL 3MB 370kbps Up/70kbps Down
    Occupation
    N/A
    Country Flag
    usa
    State/Region Flag
    us north carolina

SIW2

Vista Guru
Gold Member
Hi,

When you install XP, it will overwrite the Vista mbr,bootsector and bootfiles.

You could boot from the Vista dvd and use bootsect.exe and bcdedit from the command prompt to fix it.

Or, you could install Easybcd and .Net 2.0 framework on XP and use that.

Installing XP After Vista - NeoSmart Technologies Wiki
 

My Computer

System One

  • Operating System
    Vista
    CPU
    Intel E8400
    Motherboard
    ASRock1333-GLAN R2.0
    Memory
    4gb DDR2 800
    Graphics Card(s)
    nvidia 9500GT 1gb

1COMPWin7

New Member
no, i meant the partition wouldn't even boot at all. brought up bootmgr missing. so even trying to install Xp without the Setup screen coming up this will happen? this is awfully strange to me.
 

My Computer

System One

  • Name
    Joseph
    Manufacturer/Model
    1COMP
    CPU
    AMD Athlon 4850e 2.5GHZ OC'ed @3.1GHZ
    Motherboard
    ASRock A780GXE/128
    Memory
    G.SKILL 4GB (2 x 2GB)
    Graphics Card(s)
    EVGA 512MB 8600GTS 706/1008MHZ (Stock Defualt)
    Sound Card
    Onboard
    Monitor(s) Displays
    19" ENVISION
    Screen Resolution
    1440x900
    Hard Drives
    320GB [OS] | 160GB [Storage] | 80GB [2nd OS] | 40GB [BAD STATUS]
    PSU
    Rosewill 450W 12v @30 Rails
    Case
    COOLER MASTER Centurion 590
    Cooling
    XIGMATEK HDT-S963 | 5 Blue LED 120mm Fans 1 Regular 120mm FA
    Mouse
    logitech 7100X? don't remember actual Model
    Keyboard
    logitech 7100X? don't remember actual Model
    Internet Speed
    DSL 3MB 370kbps Up/70kbps Down
    Occupation
    N/A
    Country Flag
    usa
    State/Region Flag
    us north carolina

SIW2

Vista Guru
Gold Member
What exactly do you mean "booting from the partition with the XP setup files".

Do you have a setup.exe file among the XP installation files?
 

My Computer

System One

  • Operating System
    Vista
    CPU
    Intel E8400
    Motherboard
    ASRock1333-GLAN R2.0
    Memory
    4gb DDR2 800
    Graphics Card(s)
    nvidia 9500GT 1gb

1COMPWin7

New Member
What exactly do you mean "booting from the partition with the XP setup files".

Do you have a setup.exe file among the XP installation files?
yes, i have a Xp 64 CD. all i did was created a ISO Image of the Disc with ImageBurn. i used Diskpart from cmd to exract the Files from the ISO to the 700MB Partition.

as i said before the partition will not boot! everytime i have tried, it brings up bootmgr missing.

Edit: yes, there is a Setup.exe in the partition.
 

My Computer

System One

  • Name
    Joseph
    Manufacturer/Model
    1COMP
    CPU
    AMD Athlon 4850e 2.5GHZ OC'ed @3.1GHZ
    Motherboard
    ASRock A780GXE/128
    Memory
    G.SKILL 4GB (2 x 2GB)
    Graphics Card(s)
    EVGA 512MB 8600GTS 706/1008MHZ (Stock Defualt)
    Sound Card
    Onboard
    Monitor(s) Displays
    19" ENVISION
    Screen Resolution
    1440x900
    Hard Drives
    320GB [OS] | 160GB [Storage] | 80GB [2nd OS] | 40GB [BAD STATUS]
    PSU
    Rosewill 450W 12v @30 Rails
    Case
    COOLER MASTER Centurion 590
    Cooling
    XIGMATEK HDT-S963 | 5 Blue LED 120mm Fans 1 Regular 120mm FA
    Mouse
    logitech 7100X? don't remember actual Model
    Keyboard
    logitech 7100X? don't remember actual Model
    Internet Speed
    DSL 3MB 370kbps Up/70kbps Down
    Occupation
    N/A
    Country Flag
    usa
    State/Region Flag
    us north carolina

SIW2

Vista Guru
Gold Member
Your HD is already bootable - you can boot into Vista.

Mark the Vista partition Active - you will need that to be the Active partition, or it will get messy.

Download and install the free Daemon Tools Lite. Mount the XP .iso - run XP setup from the virtual drive.

Downloads :: DAEMON-Tools.cc


When XP asks where you want to install it, point it to the partition you created to install it onto.

When it is installed, you will only be able to boot into XP - follow the instructions at this link to get the ability to boot into Vista.

Installing XP After Vista - NeoSmart Technologies Wiki
 

My Computer

System One

  • Operating System
    Vista
    CPU
    Intel E8400
    Motherboard
    ASRock1333-GLAN R2.0
    Memory
    4gb DDR2 800
    Graphics Card(s)
    nvidia 9500GT 1gb

SIW2

Vista Guru
Gold Member
FYI - you got the bootmgr is missing message because the Program Loader ( the first bit of code to run during the boot process- it is on the first track of the HD) - will only look at the active partition - where bootmgr ought to be.

Since you marked a different partition as active , bootmgr was not there - (it is still on Vista partition) - hence the bootmr is missing message - which means bootmgr is not on the partition that is currently marked active.
 

My Computer

System One

  • Operating System
    Vista
    CPU
    Intel E8400
    Motherboard
    ASRock1333-GLAN R2.0
    Memory
    4gb DDR2 800
    Graphics Card(s)
    nvidia 9500GT 1gb

1COMPWin7

New Member
aww... ok and thanks for the quick tip. i should of known to do this earlier. thanks for the help man. thanks also for your time in trying to help.
 

My Computer

System One

  • Name
    Joseph
    Manufacturer/Model
    1COMP
    CPU
    AMD Athlon 4850e 2.5GHZ OC'ed @3.1GHZ
    Motherboard
    ASRock A780GXE/128
    Memory
    G.SKILL 4GB (2 x 2GB)
    Graphics Card(s)
    EVGA 512MB 8600GTS 706/1008MHZ (Stock Defualt)
    Sound Card
    Onboard
    Monitor(s) Displays
    19" ENVISION
    Screen Resolution
    1440x900
    Hard Drives
    320GB [OS] | 160GB [Storage] | 80GB [2nd OS] | 40GB [BAD STATUS]
    PSU
    Rosewill 450W 12v @30 Rails
    Case
    COOLER MASTER Centurion 590
    Cooling
    XIGMATEK HDT-S963 | 5 Blue LED 120mm Fans 1 Regular 120mm FA
    Mouse
    logitech 7100X? don't remember actual Model
    Keyboard
    logitech 7100X? don't remember actual Model
    Internet Speed
    DSL 3MB 370kbps Up/70kbps Down
    Occupation
    N/A
    Country Flag
    usa
    State/Region Flag
    us north carolina
Top