• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Lenovo laptop says connected to internet, but isn't

#1
My Lenovo laptop with Vista Premium Home says it is connected to my wireless network, both local and internet, but only local connection is working. I cannot connect to the internet with either Firefox or IE. I cannot ping websites (e.g. Yahoo.com). I can ping my router (Linksys WCG200) and visa versa. I can see local shares just fine.

AVG antivirus and ZoneAlarm are turned off (during troubleshooting only). When I turn on AVG antivirus and tell it to update, it fails - no connection.

From ipconfig/all:

Windows IP Configuration
Host Name - Tablet
Primary Dns Suffix - (blank)
Module Type - Hybrid
IP Routing Enabled - No
WINS Proxy Enabled - No
DNS Suffix Search List - hsd1.nm.comcast.net

Wireless LAN adapter Wireless Network Connection:
Connection-specific DNS suffix - hsd1.nm.comcast.net
Intel (R) Wireless WiFi Link 4965AGN
Physicall Address - 00-13-E8-DC-B7-59
DHCP Enabled - Yes
Autoconfiguration Enabled - Yes
IPv4 Address - 192.168.0.16 (Preferred)
Default Gateway - 192.168.0.1
DHCP Server - 192.168.0.1
DNS Servers - 68.87.85.98
68.87.69.146
68.87.78.130
NetBIOS over Tcpip - Enabled

It's got to be something simple, but I've got burnout from troubleshooting and web surfing for solutions.

Any ideas/suggestions would be greatly appreciated? Thanks in advance.
 
#2
Why don't you uninstall your firewalls, sometimes the services are still running even although you kill the task. Also, provide the output from an "IPCONFIG /ALL" at the MS-DOS prompt. Also, go to your router's home page (http://192.168.0.1?) and try a ping from there, I have D-Link but there's a tool in there to try pinging, at least you'll know if the connection from the router to the Internet works.
 
#3
I mis-spoke originally. I did uninstall ZoneAlarm, but I did not uninstall Windows firewall. My original post has the IPCONFIG/ALL info.

I can ping the router from the Lenovo. I CANNOT ping the Lenovo from the router. I CAN ping other machines in the network from the router. I CAN ping my ISP (Comcast) from the router, but not other internet sites. This may be normal, however. I don't know.
 
#4
Sorry I didn't recognize the format of your IPCONFIG /ALL, I now see that's what it is.

So you can't ping www.yahoo.com from your router? In that case I'd say that's the first problem. I'd say the goal is to get the router to see the Internet, then the Lenovo to see the router.

Good that ZoneAlarm is uninstalled, you won't be able to uninstall the Windows firewall, only via SERVICES.MSC (at the Windows Run prompt) and disable the Windows Firewall service can you stop it.

You should be able to ping anything from your Router. Check the manual for your Linksys WGC200 and see if that's supposed to be possible.