Logitech mouse crashing windows?

M

mdiemer

Anyone have this happen? Lately my computer is crashing when I move my logitech mouse. Usually, it happens when I use the scroll wheel. The computer just shuts down. No BSOD or warning. It's only happening on my Vista drive. Doesn't happen on W7 drive. Could it be a driver issue? It just started to happen recently, after many months of use.
 

My Computer

M

mdiemer

Now the problem is happening with my Gateway corded-mouse as well. Now and then, when I use scroll button, the computer just shuts off. So it's not a Logitech issue, as it happens with whatever mouse I use. So I wonder if it's a virus, or something peculiar to Vista? I did scan with Malwarebites, but it found nothing. Really at a loss. Would love to use Vista as main drive again!
 

My Computer

M

mdiemer

Why is this in the wrong forum? I'm pretty sure I posted it in the 'crashes' etc forum. No wonder I'm not getting any replies!
 

My Computer

Patonb

Vista Guru
Gold Member
Ha, Have you tried different usb ports?
Could be a bad port.
 

My Computer

System One

  • CPU
    Dual L5639 // i7 950 @ 4.0Ghz
    Motherboard
    Evga SR-2 // Gigabyte x58a-ud3r
    Memory
    12Gig Corsair XMS3 // 6Gig OCZ Gold
    Graphics Card(s)
    gtx 560 ti // gtx 260-216
    Monitor(s) Displays
    Dual 22" // Headless
    Hard Drives
    OCZ aGILITY 3, 120Gig + Seagate 500Gig x 2
    PSU
    Silverstone da700 // Corsair 520hx
    Case
    Rosewill BlackHawk Ultra // Antec 900v1
    Cooling
    Twin CM Hyper 212+ // Noctua NH-u12
    Other Info
    Acer 8930 laptop with x9100...

Patonb

Vista Guru
Gold Member
Weird, don't know.
 

My Computer

System One

  • CPU
    Dual L5639 // i7 950 @ 4.0Ghz
    Motherboard
    Evga SR-2 // Gigabyte x58a-ud3r
    Memory
    12Gig Corsair XMS3 // 6Gig OCZ Gold
    Graphics Card(s)
    gtx 560 ti // gtx 260-216
    Monitor(s) Displays
    Dual 22" // Headless
    Hard Drives
    OCZ aGILITY 3, 120Gig + Seagate 500Gig x 2
    PSU
    Silverstone da700 // Corsair 520hx
    Case
    Rosewill BlackHawk Ultra // Antec 900v1
    Cooling
    Twin CM Hyper 212+ // Noctua NH-u12
    Other Info
    Acer 8930 laptop with x9100...
M

mdiemer

Yes it is weird! Fortunately it only happens occasionally. It's been OK the last 2 days.
 

My Computer

M

mdiemer

Status report on this problem: The latest thing I have tried is to disable smooth scrolling on the Logitech utility software. Maybe this is the issue here. The problem seems to happen when I am using the scroller and also moving the mouse, just kind of drifting so to speak.
 

My Computer

richc46

Vista Guru
Gold Member
I have a Logitech Wireless and no problem. You may want to try another mouse to see if the problem continues. If it does at least we know it is not the mouse.
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT
M

mdiemer

Thanks Rich for reminding me: It does happen with a wired mouse. I'd forgotten about that.

For the latest update: I have reinstalled my 8400GS card, as this could be a graphics problem. Previously, I had taken it out because I was getting display driver failures. I discovered recently however that they were due to bad memory. So I put the card back in. So far, graphics are improved and no DDFs. And no mouse-related crashes so far.
 

My Computer

Top