Logon Automatically

ByLine
How to Log On Automatically at Startup in Vista
Synopsis
This will show you how to set or change a user account for Vista to automatically log on to at startup. By default all user accounts must log on at startup.
How to Log on Automatically at Startup in Vista


information   Information
This will show you how to set or change a user account for Vista to automatically log on to at startup. By default all user accounts must log on at startup.
Note   Note

  • If you only have one user account without a password on your computer, then Vista will logon to that account automatically at startup.
  • If you have more than one user account and the one you want to have Vista logon to automatically at startup does not have a password, then leave the password fields blank in step 7 below.
  • If you forgot or lost the password for a user account, then see: How to Reset a User Account Password in Vista
  • If your computer is a member of a domain, then the check box for Users must enter a user name and password to use this computer will not be available. It will be grayed out instead.
warning   Warning
Be sure to enter the correct password for the selected user account to have Vista automatically log on to at startup. If this user account does not have a password, then leave it blank. If you change the user account password, be sure to change it here as well. If you enter or have a incorrect password for this user account you will get a Incorrect Password error at the next startup. When you click OK to this at the logon screen, you will then see a duplicate logon icon for this user account. You can fix this problem by loging on to another account, or boot into Safe mode, and change the password to the correct one in step 7 below and restart again.

EXAMPLE: Log On Screen
NOTE:
With Automatic Log On, you will not see this anymore. Vista will boot into the desktop of the selected user account instead.
Logon_Screen.jpg


Here's How:
1. Open the Start Menu.​
2. In the white line (Start Search) area, type netplwiz or control userpasswords2 and press Enter.​
NOTE: It is your choice on which one to type. They both open the same window.
3. Click on Continue in the UAC prompt.​
4. To Turn On Automatic Log On for a User Account
A) Check the Users must enter a user name and password to use this computer box. (See screenshot below step 6)​
B) Click on the user account name, that you want to have automatically log on at startup, to highlight it.​
C) Uncheck the Users must enter a user name and password to use this computer box.​
D) Click on OK.​
E) Go to step 7.​

5. To Turn Off Automatic Log On
A) Check the Users must enter a user name and password to use this computer box. (See screenshot below step 6)​
B) Click on OK.​
C) Your done.​

6. To Choose a Different User Account to Automatically Log On to
NOTE: For this step, you would have already had a user account selected to log on to automatically in step 4.​
A) Check the Users must enter a user name and password to use this computer box. (See screenshot below)​
B) Click on Apply.​
C) Select the other user account name, that you want to have automatically log on at startup instead, to highlight it.​
D) Uncheck the Users must enter a user name and password to use this computer box.​
E) Click on OK.​
Users.jpg


7. Enter the User Account Password
A) In the Password field, enter the selected user account's password. (See screenshot below)​
NOTE: If the user account does not have a password, then leave this field empty. See the WARNING at the top of the tutorial.​
B) In the Confirm Password field, enter the selected user account's password again to confirm that it is the same as in step 7A.​
NOTE: Be sure to enter the correct password for this user account. If this user account does not have a password, then leave it empty. See the WARNING at the top of the tutorial.
C) Click on OK.​
pass.jpg


That's it,
Shawn


Related Tutorials


 
Last edited by a moderator:
Shawn Brink

Comments

Andy,

Double check you BIOS settings to make sure they are set to allow USB at boot, then see if it works. :)
 
I did as you said. The only thing not set was Legacy USB Support so I enabled it, which did nothing. Since I was able to get to the BIOS, I didn't think it would work anyway.

I was also having problems accessing Asus Express Gate so I thought that might be related. I then moved the receiver to a different USB port and Express Gate worked, but this bypass did not. I moved the receiver back and again had the problem with Express Gate. I uninstalled the Logitech software and uninstalled hidden HID-Compliant Devices, Mice, and Keyboards in Device Manager. I put the receiver back where it should be and installed the software.

I have now fixed Express Gate, but this bypass auto-login keystroke still doesn't work. There was also an incident where the BIOS changed the boot disk assignment which confused me for a couple hours as I did constant startup repairs but that's a different issue.
 
Keep playing with the bypass to see if you may get it to work for you. You only have a few brief seconds to press the keys. If you miss that window of time, it won't work. It can be a bit tricky to get it just right.
 
It works with my old PS2 keyboard, but not with my Wireless USB keyboard. I guess I'll have to live without it unless there's another way of getting to the registry without going through the default profile.
 
All USB settings were enabled in the BIOS, I also re-flashed the BIOS. It was already at the latest version. The keyboard works with ASUS Express Gate and also allows me into the BIOS which means the computer is getting keypresses from the keyboard.

20150514_114855[1].jpg

This is a snapshot of my USB Configuration page of my BIOS. I didn't change anything. However, when I exited, the BIOS changed my Hard Disk Boot Priority on its own and added a non-system disk and two USB devices as boot devices before my system disk. So it wouldn't boot because it was a non-system disk. Also, my mouse which also uses the same Unifying USB receiver no longer works for Express Gate. It worked before today. I am seriously frustrated at this point.
 
Last edited:
In that case, it appears to come down to timing and pressing the key at that very limited time frame to do so. :(
 
I had already done that before and it didn't help so I put it back. The thing is that people have had this trouble and MS has put out hotfixes, but only for XP, 7, and 8. They skipped Vista.
 
Holding down a shift key or repeatedly tapping a shift key not only failed, but brought up multiple dialog boxes asking me if I wanted to start Sticky Keys. I finally got it to work by pressing alternating shift keys very quickly. It only worked if I started pressing while the little bar that goes back and forth was visible. I tried using alternating shift keys with one hand, but I was too slow, so handicapped people can't do it that way. So I tried tapping on a single shift key in double time. It worked, but my wrist almost tired out in the process plus I got the multiple Sticky Key dialogs.

Windows must check in two or more places during boot up to see if you reaaaalllly want to bypass the autologon. I tried starting later or ending earlier and it failed. It's not very user friendly.
 
Yeah, you can only doing it during boot when that bar is showing.

It's about like pressing F8 at boot for advanced boot options. You only have that one or two seconds to do it.
 
Top