Memory card slot not recognized on printer

sannallett

New Member
My printer's memory card slot isn't recognized by my computer. I am running Vista. Can anyone help with this. I contacted the printer's tech support and they tried but said it was a Microsoft problem.
 

My Computer

derekimo

Moderator
Welcome sannallett,
Sounds like a tech support answer. What is the Brand and Model of the printer?
In Device Manager under your Printer is there a notification sign?
 

My Computer

System One

  • Manufacturer/Model
    Self Built
    CPU
    Intel I5-2500K @3.3GHz
    Motherboard
    Asrock P67 Extreme4
    Memory
    16GB G.Skill Ripjaws X (4x4GB)
    Graphics Card(s)
    EVGA GeForce 750 Ti SC 2GB
    Sound Card
    ASUS Xonar DG 5.1 Channels 24-bit 96KHz PCI Interface Sound
    Monitor(s) Displays
    auria eq2367
    Screen Resolution
    1920 x 1080
    Hard Drives
    250GB Samsung 850 EVO SSD
    1TB WD Blue
    1TB Hitachi
    PSU
    SeaSonic X 650W 80 Plus Gold
    Case
    Corsair Obsidian 750D
    Cooling
    Corsair H60, Three 140mm case fans
    Mouse
    Logitech Wireless Mouse M310
    Keyboard
    Logitech Wireless Keyboard K520
    Internet Speed
    Wave Broadband ~ 100 down 5 Up
    Other Info
    Laptop specs: HP g7-1365dx /
    CPU: AMD A6-3420M APU with Radeon(tm) HD Graphics /
    RAM: Crucial 8Gb (2x4Gb) /
    SSD: Crucial M4-CT128M4SSD2 ATA Device/ FW 000F /
    GFX: AMD Radeon HD 6520G /
    OS: Windows 10 Pro x64

sannallett

New Member
I have checked the device manager list and it is all clear. This is an Epson NX515 and I spent almost an hour with their tech support but they ended up telling me it was a problem with Vista.
 

My Computer

derekimo

Moderator
Well to be honest I can't find a specific answer to your problem, I looked for your printer on the compatibility list and didn't see it, that doesn't mean it won't work they just don't have it listed.
You might want to try the Microsoft Solution Center Hardware devices not detected or not working
Or keep checking back to see if someone else has an answer for you.

I'm guessing you have already tried the troubleshooting option on the Epson Site,
Epson Stylus NX515, Overview - Technical Support - Epson America, Inc.

Sorry I couldn't be more help.
 

My Computer

System One

  • Manufacturer/Model
    Self Built
    CPU
    Intel I5-2500K @3.3GHz
    Motherboard
    Asrock P67 Extreme4
    Memory
    16GB G.Skill Ripjaws X (4x4GB)
    Graphics Card(s)
    EVGA GeForce 750 Ti SC 2GB
    Sound Card
    ASUS Xonar DG 5.1 Channels 24-bit 96KHz PCI Interface Sound
    Monitor(s) Displays
    auria eq2367
    Screen Resolution
    1920 x 1080
    Hard Drives
    250GB Samsung 850 EVO SSD
    1TB WD Blue
    1TB Hitachi
    PSU
    SeaSonic X 650W 80 Plus Gold
    Case
    Corsair Obsidian 750D
    Cooling
    Corsair H60, Three 140mm case fans
    Mouse
    Logitech Wireless Mouse M310
    Keyboard
    Logitech Wireless Keyboard K520
    Internet Speed
    Wave Broadband ~ 100 down 5 Up
    Other Info
    Laptop specs: HP g7-1365dx /
    CPU: AMD A6-3420M APU with Radeon(tm) HD Graphics /
    RAM: Crucial 8Gb (2x4Gb) /
    SSD: Crucial M4-CT128M4SSD2 ATA Device/ FW 000F /
    GFX: AMD Radeon HD 6520G /
    OS: Windows 10 Pro x64
Top