• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Need flash player, can't download it. Help!

amplid

Vlaming
Power User
#1
I want to play call of duty 2 again, but I haven't got flash player installed on my pc anymore since I got Vista. Anyone know a good patch because every time I download flash player from the adobe website, I either get nothing at all or can't find the program except in my 'programs and features' on the control panel. There I see the flash player icon, with a BIG RED CROSS in the upper right corner and I'm sure it's not supposed to be there.

Some help plz:p

Amplid
 

My Computer

System One

  • CPU
    Intel Q9550 @ 3.2 GHz (for now)
    Motherboard
    Asus ROG Striker 2 Extreme
    Memory
    2 x 2Gb Patriot DDR3
    Graphics Card(s)
    XFX GeForce 9800 GTX+
    Sound Card
    Creative Supreme FX 2
    Monitor(s) Displays
    Neovo F417 17''
    Screen Resolution
    1280x1024
    Hard Drives
    Samsung SP2504C SATA 7200rpm
    PSU
    Pc Power & Cooling 750
    Case
    Coolermaster CM 690
    Cooling
    6 120mm's, Xigmatek HDT 1283 with crossbow backplate
    Mouse
    Logitech Cordless Trackman Wheel
    Keyboard
    Logitech G11
    Internet Speed
    ~1000 Kb/sec

roy69

47,65,65,6B
Vista Guru
Gold Member
#2
Make sure you download it using the 32bit version of explorer. Flash is not compatable with 64bit versions.
 

My Computer

System One

  • Manufacturer/Model
    Self Built
    CPU
    I5 3570K
    Motherboard
    Gigabyte Z77-DS3H
    Memory
    4 x 4GB corsair ballistix sport DDR3 1600 Mhz
    Graphics Card(s)
    Gigabyte Geforce GTX 660 TI
    Sound Card
    creative x-fi
    Monitor(s) Displays
    Primary CiBox 22" Widescreen LCD ,Secondary Dell 22" Widescreen
    Screen Resolution
    Both 1680 x 1050
    Hard Drives
    2 x 500G HD (SATA) 1 x 2TB USB
    PSU
    Corsair HX 620W ATX2.2 Modular SLI Complient PSU
    Case
    Antec 900 Ultimate Gaming Case
    Cooling
    3 x 80mm tri led front, 120mm side 120mm back, 200mm top
    Mouse
    Technika TKOPTM2
    Keyboard
    Logik
    Internet Speed
    288 / 4000
    Other Info
    Creative Inspire 7.1 T7900 Speakers
    Trust Graphics Tablet

amplid

Vlaming
Power User
#3
And how do I know with what version of internet explorer I'm downloading it?

Amplid
 

My Computer

System One

  • CPU
    Intel Q9550 @ 3.2 GHz (for now)
    Motherboard
    Asus ROG Striker 2 Extreme
    Memory
    2 x 2Gb Patriot DDR3
    Graphics Card(s)
    XFX GeForce 9800 GTX+
    Sound Card
    Creative Supreme FX 2
    Monitor(s) Displays
    Neovo F417 17''
    Screen Resolution
    1280x1024
    Hard Drives
    Samsung SP2504C SATA 7200rpm
    PSU
    Pc Power & Cooling 750
    Case
    Coolermaster CM 690
    Cooling
    6 120mm's, Xigmatek HDT 1283 with crossbow backplate
    Mouse
    Logitech Cordless Trackman Wheel
    Keyboard
    Logitech G11
    Internet Speed
    ~1000 Kb/sec

roy69

47,65,65,6B
Vista Guru
Gold Member
#4
The 64 bit version tells you it is 64 bit.
To be totaly sure, use a different browser to download it.
 

My Computer

System One

  • Manufacturer/Model
    Self Built
    CPU
    I5 3570K
    Motherboard
    Gigabyte Z77-DS3H
    Memory
    4 x 4GB corsair ballistix sport DDR3 1600 Mhz
    Graphics Card(s)
    Gigabyte Geforce GTX 660 TI
    Sound Card
    creative x-fi
    Monitor(s) Displays
    Primary CiBox 22" Widescreen LCD ,Secondary Dell 22" Widescreen
    Screen Resolution
    Both 1680 x 1050
    Hard Drives
    2 x 500G HD (SATA) 1 x 2TB USB
    PSU
    Corsair HX 620W ATX2.2 Modular SLI Complient PSU
    Case
    Antec 900 Ultimate Gaming Case
    Cooling
    3 x 80mm tri led front, 120mm side 120mm back, 200mm top
    Mouse
    Technika TKOPTM2
    Keyboard
    Logik
    Internet Speed
    288 / 4000
    Other Info
    Creative Inspire 7.1 T7900 Speakers
    Trust Graphics Tablet

amplid

Vlaming
Power User
#5
Okay so my Vista is the 64 bit version, so internet explorer is 64 bit too. A different browser is like Mozilla or something, right?

Amplid
 

My Computer

System One

  • CPU
    Intel Q9550 @ 3.2 GHz (for now)
    Motherboard
    Asus ROG Striker 2 Extreme
    Memory
    2 x 2Gb Patriot DDR3
    Graphics Card(s)
    XFX GeForce 9800 GTX+
    Sound Card
    Creative Supreme FX 2
    Monitor(s) Displays
    Neovo F417 17''
    Screen Resolution
    1280x1024
    Hard Drives
    Samsung SP2504C SATA 7200rpm
    PSU
    Pc Power & Cooling 750
    Case
    Coolermaster CM 690
    Cooling
    6 120mm's, Xigmatek HDT 1283 with crossbow backplate
    Mouse
    Logitech Cordless Trackman Wheel
    Keyboard
    Logitech G11
    Internet Speed
    ~1000 Kb/sec

amplid

Vlaming
Power User
#6
Roy, I just installed it with Mozilla Firefox and just like in internet explorer it installed in less than 2 seconds....? Here's the icon I get when I open my programs and features window on the control panel:

Capture.JPG

Amplid
 

My Computer

System One

  • CPU
    Intel Q9550 @ 3.2 GHz (for now)
    Motherboard
    Asus ROG Striker 2 Extreme
    Memory
    2 x 2Gb Patriot DDR3
    Graphics Card(s)
    XFX GeForce 9800 GTX+
    Sound Card
    Creative Supreme FX 2
    Monitor(s) Displays
    Neovo F417 17''
    Screen Resolution
    1280x1024
    Hard Drives
    Samsung SP2504C SATA 7200rpm
    PSU
    Pc Power & Cooling 750
    Case
    Coolermaster CM 690
    Cooling
    6 120mm's, Xigmatek HDT 1283 with crossbow backplate
    Mouse
    Logitech Cordless Trackman Wheel
    Keyboard
    Logitech G11
    Internet Speed
    ~1000 Kb/sec

roy69

47,65,65,6B
Vista Guru
Gold Member
#7

My Computer

System One

  • Manufacturer/Model
    Self Built
    CPU
    I5 3570K
    Motherboard
    Gigabyte Z77-DS3H
    Memory
    4 x 4GB corsair ballistix sport DDR3 1600 Mhz
    Graphics Card(s)
    Gigabyte Geforce GTX 660 TI
    Sound Card
    creative x-fi
    Monitor(s) Displays
    Primary CiBox 22" Widescreen LCD ,Secondary Dell 22" Widescreen
    Screen Resolution
    Both 1680 x 1050
    Hard Drives
    2 x 500G HD (SATA) 1 x 2TB USB
    PSU
    Corsair HX 620W ATX2.2 Modular SLI Complient PSU
    Case
    Antec 900 Ultimate Gaming Case
    Cooling
    3 x 80mm tri led front, 120mm side 120mm back, 200mm top
    Mouse
    Technika TKOPTM2
    Keyboard
    Logik
    Internet Speed
    288 / 4000
    Other Info
    Creative Inspire 7.1 T7900 Speakers
    Trust Graphics Tablet

Brink

Staff member
mvp
#8
Hi Amplid,

You can check what version of IE7 your are in by clicking on Help and About Internet Explorer. As Roy posted, it will have 64 bit listed of you are, otherwise you are in the correct 32 bit IE7.


You might try the Adobe Flash Player uninstaller program to remove it from your computer first:

How to uninstall the Adobe Flash Player plug-in and ActiveX control


then see if it will install from here:

http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash&promoid=BIOW


Hope this helps you,
Shawn
 

My Computers

System One System Two

  • Show second system?
    Yes
    Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    PSU
    Seasonic Prime Titanium 850W
    Case
    Corsair Air 740
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master
    Keyboard
    Logitech wireless K800
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Creative F200 webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD

amplid

Vlaming
Power User
#9
Huh, Brink it says I have 256 bit...

Amplid

Capture00.JPG
 

My Computer

System One

  • CPU
    Intel Q9550 @ 3.2 GHz (for now)
    Motherboard
    Asus ROG Striker 2 Extreme
    Memory
    2 x 2Gb Patriot DDR3
    Graphics Card(s)
    XFX GeForce 9800 GTX+
    Sound Card
    Creative Supreme FX 2
    Monitor(s) Displays
    Neovo F417 17''
    Screen Resolution
    1280x1024
    Hard Drives
    Samsung SP2504C SATA 7200rpm
    PSU
    Pc Power & Cooling 750
    Case
    Coolermaster CM 690
    Cooling
    6 120mm's, Xigmatek HDT 1283 with crossbow backplate
    Mouse
    Logitech Cordless Trackman Wheel
    Keyboard
    Logitech G11
    Internet Speed
    ~1000 Kb/sec

scrooge

Member
Vista Pro
#10
anyone no why Flash is not compatable with 64bit versions yet?
will thay be making a 64bit version?
scrooge
 

My Computer

System One

  • CPU
    Intel Core 2 Duo E8400 / 3.00
    Motherboard
    ASUS P5K-E/WIFI-AP LGA 775 Int
    Memory
    G.SKILL 4GB (2 x 2GB)
    Graphics Card(s)
    SAPPHIRE 100225L Radeon HD 387
    Hard Drives
    1 x 1tb western digital
    4 x 250 western digital
    2 x 160 western digital
    1 x 320 western digital

amplid

Vlaming
Power User
#11
Yeah scrooge I'm trying to work that out too. Do you also have this icon in your programs menu after downloading flash player:


??

Amplid

Capture000.JPG
 

My Computer

System One

  • CPU
    Intel Q9550 @ 3.2 GHz (for now)
    Motherboard
    Asus ROG Striker 2 Extreme
    Memory
    2 x 2Gb Patriot DDR3
    Graphics Card(s)
    XFX GeForce 9800 GTX+
    Sound Card
    Creative Supreme FX 2
    Monitor(s) Displays
    Neovo F417 17''
    Screen Resolution
    1280x1024
    Hard Drives
    Samsung SP2504C SATA 7200rpm
    PSU
    Pc Power & Cooling 750
    Case
    Coolermaster CM 690
    Cooling
    6 120mm's, Xigmatek HDT 1283 with crossbow backplate
    Mouse
    Logitech Cordless Trackman Wheel
    Keyboard
    Logitech G11
    Internet Speed
    ~1000 Kb/sec

scrooge

Member
Vista Pro
#12
no i can use the 32bit just fine . but a ( 64bit os ) has been out for some time now .i'd
think thay could make one by now . may be it's just not needed or something like that.
i like using the 64bit browser ( why i don't no ) i just do . but the the popup to install flash is getting old .
scrooge
 

My Computer

System One

  • CPU
    Intel Core 2 Duo E8400 / 3.00
    Motherboard
    ASUS P5K-E/WIFI-AP LGA 775 Int
    Memory
    G.SKILL 4GB (2 x 2GB)
    Graphics Card(s)
    SAPPHIRE 100225L Radeon HD 387
    Hard Drives
    1 x 1tb western digital
    4 x 250 western digital
    2 x 160 western digital
    1 x 320 western digital

Brink

Staff member
mvp
#13
Amplid,

That would be 32 bit IE7. The 256 bit is just the encryption strength. Both versions of IE7 have 256 bit.


Try using the Adobe uninstaller program in the above post.

This is what it will look like for the 64 bit IE7. Notice the area boxed in red.

64_IE7.jpg

Shawn
 

My Computers

System One System Two

  • Show second system?
    Yes
    Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    PSU
    Seasonic Prime Titanium 850W
    Case
    Corsair Air 740
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master
    Keyboard
    Logitech wireless K800
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Creative F200 webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD

amplid

Vlaming
Power User
#14
Brink, he just won't pull it off. This time I didn't even get the installation movie showing it was installed, just this icon in my programs and features on the CP:

Capture0000.JPG

Amplid
 

My Computer

System One

  • CPU
    Intel Q9550 @ 3.2 GHz (for now)
    Motherboard
    Asus ROG Striker 2 Extreme
    Memory
    2 x 2Gb Patriot DDR3
    Graphics Card(s)
    XFX GeForce 9800 GTX+
    Sound Card
    Creative Supreme FX 2
    Monitor(s) Displays
    Neovo F417 17''
    Screen Resolution
    1280x1024
    Hard Drives
    Samsung SP2504C SATA 7200rpm
    PSU
    Pc Power & Cooling 750
    Case
    Coolermaster CM 690
    Cooling
    6 120mm's, Xigmatek HDT 1283 with crossbow backplate
    Mouse
    Logitech Cordless Trackman Wheel
    Keyboard
    Logitech G11
    Internet Speed
    ~1000 Kb/sec

amplid

Vlaming
Power User
#15
And there is something in their support section about registry permission issues and SubInAcl. What's that about?



Amplid
 

My Computer

System One

  • CPU
    Intel Q9550 @ 3.2 GHz (for now)
    Motherboard
    Asus ROG Striker 2 Extreme
    Memory
    2 x 2Gb Patriot DDR3
    Graphics Card(s)
    XFX GeForce 9800 GTX+
    Sound Card
    Creative Supreme FX 2
    Monitor(s) Displays
    Neovo F417 17''
    Screen Resolution
    1280x1024
    Hard Drives
    Samsung SP2504C SATA 7200rpm
    PSU
    Pc Power & Cooling 750
    Case
    Coolermaster CM 690
    Cooling
    6 120mm's, Xigmatek HDT 1283 with crossbow backplate
    Mouse
    Logitech Cordless Trackman Wheel
    Keyboard
    Logitech G11
    Internet Speed
    ~1000 Kb/sec
#16
Brink, he just won't pull it off. This time I didn't even get the installation movie showing it was installed, just this icon in my programs and features on the CP:

View attachment 3563

Amplid
Hi Amplid,

I believe that that icon is for the flash player uninstall program. I have the same icon in my CP/programs & features, and the player is working fine for me. I did have to go through the Adobe uninstall/reinstall directions a couple times before it took, but got it.

Gary
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    CPU
    Intel Core2 Quad Q6600
    Memory
    Crucial Ballistix 4x2GB PC2 6400
    Graphics Card(s)
    NVIDIA GeForce 8600 GTS 256 MB
    Sound Card
    Creative SB X-Fi
    Monitor(s) Displays
    HP w2207 + HPvs15
    Screen Resolution
    1680x1050 + 1024x768
    Hard Drives
    2-WD5000AAKS-500 GB
    WD 5000AAV-500 GB external
    Mouse
    MX Revolution
    Keyboard
    Microsoft Comfort Curve
    Other Info
    Wacom Intuos 2 Graphics Tablet
    Experience Index=5.5

amplid

Vlaming
Power User
#17
Brink what is all that about permissions and the registry, that roy mentioned as well?

Amplid
 

My Computer

System One

  • CPU
    Intel Q9550 @ 3.2 GHz (for now)
    Motherboard
    Asus ROG Striker 2 Extreme
    Memory
    2 x 2Gb Patriot DDR3
    Graphics Card(s)
    XFX GeForce 9800 GTX+
    Sound Card
    Creative Supreme FX 2
    Monitor(s) Displays
    Neovo F417 17''
    Screen Resolution
    1280x1024
    Hard Drives
    Samsung SP2504C SATA 7200rpm
    PSU
    Pc Power & Cooling 750
    Case
    Coolermaster CM 690
    Cooling
    6 120mm's, Xigmatek HDT 1283 with crossbow backplate
    Mouse
    Logitech Cordless Trackman Wheel
    Keyboard
    Logitech G11
    Internet Speed
    ~1000 Kb/sec

Brink

Staff member
mvp
#18
Amplid,

I'm not sure what they mean by that. Usually if you have a problem with Flash Player it will need to be uninstalled and reinstalled, or you have DEP enabled in IE7. Check to see if DEP is enabled. If it is, then turn it off in IE7 to see if the Flash player will work afterwards. Option Two in this tutorial will show you how.

http://www.vistax64.com/tutorials/120778-dep-enable-disable.html




As Gary posted, that icon is just the uninstall program for the Adobe Flash Player in Programs & Features. This is normal and should be there.


Hope this helps,
Shawn
 

My Computers

System One System Two

  • Show second system?
    Yes
    Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    PSU
    Seasonic Prime Titanium 850W
    Case
    Corsair Air 740
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master
    Keyboard
    Logitech wireless K800
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Creative F200 webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD

amplid

Vlaming
Power User
#19
Hye Brink,
Ah ok, but why don't I get a separate icon for the actual player then? Or is that because it just doesn't install at all? I tried the Disabling for IE7, but when I do this, I can't get on the internet any more:s It doesn't say I have no connection, but simply stays stuck on the 'Connecting...' screen...

Amplid
 

My Computer

System One

  • CPU
    Intel Q9550 @ 3.2 GHz (for now)
    Motherboard
    Asus ROG Striker 2 Extreme
    Memory
    2 x 2Gb Patriot DDR3
    Graphics Card(s)
    XFX GeForce 9800 GTX+
    Sound Card
    Creative Supreme FX 2
    Monitor(s) Displays
    Neovo F417 17''
    Screen Resolution
    1280x1024
    Hard Drives
    Samsung SP2504C SATA 7200rpm
    PSU
    Pc Power & Cooling 750
    Case
    Coolermaster CM 690
    Cooling
    6 120mm's, Xigmatek HDT 1283 with crossbow backplate
    Mouse
    Logitech Cordless Trackman Wheel
    Keyboard
    Logitech G11
    Internet Speed
    ~1000 Kb/sec

Brink

Staff member
mvp
#20
Amplid,

It will not install a separate shortcut or anything for the flash player. It will just be a add-on for IE7 used automatically when a webpage has any content that uses the Adobe Flash Player.

In IE7, you can click on Tools, Manage Add-ons, Enable or Disable Add-ons to see if the Shockwave Flash Object is installed and enabled.
 

My Computers

System One System Two

  • Show second system?
    Yes
    Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS Maximus X Code Z370
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated
    Monitor(s) Displays
    3 x 27" Asus VE278Q
    Screen Resolution
    1920x1080
    Hard Drives
    250GB Samsung 960 EVO M.2,
    256GB OCZ Vector,
    6TB WD Black WD6001FZWX
    PSU
    Seasonic Prime Titanium 850W
    Case
    Corsair Air 740
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master
    Keyboard
    Logitech wireless K800
    Internet Speed
    300 Mb/s Download and 30 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Creative F200 webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB6190 cable modem,
    APC SMART-UPS RT 1000 XL,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD