New Shortcut Fix

thread_prefix_desc.27
ByLine
How to Restore the New Shortcut Context Menu Item in Vista
Synopsis
If when you right click on the desktop or in a User folder and click on New and Shortcut it does not work, then this will show you how to fix and restore the Shortcut menu item so it will create a new shortcut again.
How to Restore the New Shortcut Context Menu Item in Vista


information   Information
If when you right click on the desktop or in a User folder and click on New and Shortcut it does not work, then this will show you how to fix and restore the Shortcut menu item so it will create a new shortcut again.
EXAMPLE: New Shortcut in the Context Menu
NOTE:
You will only see this context menu item when you right click on a empty space on the desktop and in a nonsystem folder (Ex: C:\Users) Windows Explorer window. If you right on a empty space in a system folder (Ex: C:\Program Files, C:\Windows, etc...} Windows Explorer window, you will only see Folder in the New menu.

Context_Menu.jpg


Here's How:
1. Click on the Download button below to download the file below to your desktop.​
New_Shortcut_Fix.reg
download

2. Right click on the downloaded .reg file and click on Merge.​
3. Click on Run, Continue, Yes, OK if prompted.​
4. Log off and log on, or restart the computer to apply the fix.​
5. When done, you can delete the downloaded .reg if you like.​
NOTE: If the problem still persists, then do a System Restore using a restore point dated before the problem.
That's it,
Shawn


 

Attachments

  • New_Shortcut_Fix.reg
    10.1 KB · Views: 6,522
  • thumb_SendTo.jpg
    thumb_SendTo.jpg
    3 KB · Views: 41
  • thumb_Explorer_New.jpg
    thumb_Explorer_New.jpg
    3 KB · Views: 34
Last edited:

gixykings

New Member
Thanks for this wonderful thread. I wonder if there is a way to remove New > Shortcut from context menu permanently. I think this function is unnecessary.
 

gixykings

New Member
Hi,
I clicked on the link you've posted, but this is not a direct answer to my request. I want to remove "Shortcut" from "New" menu. Because this function is needless and annoying if you click on it instead of "Folder" by mistake.

-----
Edit:

I've tried to change ".lnk" (ShellNew to ShellOld) from "HKEY_CLASSES_ROOT". It works well on Vista, but it does not work in XP. I know this is a Vista forum but i guess it would work for XP, too. (I'm using XP Professional on VMware due to the compatibility problems of some important programs.)
-----

Thanks for your post.
 

z3r010

Staff member
Hi,
I clicked on the link you've posted, but this is not a direct answer to my request. I want to remove "Shortcut" from "New" menu. Because this function is needless and annoying if you click on it instead of "Folder" by mistake.
Thanks for your post.

The tutorial link posted by Gary is the answer to your request.
 

garysgold

Vista Guru
Hi gixkings,

To remove 'shortcut' from the new menu. Follow the directions at the above link. Use 'Option One', 'step 8'. The file extension you want to remove is .lnk.

Worked for me.

Gary
 

FiRe5tOrM

New Member
Was wondering if somebody could help me. I have tried the .reg file posted but I still cannot use the New > Shortcut menu. When I select New Shortcut nothing happens.

Does anybody have any ideas?

Thank you!
 

Brink

Staff member
mvp
Hello FiRe5tOrM, and welcome to Vista Forums.

I have updated the reg file download. Please redownload it and give the new one a try to see if may fix it for you afterwards.

Hope this helps,
Shawn
 

FiRe5tOrM

New Member
Hello FiRe5tOrM, and welcome to Vista Forums.

I have updated the reg file download. Please redownload it and give the new one a try to see if may fix it for you afterwards.

Hope this helps,
Shawn

Thank you! :D That works a treat. Greatly appreciated !



Edit: And such a quick response btw, very impressed. Thanks again!
 
THANK YOU!!! I googled for a solution to this but everyone else is supplying time-consuming steps to try in addition to reinstalling Vista, etc. I'm glad I didn't try any of those before I saw this link. This worked perfectly, thanks again!
 
Top