• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

No audio through hdmi to tv

#1
Seems to be a common problem. I used to connect my HP Pavilion dv9260nr Notebook to my Sharp Aquos LCD tv through an HDMI cable and got audio and video w/ no problems. About 2 months ago I reinstalled Vista Ultimate x64. I haven't tried to reconnect until recently and now I get video but no audio.

I have tried to set SPDIF Interface to default like I used to but it doesn't work. You can see the green "mixer" bar moving, but I can't hear anything. Also, when it's set to default the configure box is greyed out.



I have the latest Conexant High Definition Audio Driver, 4.33.1.61.
I also have Vista Codec pack v511 installed.

Seems like I need to "enable" hdmi somewhere but I can't find anywhere to. Any ideas?

Thanks for any help!
 
#3
Are you talking about the audio jack in the front? Why would I connect an hdmi cable and and audio cable? Sound did come out of hdmi before, always did.
 

Hogtowner

Ay, No Disrepect.
Member
#4
I have the same problem intermittantly, but not through HDMI. I use an optic from my computer to my receiver. Every once in a long while I lose my sound even though the green bar shows output also. But my receiver shows no input. And it ain't the cable.

I can solve the problem by rebooting, so I think there are conflicts in some of the audio software I run. You might try simplifying your audio driver situation as much as possible until you find the culprit on your system.

I know this isn't much in the way of help. Thought you might like to know you weren't alone though.
 
#5
I am in the exact same situation with my HP Pavilion dv9207us..
And the interesting part is that I have been using this HDMI to watch movies with no problem for more than an year now and saddenly it stopped working...I have Conexant HD Audio - last drivers...BIOS...tried everything...nothing worked. I think that it may be some Windows update now...If somebody knows something, please let me know..
Thanks
 

Martee

Vista Die-Hard
Vista Guru
#6
Seems to be a common problem. I used to connect my HP Pavilion dv9260nr Notebook to my Sharp Aquos LCD tv through an HDMI cable and got audio and video w/ no problems. About 2 months ago I reinstalled Vista Ultimate x64. I haven't tried to reconnect until recently and now I get video but no audio.

I have tried to set SPDIF Interface to default like I used to but it doesn't work. You can see the green "mixer" bar moving, but I can't hear anything. Also, when it's set to default the configure box is greyed out.



I have the latest Conexant High Definition Audio Driver, 4.33.1.61.
I also have Vista Codec pack v511 installed.

Seems like I need to "enable" hdmi somewhere but I can't find anywhere to. Any ideas?

Thanks for any help!
Hello,

I'm not sure if I can help here, but I have clean installation of Vista and
found little difference in my Sound window than your one. I will try to explain
what I mean.

Go to Control Panel/Hardware and Sound/ Sound then click Manage Audio Devices.
In this window you should find three items:
-Digital Output Device (HDMI)
-Speakers/Headphones
-Digital Output Device (SPDIF Out)

From your attached image, looks like, you don't have Digital Output Device (HDMI),
do you?. But if you got it, right click it and set it as the Dafault, also check
it and click on Properties, "Enable" the device usage first, then under Levels tab,
check if the volume level is all the way up.

Also, in the Device Manager,I found two devices....High Definition Audio Device
and in my case SigmaTel High Definition Audio CODEC. This first one is just for
HDMI audio. By the way, audio drivers are still the same that OEM provided.

You already try set the SPDIF interface to Default, but click Supported Format
tab and try to check in the Microsoft WMA Audio, and at the same time deselect
the other ones. Maybe, this will help.

Cheers...
 
#7
Seems to be a common problem. I used to connect my HP Pavilion dv9260nr Notebook to my Sharp Aquos LCD tv through an HDMI cable and got audio and video w/ no problems. About 2 months ago I reinstalled Vista Ultimate x64. I haven't tried to reconnect until recently and now I get video but no audio.

I have tried to set SPDIF Interface to default like I used to but it doesn't work. You can see the green "mixer" bar moving, but I can't hear anything. Also, when it's set to default the configure box is greyed out.



I have the latest Conexant High Definition Audio Driver, 4.33.1.61.
I also have Vista Codec pack v511 installed.

Seems like I need to "enable" hdmi somewhere but I can't find anywhere to. Any ideas?

Thanks for any help!
If you click on the background of that window showing your speakers, there is a context menu that allows you to see disabled devices. Put a checkmark there, and when your HDMI shows up you can right click it and choose to enable it and if you want, make it the default device.
 
#8
I already solved this problem.
It is the update of NVidia driver.
Just uninstall it, restart and everything will work fiine.
It took me months untill I found out the problem is Video, not audio driver.
Good luck!
 

DonMc

New Member
#9
First, sometime during a two-day effort my problem of no HDMI audio was fixed. I don't know exactly when because I finally discovered that the audio test sound (Playback Device's green bar) was not going out over my HDMI link. (It worked fine for the computer and docking-station speakers.) Thus, if you're trying to fix this very common no-audio problem, include a Media Player video or some other audio source in your tests.

Second, the fix was to download and install (not update) the very latest nVidia driver. (Reinstalling the original driver from the recovery disk may have worked but I'll never know because of the test-sound problem.) When I just updated the driver from Device Manager, it didn't install the associated driver-specific nVidia Control Panel. (Losing the Control Panel also seems to be a common problem.) Thus, I suggest downloading the latest driver from the manufacturer and running their included Setup program. It worked for me.

One last word: Blindly installing older drivers (a solution suggested by some) looks very dangerous - especially those from a popular site's "European" sources. At least Norton sure didn't like some of them.
 
#10
This is my solution apprantley.
I was trying to run some video clips through different things to test it and I came to this. For example with VLC when you run it it uses it's own settings for sound. So I went into "Audi > Audio Device > And in my case > 5.1.
And voila it was working, I tried this with Itunes, WMA and same result each time.
So maybe just try that, it might help.

:)
 
#11
Old thread I know nut been annoying me for a while and finally found the solution here and thought I'd confirm what megyruse suggested.

Had the same problem. After a search to this site I found the answer.
Was a bit apprehensive about doing it but megyruse was right

Rolled back the Nvidia driver and working as I type this.

Thanks
 
#12
I had the same problem, and this is how I fixed it.

While the HDMI connection is plugged in and the Image is visible on the external display, go to Control Panel> Hardware and Sounds> Manage Audio Devices.

Then the window "Sound" should pop up. You should be able to see the NVIDIA HDMI OUTPUT driver. Select this and go to Properties> Advanced. Then select the highest quality of audio under Default Format. Then click OK, and restart what ever program you want audio to come out of.

It should work.
 
#13
Janm21's solution works for me except for one variation... i had to select the lower quality setting and then set it the HDMI as the default output. I never used to have to do all that and i don;t know what went wrong, but at least i can get the sound where i want it now. Good-o.
 
#14
I had the exact same problem. Before you start messing around uninstalling devices, it may have just disabled itself somehow.

Try right clicking anywhere on the playback tab in the sound box within control panel. An option appears "show disabled devices". You might be able to "enable" from this screen.

Best of luck x
 
#15
I found a solution that works!

Just check your Control Panel and search for a program called "VIA HD Audio Deck"
On the menue, click the SPDIF button and just adjust the setting to HDMI, worked fine for me.