Solved Nvidea NVKDLLM error....possible fix for gigibyte MOBO users BIOS update

harlza18

Member
Hi there vista users. harley here again.

ok for those who have that dreaded Nvidea NVKDLLM error, i had the same. dureing a game it would freeze up. black screen then come back with the error. some times my mouse pointer would glitch up.

my Nvidea card is attached to a GIGIBYTE GA-EP43-DS3 motherboard which has been with me since 2008. and a lot of changes have happend since then. 1 GIG of extra ram. fried my Nvidea 8800GT xD replaced with 450GTS.

so my fix was is that i went to the gigbyte website....looked up my bord there and clicked on support and downloads. went to BIOS in the drop down menu and a bunch of BIOS versions were there F4 to F9, so i checked my bios firmwear in system info to see it was F3 OMG :D the orginal firmwear from when i got it built. so downloaded @bios from gigibyte download page and ran it. had it check the GB servers in the US with one which was for my bord was the F9 (latest ver.). and flashed it. when it was done, it asked for a reset i hit ok, at the splash screen booted into bios and hit LOAD OPTIMIZED DEFULTS(just to be safe) hit F10 to save.

tryed a game like GTA IV or SR3 (direct x version 10 or 11) with no problems. i think that this has fixed it

*for those who are worried about flashing the bios please take it to your local PC shop for it to be done.

have not had a problem since yesterday when i did it.

if you have any questions please leave a messege on this thead.
Harley
 

My Computer

System One

  • Manufacturer/Model
    Microsoft
    CPU
    Intel Core Duo 2
    Motherboard
    EP43-DS3
    Memory
    E4800 @ 3.00
    Graphics Card(s)
    Nvidea Geforce GTS 450
    Sound Card
    Realtack high def
    Monitor(s) Displays
    BenQ T22IW
    Screen Resolution
    1280X1024
    Hard Drives
    Maxtor STM 3320820AS ATA device
    Mouse
    logitch wireless mouse
    Keyboard
    logitech wireless keybord
    Internet Speed
    running off a USB internet dongle

tom982

٩(͡๏̯͡๏)۶
Vista Guru
Gold Member
Hi Harley,

Thanks for taking the time to share this solution! I'm sure others experiencing this problem will really appreciate your efforts :)

Tom
 

My Computer

System One

  • Manufacturer/Model
    Build #1
    CPU
    Intel Core i7 3770K @4.4GHz
    Motherboard
    ASUS P8Z77-V PRO
    Memory
    Corsair Vengeance 2x4GB DDR3 1600MHz Low Profile (White)
    Graphics Card(s)
    Gigabyte Radeon HD 7850 (2GB GDDR5)
    Sound Card
    Integrated on motherboard
    Monitor(s) Displays
    23" LG LCD/LED IPS
    Screen Resolution
    1920*1080
    Hard Drives
    Samsung EVO 128GB SSD
    Seagate Barracuda 2TB 7200rpm
    2x500GB Seagate FreeAgent 5400rpm
    PSU
    Corsair TX650W V2 (80+ Bronze)
    Case
    NZXT Phantom 410
    Cooling
    Corsair H100 Water Cooler, 1x140mm and 1x120mm stock fans
    Mouse
    Microsoft Desktop 2000 Wireless Mouse
    Keyboard
    Microsoft Desktop 2000 Wireless Keyboard
    Internet Speed
    95 Mb/s Download 70 Mb/s Upload
Top