nvidia driver update failed

negis

Member
Hi,

About last week I update my graphic card driver (nvidia geforce go 7150m/630m) from ver 7.15.11.5665 to 7.15.11.7991 using updating function in Device Management. The update when smoothly and I thought at first that it's successfull since I did not receive any error messag and in Device management list the new ver. as 7.15.11.7991. However, after that I got some conflicts in driver and it somehow affects my cdrom drive as it's now no longer start when turn on the laptop unless restart immediately.

I went to the regedit and see in the installer folder of nvidia, the install regitry listed as "failure" and the version is still listed as the old one (7.15.11.5665). Is there any way to correct this?

BTW, my OS is window vista home premium 32-bit.
 

My Computer

richc46

Vista Guru
Gold Member
Welcome
If you have the new driver and are having problems, go back to device manager and roll back to the old driver. What you are experiencing is a common problem. Many here feel it is best not to upadate unless you are having problems.

Edit: Better to roll back with a system restore.
http://www.vistax64.com/tutorials/76905-system-restore-how.html
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

negis

Member
My restore point for that time is long gone, unfortunately. I did try roll back driver but nothing happen. Just a moment ago, I uninstalled the current version in device management and try installed the old one I had before updating but unsuccessful. After uninstall and reinstall, my computer had no nvidia driver for configure. The install registry in the nvidia installer folder in regedit was listed as failure and no version installed. I have to do system restore just now in order to restore my graphic driver back.
I think there's something wrong with the nvidia registry now
 

My Computer

richc46

Vista Guru
Gold Member
It appears that there may be a problem with the registry. If you have no restore points and you did not save your registry settings, there are problems.
Not much that can be done if your registry is screwed.
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

negis

Member
Is there a way to clean/correct the registry? I have just reinstall my OS after the corruption about 3 weeks ago so I don't want to format it again
 

My Computer

richc46

Vista Guru
Gold Member
You have a Vista DVD?
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

richc46

Vista Guru
Gold Member
There are not many ways to fix registry, unless backed up
System Restore
Reinstall of Operating System
Repair install, but a CD is needed. Can you borrow one?
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

richc46

Vista Guru
Gold Member
If you have an SP2 CD and your OS is SP2, you can use it. It must be an install CD, not just an image of what was on your computer when you received it.
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

richc46

Vista Guru
Gold Member
For repair install it must be the same sp
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

negis

Member
About the registry, in the installer folder of nvidia, registry install REG_SZ listed as failure does it mean the whole registry has problem or just indicate a fail install? Because my display still function well beside the cdrom problem so is it need to be repaired?
 

My Computer

richc46

Vista Guru
Gold Member
Registry do not go bad all at once. Usually just portions at a time. I think its just that one area that is corrupt.
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

negis

Member
I don't understand. Why does the registry lists status install as failure but both msconfig and DM list nvidia graphic driver as the new version and it appears working fine? And during the update/installation, I did not receive any error.
 

My Computer

Top