OpenGL programs/games freezing in 64 bit Vista

bpward

New Member
Hi, I recently picked up the gateway FX 1050u laptop. It is running a geforce 9800M GTS cuda with 1GB ram. I was previously on Vista 32 bit and had no problems running either Diablo II or PyMol (it is a 3D biochemical structure program, widely used amongst scientists to view structures). Both programs use OpenGL.

However with the gateway computer I am getting a lot of outright freezes in both programs. When Diablo freezes, I have to restart the computer entirely. Usually with PyMol it will freeze for a few seconds and then I can get out of it. I don't really game much outside Diablo II so I can't speak for other game programs, however I suspect something is wrong regarding the way these programs use OpenGL as I get error messages from PyMol saying it had an OpenGL error and then a C++ error.

I've tried messing with the video card settings the programs run with (there's a lot of customizable options), perhaps not enough, but nothing has seemed to help.

Does anyone have any suggestions as to how to get it to work? I really can't live without PyMol... perhaps going to Windows 7 beta would help me out?
 

My Computer

bpward

New Member
Yea I did that a few days ago. I updated the geforce driver to a 4/30 version and that didn't fix it last night. I just found there's a new nvidia cuda opengl package update though. Maybe that will help...
 

My Computer

sygnus21

Here to learn
Vista Guru
Hi, I recently picked up the gateway FX 1050u laptop. It is running a geforce 9800M GTS cuda with 1GB ram. I was previously on Vista 32 bit and had no problems running either Diablo II or PyMol (it is a 3D biochemical structure program, widely used amongst scientists to view structures). Both programs use OpenGL.

However with the gateway computer I am getting a lot of outright freezes in both programs. When Diablo freezes, I have to restart the computer entirely. Usually with PyMol it will freeze for a few seconds and then I can get out of it. I don't really game much outside Diablo II so I can't speak for other game programs, however I suspect something is wrong regarding the way these programs use OpenGL as I get error messages from PyMol saying it had an OpenGL error and then a C++ error.

I've tried messing with the video card settings the programs run with (there's a lot of customizable options), perhaps not enough, but nothing has seemed to help.

Does anyone have any suggestions as to how to get it to work? I really can't live without PyMol... perhaps going to Windows 7 beta would help me out?
What were you running before you picked up that laptop? Are you running Vista 64-bit now? From your description, it sounds like a 64-bit compatibility issue?

Also, "if" you are running Vista 64, than I'd recommend your get more RAM. The prevailing thought is to have at least 2gig on Vista and 4gig on Vista x64.

Lastly, make sure the OS is up to date on all patches and service pack.
 

My Computer

System One

  • Manufacturer/Model
    Custom Built
    CPU
    Intel Core 2 Quad Q6600 2.4GHz
    Motherboard
    Intel D975XBX2
    Memory
    Corsair TWIN2X4096-PC8500 (2x2GHz)
    Graphics Card(s)
    ATI Radeon HD 4890 (1GHz)
    Sound Card
    X-Fi Titanium - Fatality Pro Series
    Monitor(s) Displays
    hp w2207h (22" widescreen)
    Screen Resolution
    1680 x 1050
    Hard Drives
    One 750GB, 2x500GB Western Digital Caviar Black Hard Drives (32meg)
    PSU
    Antec Neo HE 550
    Case
    Antec P182
    Cooling
    Zalman CNPS9500 AT
    Mouse
    Logitech MX Revolution
    Keyboard
    Logitech Wireless Wave
    Internet Speed
    "High" Speed DSL? Is that like low speed FIOS?
    Other Info
    Q6600 B3 Revision OC to 3.0GHz
Top