Personal User Shell Folders

thread_prefix_desc.28
ByLine
How to Fix a Personal User Shell Folder Displayed as a Standard Yellow Folder Icon in Vista
Synopsis
If you open your personal user folder in the Start menu and the folder is displayed with a standard yellow folder icon instead of the special green folder icon, then this will show you how to fix it.
How to Fix a Personal User Shell Folder Displayed as a Standard Yellow Folder Icon in Vista

information   Information
If you open your personal user folder in the Start menu or from C:\Users\(user name), and a user folder has a standard yellow folder icon instead of the special green folder icon, then this will show you how to restore the green folder icon for that particular user folder.
Note   Note
This usually can occur when the desktop.ini file in the shell folder is missing or incorrect, or the user folder has no read only attribute set to it.

EXAMPLE: Special Green Personal User Profile Folder Icons
User_Folders.jpg



OPTION ONE
For the User Name Folder

NOTE: This is the User Name folder that appears in the Desktop folder tree view in Windows Explorer or the Start Menu.
1. Right click on a empty area of the desktop and click on Personalize.​
2. Click on Change desktop icons in the upper left corner. (See screenshot below)​
Change.jpg

3. In the lower box, click on your User Name folder to highlight it in blue. (See screenshot below)​
Settings.jpg

4. Click on the Restore Default button. (See screenshot above)​
A) Click on Apply.​
NOTE: If it did not restore the default User Name folder icon, then proceed to step 5.​
B) Go to step 6.​

5. Click on the Change Icon button. (See screenshot below step 3)​
A) If not already in the top line, then click on the Browse button and browse to C:\Windows\system32\imageres.dll.​
B) Select the default User Name folder icon and click OK. (See highlighted in blue icon in the screenshot below)​
Change_Icon.jpg

6. Click on OK. (See screenshot below step 3)​



OPTION TWO
For the User Folders in the User Name Folder

1. Verify that the user folder has it's correct default path in METHOD THREE here.​
STEP ONE:
Shell Command
2. Open the Start Menu.​
3. Type in the Shell command (see table below) for the Personal User folder and press Enter..​

User Folder

Shell Command

Contacts

shell:Contacts

Desktop

shell:desktop

Documents

shell:personal

Downloads

shell:downloads

Favorites

shell:Favorites

Links

shell:Links

Music

shell:My Music

Pictures

shell:My Pictures

Saved Games

shell:SavedGames

Searches

shell:Searches

Videos

shell:My Video

4. This will open the personal user folder from it's location.​
5. Close the personal user folder window.​
6. Check to see if the personal user folder has turned back to the special green folder in the start menu.​
A) If yes, then your done.​
B) If not, proceed to STEP TWO below.​

STEP TWO:
Replace Desktop.ini File for User Folder
7. Have Show hidden files and folders dotted and Hide protected operating system files (Recommended) unchecked in Folder Options.​
NOTE: For how, see OPTION TWO here:How to Hide or Show Hidden Files and Folders in Vista
8. Click on the download button below to download the User Folders.zip file, then click on Save and save it to the Desktop.​
download

9. Right click on the User Folders.zip file (on Desktop) and click on Open.​
10. Extract the same folder(s) for your user folder name with the standard yellow icon displayed to the Desktop.​
11. Open the extracted folder and right click on the desktop.ini file and click Copy. (See screenshot below)​
NOTE: This file is set as a hidden file. This is why it is faded.
Desktop_ini.jpg

12. Open the user folder that has the standard yellow folder icon displayed.​
A) Right click on a empty area in the folder's window and click Paste.​
NOTE: If you are asked if you want to replace the old desktop.ini file, then click Copy and Replace. (See screenshot below)
B) Repeat step 11 for each user folder you need to fix.​
Copy_and_Replace.jpg

13. Close all windows.​
15. If prompted, click on Continue in the UAC prompt.​
16. In the elevated command prompt, type the command below (see table below) for the user folder name you need to fix. (See screenshot below table)​
NOTE: This will set the user folder as Read-only. You can Copy and Paste these to make it easier for you.
WARNING: If you have changed the default location of your user folder, then you will need to type the full path of it's new location after attrib +r instead of the default %USERPROFILE% location below. For example, attrib +r D:\New location

User Folder

Command

Contacts

attrib +r -s -h %USERPROFILE%\Contacts /S /D

Desktop

attrib +r -s -h %USERPROFILE%\Desktop /S /D

Documents

attrib +r -s -h %USERPROFILE%\Documents /S /D

Downloads

attrib +r -s -h %USERPROFILE%\Downloads /S /D

Favorites

attrib +r -s -h %USERPROFILE%\Favorites /S /D

Links

attrib +r -s -h %USERPROFILE%\Links /S /D

Music

attrib +r -s -h %USERPROFILE%\Music /S /D

Pictures

attrib +r -s -h %USERPROFILE%\Pictures /S /D

Saved Games

attrib +r -s -h %USERPROFILE%\"Saved Games" /S /D

Searches

attrib +r -s -h %USERPROFILE%\Searches /S /D

Videos

attrib +r -s -h %USERPROFILE%\Videos /S /D

Command_Prompt.jpg

17. Repeat step 16 for each user folder that you replaced the desktop.ini file for.​
18. Close the elevated command prompt.​
19. Restart the computer, or logoff and login again for the changes to take effect.​
20. Confirm that the folder icon is back to normal.​
21. You can now delete the downloaded folders on the desktop and set your hidden files and folders settings back to normal in step 7 above.​

That's it,
Shawn


 

Attachments

  • User Folders.zip
    3.1 KB · Views: 15,702
  • thumb_Username_Folder.jpg
    thumb_Username_Folder.jpg
    2.6 KB · Views: 43
Last edited:

stereotype

New Member
Hello.

First of all, thanks for bothering to make this tutorial.

My Documents folder isn't showing properly. About a week ago, I deleted it permanently. I made another folder in it's place, but the new one is yellow and I want to change it.

Option 1, didn't work.
Option 2: Step 1 didn't work. I'm on Step 2. After I download and extract the new Documents folder that contains Desktop.ini I can't see any files in the folder. My "see hidden files" option is turned on in Folder Options.

What gives?

***EDIT***

Seems I can't follow simple instructions. I had the "show hidden files on" but I didn't uncheck the protected files. Problem fixed. Sorry if I wasted your time! :)
 

IslandBoy77

New Member
Hi
Have run across this problem a couple of times now when trying to help people with their PCs. I note that on the PC I'm working on now, which has a user of 'Chris & Cherie', Vista is having issue with the spaces & the '&' character, as when I try to issue the attrib command I get 'File note found - C:\Users\Chris' followed by 'The system cannot find the path specified'. Also, I note that when I try to direct Windows to the system32 folder it can't see the imageres.dll file even though it is there. All the other icons in the user folder display correctly, just not the music one. It's not the world's biggest deal, but it is annoying, and does make me wonder if there isn't a more significant problem "lower down".
I've tried all the steps in this tutorial as well as the one here http://www.vistax64.com/tutorials/148461-personal-user-folder-restore-missing-folder.html, and have used TuneUp Utilities 2010 to repair the icon cache. I've also restarted.
A mystery! Any more ideas? Presumably I'd have to create a whole new user without spaces or the & character, tx all my data to it, delete the old user, & restart in order to nullify any poss issues Windows is having with the username - not really an option on a PC with lots of software & customised user data on it...
Cheers
Peter
 

Brink

Staff member
mvp
Hello Peter, and welcome to Vista Forums.

When you have a space in a user name like that while doing a command, it would be better to either include the path in quotes like "C:\Users\Chris & Cherie\Music" or use %UserProfile%\Music for the path to the Music folder as an example instead.

Without either one of the commands used the way above instead, the command prompt actually only sees the path as C:\Users\Chris instead of C:\Users\Chris & Cherie\Music due to the space.

Hope this helps,
Shawn
 

Sweet

Banned
Tool to restore the icons of the personal user shell folders

Hi everyone,

Because I've just helped with a problem on restoring the icons of the personal user shell folders,
I thought it was useful to develop a tool, that not only restores the desktop.ini files,
but that also changes the attribute of the personal user shell folders to read only (what's necessary to display the icons.)
You can use one of the tools below to restore the icons of your personal user shell folders.
Remember that sometimes it is necessary to restart Windows Explorer for the changes to take effect.
You can do this by using the tool with the plus sign.

Kind regards
Sweet
 

Attachments

  • FldrIcon32.exe
    156.5 KB · Views: 91
  • FldrIcon32+.exe
    156.5 KB · Views: 113
  • FldrIcon64.exe
    162.5 KB · Views: 95
  • FldrIcon64+.exe
    162.5 KB · Views: 93

Brink

Staff member
mvp
Re: Tool to restore the icons of the personal user shell folders

Hello Sweet,

Thank you for another option. :)
 

muaaz17

New Member
i have deleted my desktop folder by mistakke & it got replaced by some yellow folder .. when i click it, it says the path changed something like that:mad: ... plz help to get it back ... thank you :)
 

muaaz17

New Member
u can see in this image that...there is no desktop icon/folder .. it was there with yellow color bt i deleted it by mistake ... plz help help :)

Untitled.jpg
 

Brink

Staff member
mvp

Brink

Staff member
mvp
Muaaz,

Was that the correct Desktop shortcut you were referring to, and did this restore it for you?

It would be best to create a new thread for the other question at our sister site Seven Forums since it's off topic from this tutorial, and for Windows 7. :)
 
Top