Solved Problem with "Sleep" mode

rive0108

Vista Guru
Gold Member
re: Problem with "Sleep" mode

Multimedia Settings Management will prevent sleep, Screen will turn off, but computer will never enter sleep state.
Under Hardware and Sound>Power Options>plan setttings> click ,"change advanced power settings"Media Settings"

If you see "Prevent Idling to sleep" or "allow the computer to enter away mode" this must be changed to "allow computer to sleep"

If this does not resolve issue, please see further troubleshooting:
http://www.vistax64.com/tutorials/63567-power-options-sleep-mode-problems.html
 

Jon_Uk

New Member
re: Problem with "Sleep" mode

Thank you rive0108, I went in and changed that but I still get the problem.

It turns out that it is my USB printer that is causing the problem. If I unplug the USB cable to the printer, the computer goes down to sleep without any problems.

I did ran “powercfg -devicequery wake_armed “ but the only things that comes up is my keyboard and mouse.


Right clicking on the printer in the Device Manager, doesnt give me power management tab.


Went through all the USB Hub's in there and none (as far as I can tell) have the option set “Allow to wake computer”.


Any ideas on what could be going on?


Cheers
Jon
 
Last edited:

rive0108

Vista Guru
Gold Member
re: Problem with "Sleep" mode

Thank you rive0108, I went in and changed that but I still get the problem.

It turns out that it is my USB printer that is causing the problem. If I unplug the USB cable to the printer, the computer goes down to sleep without any problems.

I did ran “powercfg -devicequery wake_armed “ but the only things that comes up is my keyboard and mouse.


Right clicking on the printer in the Device Manager, doesnt give me power management tab.


Went through all the USB Hub's in there and none (as far as I can tell) have the option set “Allow to wake computer”.


Any ideas on what could be going on?


Cheers
Jon
Why not just turn off printer, and turn it on when you need it?
 

rive0108

Vista Guru
Gold Member
re: Problem with "Sleep" mode

note- this is from hp, but the idea is the same; find the usb root hub in device manager that your printer is on, and uncheck "allow device to wake computer", and check "Allow computer to turn off this device..." (if you want)

"You'll have to check the properties of the USB Root Hubs in the device manager and find out which one the printer is plugged into. it should show the printer name itself, or 'USB Composite Device' instead of USB MAss Storage device as shown in the screenshot below."
Source:USB Printer wakes Vista - Printer, All-in-One Software and drivers - HP Support Forums
 

Attachments

  • Capture1.GIF
    Capture1.GIF
    22.2 KB · Views: 31
  • Capture2.GIF
    Capture2.GIF
    18.6 KB · Views: 25

Jon_Uk

New Member
re: Problem with "Sleep" mode

Thank you rive0108

It is of course possible to shut down the printer everytime i dont want to use it but it doesnt have an easy accessable power switch (HP 1320).

It is interesting that your link is also for an HP printer.

Here are the settings I have in device manager
 

Attachments

  • 1.jpg
    1.jpg
    25.5 KB · Views: 47
  • 2.jpg
    2.jpg
    19 KB · Views: 48

Jon_Uk

New Member
re: Problem with "Sleep" mode

I found the problem. I had just started to use on of these new power extension leads, where when you switch off the computer all the other peripherals get their power cut (to save electricity, rather then leaving them on stand-by).
For what ever reason did this make the printer send some sort of wake up signal to the computer.

I have now removed the printer from the extension lead and that resolved it.


I have now removed the printer from the extension lead and that resolved it.
 
Top