Solved Problem with Western Digital 500 GO my book essential - unrecognized

Ellioz

Member
Greatings,

I currently have a problem with a hard drive, WD my book essential edition 500 GO.

For a reason which is unknown to me, Vista simply doesn't recognize it anymore.

It remains wired to my desktop computer, but I can't see it on the Windows Explorer. I therefore cannot access the files on the external hard drive, or save files on it.

I seem not to be the only one having this problem, after having seen the WD my book review in cnet.

Letter G is now empty, saves don't function anymore.

If I go to Computer/ Manage/ Disk management, the hard drive does'nt appear.

If I go to Computer/ Manage/ Peripheral management/ disk reader, the hard drive appears and drivers seem OK (or so according to Vista).

I decided to boot from the WD hard drive to see what happens. But it hasn't resolved my problem.

BTW, there is no driver on the Western Digital website for Vista, because (or so they think) in Vista drivers are automatically updated or installed.

I now cannot use this external hard drive and would welcome any suggestion about this WD conumdrum.
 

My Computer

System One

  • Manufacturer/Model
    HP
    CPU
    Pentium E220
    Motherboard
    MSI Boston
    Memory
    4096 Mo
    Graphics Card(s)
    HP 2309 sur ATI Radeon HD 4350
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    HP2309v

wither 3

Vista Guru
Gold Member
Try this-

Open Windows Explorer. Click on Map Network Drives. It should find the external drive and assign it a volume number such as G:
 

My Computer

System One

  • Operating System
    Vista Home Premium 64 bit SP2
    Manufacturer/Model
    Cyberpower
    CPU
    Intel Quad CPU Q6700 2.67 GHZ
    Motherboard
    NVIDIA 780i
    Memory
    4 GB
    Graphics Card(s)
    MSI GTX 560 TI Twin Frozr
    Sound Card
    Sound Blaster SB Audigy
    Monitor(s) Displays
    Viewsonic VG2436
    Screen Resolution
    1920x1080p
    Hard Drives
    Samsung HD 105SI
    WDC WD20
    Case
    Apevia XJupiter
    Cooling
    air
    Mouse
    Logitech MX 600
    Keyboard
    Logitech MX 3200
    Internet Speed
    30 Mbps

Ellioz

Member
I am not sure to understand...

Since I use the French version of Vista, I went to that website just to be sure of what I was doing.

I can connect a local folder like: C:\Users\me\andsoonblablabli\gimmick\thing
to the G:\
Done.

But I still don't see the content of my hard drive.

The G contains the content of the C:\Users\me\andsoonblablabli\gimmick\thing, not of the hard drive.

Please tell me where I am wrong.

I've had a message little after I came into Windows, that something was detected, but Windows doesn't know what.
If only it knew, my problem might be fixed.

I also have the icon (on the right below of the screen) to remove USB safely. But the G does't appear here either.

I wonder where the problem is:
Software, but I'm supposed to have the latest driver...
Hardware, the hard drive may have been "on" and connected to the computer too long, I'm sure that I let "on" much longer than the time strictly required to save my data. Something I won't do again, cause mistakes make me more cautious.

I have tried to connect the same hard drive to a Win7 laptop, but to no avail: it was unrecognized, the installation of the driver failed.

Any idea of I could do?
 

My Computer

System One

  • Manufacturer/Model
    HP
    CPU
    Pentium E220
    Motherboard
    MSI Boston
    Memory
    4096 Mo
    Graphics Card(s)
    HP 2309 sur ATI Radeon HD 4350
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    HP2309v

wither 3

Vista Guru
Gold Member
As I mentioned, open your computer in Windows Explorer, as shown below and select Map Network Drives, also shown below.




mapnetworkdrive.JPG
 

My Computer

System One

  • Operating System
    Vista Home Premium 64 bit SP2
    Manufacturer/Model
    Cyberpower
    CPU
    Intel Quad CPU Q6700 2.67 GHZ
    Motherboard
    NVIDIA 780i
    Memory
    4 GB
    Graphics Card(s)
    MSI GTX 560 TI Twin Frozr
    Sound Card
    Sound Blaster SB Audigy
    Monitor(s) Displays
    Viewsonic VG2436
    Screen Resolution
    1920x1080p
    Hard Drives
    Samsung HD 105SI
    WDC WD20
    Case
    Apevia XJupiter
    Cooling
    air
    Mouse
    Logitech MX 600
    Keyboard
    Logitech MX 3200
    Internet Speed
    30 Mbps

Ellioz

Member

My Computer

System One

  • Manufacturer/Model
    HP
    CPU
    Pentium E220
    Motherboard
    MSI Boston
    Memory
    4096 Mo
    Graphics Card(s)
    HP 2309 sur ATI Radeon HD 4350
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    HP2309v

wither 3

Vista Guru
Gold Member
I deleted my post.
 
Last edited:

My Computer

System One

  • Operating System
    Vista Home Premium 64 bit SP2
    Manufacturer/Model
    Cyberpower
    CPU
    Intel Quad CPU Q6700 2.67 GHZ
    Motherboard
    NVIDIA 780i
    Memory
    4 GB
    Graphics Card(s)
    MSI GTX 560 TI Twin Frozr
    Sound Card
    Sound Blaster SB Audigy
    Monitor(s) Displays
    Viewsonic VG2436
    Screen Resolution
    1920x1080p
    Hard Drives
    Samsung HD 105SI
    WDC WD20
    Case
    Apevia XJupiter
    Cooling
    air
    Mouse
    Logitech MX 600
    Keyboard
    Logitech MX 3200
    Internet Speed
    30 Mbps

wither 3

Vista Guru
Gold Member
You said-

"If I go to Computer/ Manage/ Peripheral management/ disk reader, the hard drive appears and drivers seem OK (or so according to Vista)."

I don't know know how to get to the path you show. Is this something caused by a translator? For instance, do you mean Device Manager?
 

My Computer

System One

  • Operating System
    Vista Home Premium 64 bit SP2
    Manufacturer/Model
    Cyberpower
    CPU
    Intel Quad CPU Q6700 2.67 GHZ
    Motherboard
    NVIDIA 780i
    Memory
    4 GB
    Graphics Card(s)
    MSI GTX 560 TI Twin Frozr
    Sound Card
    Sound Blaster SB Audigy
    Monitor(s) Displays
    Viewsonic VG2436
    Screen Resolution
    1920x1080p
    Hard Drives
    Samsung HD 105SI
    WDC WD20
    Case
    Apevia XJupiter
    Cooling
    air
    Mouse
    Logitech MX 600
    Keyboard
    Logitech MX 3200
    Internet Speed
    30 Mbps

Ellioz

Member
My translation from French seems to be somewhat unprecise.

In computer management, I was indeed speaking of the device manager.

To sum it up briefly, my hard drive appears in the device manager (even when it is not connected to the computer) as WDC WD6400AAKS-65A7B2 ATA Device.

In the properties, all seems OK. If I'm looking for a driver update, there seems to be no need for any.

But my hard drive doesn't appear in the disk manager.
 

My Computer

System One

  • Manufacturer/Model
    HP
    CPU
    Pentium E220
    Motherboard
    MSI Boston
    Memory
    4096 Mo
    Graphics Card(s)
    HP 2309 sur ATI Radeon HD 4350
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    HP2309v

Ellioz

Member
Problem solved. Hard drive slightly disconnected. Now I know I should have checked all the connections. I am not an IT professionnal, which might explain my mistake.

Sorry for the time I made you lose. I lost a few hours in the process.

Thanks for your help.
 
Last edited:

My Computer

System One

  • Manufacturer/Model
    HP
    CPU
    Pentium E220
    Motherboard
    MSI Boston
    Memory
    4096 Mo
    Graphics Card(s)
    HP 2309 sur ATI Radeon HD 4350
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    HP2309v

wither 3

Vista Guru
Gold Member
No problem in regards to my time. The important thing is that you found a resolution.
 

My Computer

System One

  • Operating System
    Vista Home Premium 64 bit SP2
    Manufacturer/Model
    Cyberpower
    CPU
    Intel Quad CPU Q6700 2.67 GHZ
    Motherboard
    NVIDIA 780i
    Memory
    4 GB
    Graphics Card(s)
    MSI GTX 560 TI Twin Frozr
    Sound Card
    Sound Blaster SB Audigy
    Monitor(s) Displays
    Viewsonic VG2436
    Screen Resolution
    1920x1080p
    Hard Drives
    Samsung HD 105SI
    WDC WD20
    Case
    Apevia XJupiter
    Cooling
    air
    Mouse
    Logitech MX 600
    Keyboard
    Logitech MX 3200
    Internet Speed
    30 Mbps
Top