Public Folder Icons - Restore Default Icon

ByLine
How to Fix a Public Folder Displayed as a Standard Yellow Folder Icon in Vista
Synopsis
If you open the C:\Users\Public folder, and Public Destop, Public Documents, Public Music, Public Pictures, or Public Videos has a standard yellow folder icon instead of the default special folder icon, then this will show you how to restore the default icon for that particular Public folder.
How to Fix a Public Folder Displayed as a Standard Yellow Folder Icon in Vista

information   Information
If you open the C:\Users\Public folder, and the Public Destop, Public Documents, Public Music, Public Pictures, or Public Videos folder has a standard yellow folder icon instead of the default special folder icon, then this will show you how to restore the default icon for that particular Public folder.
Note   Note

  • The Favorites and Public Desktop folders are hidden by default.
  • The Favorites, Public Downloads, and Recorded TV folders just use the standard yellow folder by default, so there is no need to change these.

EXAMPLE: Public Folder Icons
NOTE:
Only the Public Desktop, Public Documents, Public Music, Public Pictures, and Public Videos folders have a special folder icon.

Public_Folders.jpg




STEP ONE
Shell Command

1. Open the Start Menu.​
2. Type in the Shell command (see table below) for the Public folder and press Enter.​

Public Folder

Shell Command

Public Desktop

shell:Common Desktop

Public Documents

shell:Common Documents

Public Music

shell:CommonMusic

Public Pictures

shell:CommonPictures

Public Videos

shell:CommonVideo
3. This will open the Public folder from it's location.​
4. Close the Public folder window.​
5. Check to see if the Public folder has turned back to the special defualt folder.​
A) If yes, then your done.​
B) If not, proceed to STEP TWO below.​





STEP TWO
Replace Desktop.ini File for Public Folder

2. Click on the download button below to download the Public_Folders.zip file, then click on Save and save it to the Desktop.​
download

3. Right click on the Public_Folders.zip file (on Desktop) and click on Open.​
4. Extract the same folder(s) for the Public folder name with the standard yellow icon displayed to the Desktop.​
5. Open the extracted folder and right click on the desktop.ini file and click on Copy. (See screenshot below)​
NOTE: This file is set as a hidden file. This is why it is faded.
Desktop_ini.jpg

6. Open the Public folder (Step One) that has the standard yellow folder icon displayed.​
A) Right click on a empty area in the folder's window and click Paste.​
NOTE: If you are asked if you want to replace the old desktop.ini file, then click Copy and Replace. (See screenshot below)
B) Repeat step 5 for each Public folder you need to fix.​
Copy_Replace.jpg

7. Close all windows.​
9. In the elevated command prompt, type the command below (see table below) for the Public folder name you need to fix. (See screenshot below table)​
NOTE: This will set the Public folder as Read-only. You can Copy and Paste these to make it easier for you.

Public Folder

Command

Public Desktop

attrib +h +r "C:\Users\Public\Desktop"

Public Documents

attrib +r "C:\Users\Public\Documents"

Public Music

attrib +r "C:\Users\Public\Music"

Public Pictures

attrib +r "C:\Users\Public\Pictures"

Public Videos

attrib +r "C:\Users\Public\Videos"
Command_Prompt.jpg

10. Repeat step 9 for each Public folder that you replaced the desktop.ini file for in steps 5 and 6.​
11. Close the elevated command prompt.​
12. Restart the computer, or log off and log on again for the changes to take effect.​
13. Confirm that the folder icon is back to normal.​
14. You can now delete the downloaded folders on the desktop and set your hidden files and folders settings back to normal in step 1 above.​
That's it,
Shawn


 
Last edited:
Shawn Brink

Comments

Well my icons seem to be correct, but I have a problem with the Public Documents folder when I choose anything above "medium icons" under the Views dropdown menu in the explorer window: The Public Documents' icon seems to remain in its 'medium' size. (see attachment)

I'm using Vista Business 32 bit right now, but I think the same problem exists in my Vista Home Premium 64bit machine.

I tried the above procedure hoping that it would also solve my problem but that wasn't the case. Any ideas?
 

Attachments

Hello Leo, and welcome to Vista Forums.

Strange, it must be that way by default. I get the same thing.

It using a smaller icon out of the %SystemRoot%\system32\SHELL32.dll file.

If you like you can right click on the folder, click on the Customize tab, Change Icon button, copy and paste the path below in the field box below and press Enter. Next, you could select the same icon below, or another icon if you like, then click on OK. Click on OK again in the folder properties window to apply.

%SystemRoot%\system32\imageres.dll

Public.jpg

Hope this helps,
Shawn
 
Hi Shawn,

At least this confirmed that its not only me who has this problem.

So... I've checked %SystemRoot%\system32\SHELL32.dll with IcoFx's extract feature and it seems someone forgot to include the 256px version in the Public Documents icon. ¬¬

Guess using a custom icon is the only way to fix this. :rolleyes:
I think I had downloaded a zip with all 256x256 vista icons in png format. Maybe I'll find the right icon there... If I do, I'll post it here.


Thanks,
Leo
 
Top