Removable Drives - Allow or Deny All Access

ByLine
How to Deny or Allow Access to All Removable Drives in Vista and Windows 7
Synopsis
This will show you how to deny or allow read and write access to all removable drives connected to your computer for all users. This will include access to all removable Hard Disk, CD/DVD, Floppy and USB Floppy Key, WPD (Windows Portable Devices) and Tape drive media.
How to Deny or Allow Access to All Removable Drives in Vista and Windows 7


information   Information
This will show you how to deny or allow read and write access to all removable drives connected to your computer for all users. This will include access to all removable Hard Disk, CD/DVD, Floppy and USB Floppy drive, WPD (Windows Portable Devices), and Tape drive media.
Note   Note
By default, all access is allowed to removable drives in Vista for all users. This can be handy if you do not want people that share the computer to be able to read from or write to any type of removable drive.
warning   Warning

  • If you deny read and write access to all removable drives with this setting, it will take precedence over the settings for the individual removable drive settings mentioned in the above Information box links and related links.
  • If you allow read and write access to all removable drives with this setting, it will only undo the deny all setting. Each removable drive setting can still be individually set to deny or allow access to them from the above Information box links and related links.





METHOD ONE
Through the Local Group Policy Editor

1. Open the all users, specific users or groups, or all users except administrators Local Group Policy Editor for how you want this policy applied.​
2. In the left pane, click on User Configuration, Administrative Templates, System, and Removable Storage Access. (See screenshot below step 5)​
Group_Policy.jpg

3. In the right pane, right click on All Removable Storage classes: Deny all access and click on Properties. (See screenshot above)​
4. To Allow All Removable Drives Read and Write Access
A) Select (dot) Disabled or Not Configured and click on OK. (See screenshot below step 5A)​
B) Go to step 6.​

5. To Deny All Removable Drives Read and Write Access
A) Select (dot) Enabled and click on OK.​
Properties.jpg

6. Close Local Group Policy Editor window. Your done.​



METHOD TWO
Using a REG File Download

1. To Allow All Removable Drives Read and Write Access
A) Click on the Download button below to download the file below.​
Allow_All_Removable_Devices_Access.reg
download

B) Go to step 3.​

2. To Deny All Removable Drives Read and Write Access
A) Click on the Download button below to download the file below.​
Deny_All_Removable_Devices_Access.reg
download

3. Click on Save, and save the .reg file to the Desktop.​
4. Right click on the downloaded .reg file and click on Merge.​
5. Click on Run, Continue (UAC-Vista) or Yes (Windows 7), Yes, and then OK when prompted.​
6. When done, you can delete the .reg file (on Desktop).​
7. Restart the computer to apply changes.​



METHOD THREE
Manually in Registry Editor

1. Open the Start Menu, then type regedit in the search box and press Enter.​
2. If prompted by UAC, then click on the Continue (Vista) or Yes (Windows 7).​
3. In regedit, navigate to the location below. (See screenshot below)​
NOTE: If RemovableStorageDevices is not there in the left pane, then right click on Windows and click on New and Key. Type RemovableStorageDevices and press Enter.​
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\RemovableStorageDevices
Reg_Before.jpg

4. To Deny All Removable Drives Read and Write Access
A) In the right pane of RemovableStorageDevices, right click on a empty area and click on New and DWORD (32-bit) Value and type Deny_All and press Enter. (See screenshot below)​
B) Right click on Deny_All and click on Modify.​
Deny_All.jpg

C) Type 1 and click on OK. (See screenshot below)​
Modify.jpg

D) Go to step 6.​

5. To Allow All Removable Drives Read and Write Access
A) In the right pane of RemovableStorageDevices, right click on Deny_All and click on Delete. (See screenshot below step 4B)​
B) Click on Yes to confirm delete.​

6. Close regedit.​
7. Restart the computer to apply changes.​
That's it,
Shawn


 
Last edited:
Shawn Brink

Comments

I used Method 2 in the article , downloaded the .reg file referred to in Step 1 and carried out all the further steps in Method 2. Stupidly I missed the reference to x64-my OS is Vista Home Premium 32 bit. Now when I connect my USB flash drive and try to open it from Computer I get the message "Please insert a Disk in Disk (F)", Disk F being the flash drive.

Any help you can give me to sort this problem out would be greatly appreciated.

Thanks and regards,
Roy Whitethread
 
Last edited:
Hell Royw, and welcome to Vista Forums.

I'm sorry, but I do not understand what you meant by what you said quoted below. There's no reference to that in this tutorial. :confused:

Stupidly I missed the reference to x64-my OS is Vista Home Premium 32 bit.
Using the .reg download in METHOD TWO step 1, only removes the Deny_All entry that you see in the MANUAL option in METHOD TWO (step 6).
 
Sorry, the reference to x64 only appeared in the link to the article, not in the article itself. I followed the instructions in Method 2, the Manual Way, and now when I look at HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\RemovableStorageDevices
under Data in the right pane it says "value not set". I have 2 Takems USB 2 flash devices, and now when I connect one I can open everything except one folder called CarryItEasy.exe, which says access denied. (I could open it before). When I connect the other device and try to open it from Computer it says "Please insert a Disk in Disk (F:)", F being the USB device.
Any help you can give me to resolve this problem would be greatly appreciated. (My OS is Vista Home Premium).
Thanks and regards,
Roy
 
Roy,

Try merging this .reg download below. It will delete the RemovableStorageDevices key to reset this for you back to the default settings. You will need to restart the computer after merging it for it to be applied.
 

Attachments

I did as you suggested, and the registry key concerned is no longer in the registry,but still have exactly the same problem with the USB flash drives.

Is there anything else you can think of?

Please advise and thanks for your patience.

Regards,
Roy
 
Well at least that eliminates the tutorial doing this. Check to make sure that you have the latest chipset drivers installed for your motherboard, and you might also reformat the USB key to see if that may help as well.
 
Thanks again.

I know I'm displaying my ignorance asking this, but by reformat the USB key do you mean format each USB drive?

Please advise.
Regards,
Roy
 
Sorry, yep. Formatting them with the NTFS file system may reset it in Vista to allow it to not ask you to insert a DVD for it.
 
I tried to format the disk that gives me the "...insert a Disk in Drive F" message,
but when I clicked format I was told "There is no disk in Drive F. Please insert a Disk".

Help!!

Thanks and regards,
Roy
 
Umm, ok. With the USB drive connected, go into Device Manager and expand and look under Disk drives. Right click on the USB drive(s) this is happening with, and click on Uninstall and OK to approve. Afterwards disconnect and reconnect the USB drive to see if Vista will properly detect it now.

Did you have the latest motherboard chipset drivers installed?
 
I did as you suggested but still got the same mesage when I tried to open the USB drive.
How do I check whether I have the latest motherboard chipset drivers installed.
Please advise.
Regards,
Roy
 
What is the brand and model of your computer? I'll see if I can't find a driver download page for you to check with at your computer manufacturer's website. :)
 
It turned out that one of the USB drives was faulty. The problem with the other was that it was attached to an extension cable to the USB connection on the computer, and all I had to do was get a better extension cable.

I really appreciate the time you took to help me,and apologise for the delay in getting back to you,but I have been away from home.

Best regards,
Roy
 
Top