Remove Virus without Booting into Windows Vista

ByLine
How to Remove Virus without Booting into Windows Vista
Synopsis
This will show you how to scan the system for viruses when Windows Vista fails to boot, or the system keeps restarting and not allowing you to do anything.
Remove Virus without Booting into Windows Vista
information   Information
This will show you how to scan the system for viruses when Windows Vista fails to boot, or the system keeps restarting and not allowing you to do anything.







STEP ONE
Reboot to the Microsoft® Windows Vista™ Recovery Environment (WinRE)

1. Restart the computer.​
2. Tap the <F8> key during startup until the Windows Advanced Options menu appears.​
NOTE: If the Windows Advanced Options menu does not appear, restart the computer, and try again.​
3. Press the <Down Arrow> until Repair Your Computer is highlighted, and press <Enter>.​
A) The System Recovery Options window appears.​

4. Click to select your language, and click Next.​
5. Log in as a user with administrative rights, and click OK.​
The Windows Vista Recovery Environment appears.​






STEP TWO
Enable Networking and Download Mozilla Firefox® in Windows Recovery

NOTE: To start the system in the Windows Recovery Environment, perform the following steps:
1. Press the <Windows> key (the key between the <Ctrl> and <Alt> keys) and press the <R> key.​
A) The Run window appears.​

2. Type cmd and press the <Enter> key.​
A) The System Recovery window appears.​


3. In the System Recovery Options window, click the Command Prompt option.​
A) The Command Prompt window appears.​


4. In the Command Prompt window, type the following command and press the <Enter> key after each command.​
C:\
cd windows\system32
wpeutil initializenetwork

5. Download Firefox by typing the following commands at the C\Windows\System32> prompt and press the <Enter> key after each command :​
NOTE: The download process may take several minutes.​

anonymous

lcd c:\

cd pub

cd mozilla.org

cd firefox

cd releases

cd 2.0

cd win32

cd en-US

get "Firefox Setup3.0 exe"


6. When Firefox finishes downloading, continue to type the following commands in the command prompt and press <Enter> key after each commanf.
quit​

cd\


7. Execute the Firefox installer by typing: Firefox Setup 3.0.exe
The Firefox Setup Wizard appears.​
Install mozilla firefox.​








STEP THREE
Set Up Mozilla Firefox in the Command Prompt Window

1. In the Command Prompt window, type c:\program files\mozilla firefox\firefox.exe and press the <Enter> key.​
A) The Mozilla Firefox window appears.​

2. Click Tools and click OptionsThe Options menu appears.​
3. Choose Always ask me where to save files and click OK.​







STEP FOUR
Download and install Avast AntiVirus with Mozilla Firefox

1. In the Command Prompt window, type c:\program files\mozilla firefox\firefox.exe and press the <Enter> key.​
A) The Mozilla Firefox browser appears.​

2. Type in the following URL in the address bar: http://files.avast.com/iavs4pro/setupeng.exe and press the <Enter> key.​
A) The Opening Setupeng.exe window appears.​

3. Click Save File.​
A) The Downloads window appears.​


4. Click Open to launch the installer.​
A) The Open Executable File window appears.​


5. Click OK to launch the setupeng.exe file.​
A) The Avast Setup window appears.​


6. Leave the destination as C:\Program Files\Alwil Software\Avast4 and install Avast.​
7. When the progress bar stops on the Installation Progress window, the installation is complete.​
A) A new window appears to ask if you want to schedule an antivirus scan of your hard drive.​


8. Click Yes to restart your computer.​
A) The Seup Finished window appears.​

9. Click Restart and click Finish.
A) Your computer restarts and completes the installation process.​


NOTE: If any issues arise after launching Avast after it has been installed, navigate and load the following application from the Command Prompt window: C:\Program Files\Alwil Software\Avast4\ashSimp2.exe.



The computer will restart and will perform a boot scan.
Thats it,
Dinesh. ;)
 

Attachments

  • Biohazard.png
    Biohazard.png
    37 KB · Views: 91
Last edited by a moderator:

Kernel

Vista User
Power User
Hi Denesh,

I was able to initialize the network by typing the following command "wpeutil initializenetwork" it says "the command completed successfully" but it could not connect to the ftp server. Do you have any idea why i am not able to connect?

Tried following things....
Tried to load static IP
Installed firefox...still not able to use
Tried in virtual pc too
loaded driver using drvload.exe command

it was wonderful tutorial but i am not able to try different things here as i stuck.

Thanks in advance.
 

My Computer

System One

  • Manufacturer/Model
    Custom
    CPU
    AMD
    Motherboard
    ASUS
    Memory
    2GB
    Graphics Card(s)
    Nvidia 256MB
    Sound Card
    Creative 7.1
    Monitor(s) Displays
    19" Viewsonic and Sony 26" S Series TV
    Screen Resolution
    1920x1080
    Hard Drives
    Sata (1 TB) and IDE (350GB)
    Mouse
    Optical (Wireless)
    Keyboard
    Multimedia (Wireless)
    Internet Speed
    2MB

dinesh

Vista Expert
Vista Guru
Hi kernel, in my case, i have an auto generated IP address which is differnet everytime i restart my modem.
If you have only one ip address assigned to this computer then i doubt it will work.
try resetting your modem while you are in WIN RE.
let me know if it works for you.
Note: I have also tried this above tutorial on 3-5 different computers and ISP and it works just fine. But they all had dynamic ip address.
 

My Computer

System One

  • Manufacturer/Model
    Compaq
    CPU
    intel core 2 duo T 5550 @ 1.83 MHz
    Motherboard
    intel 965 chipset family
    Memory
    2 GB DDR 2 SD RAM @ 667 MHz
    Graphics Card(s)
    On board upto 358 MB RAM
    Sound Card
    Onboard
    Monitor(s) Displays
    15"
    Hard Drives
    160 GB WDC

tanuj_chadha

Devil
Vista Guru
Hi Dinesh,
get "Firefox Setup2.0 exe". This command is not working states as access denied. :mad:

I have tried without quotes, with quotes. Tried .exe extn as well. But still the same thing.
 

My Computer

System One

  • CPU
    T4200 Intel
    Memory
    2 X 1GB DDR2
    Graphics Card(s)
    Intel Integrated
    Hard Drives
    1 X 250GB 7200RPM

Kernel

Vista User
Power User
Hi Dinesh,
get "Firefox Setup2.0 exe". This command is not working states as access denied. :mad:

I have tried without quotes, with quotes. Tried .exe extn as well. But still the same thing.

I got the same error :(. I tried with 3.0 and that worked :D.
 

My Computer

System One

  • Manufacturer/Model
    Custom
    CPU
    AMD
    Motherboard
    ASUS
    Memory
    2GB
    Graphics Card(s)
    Nvidia 256MB
    Sound Card
    Creative 7.1
    Monitor(s) Displays
    19" Viewsonic and Sony 26" S Series TV
    Screen Resolution
    1920x1080
    Hard Drives
    Sata (1 TB) and IDE (350GB)
    Mouse
    Optical (Wireless)
    Keyboard
    Multimedia (Wireless)
    Internet Speed
    2MB

Kernel

Vista User
Power User
Hi kernel, in my case, i have an auto generated IP address which is differnet everytime i restart my modem.
If you have only one ip address assigned to this computer then i doubt it will work.
try resetting your modem while you are in WIN RE.
let me know if it works for you.
Note: I have also tried this above tutorial on 3-5 different computers and ISP and it works just fine. But they all had dynamic ip address.

Sorry buddy, it was my mistake.
I get different IP Address everytime i restart my modem (Dynamic :))..but DHCP server was turned of in modem modem setting.

I turned on DHCP server and everything just worked fine :).

Thanks for your reply.
 

My Computer

System One

  • Manufacturer/Model
    Custom
    CPU
    AMD
    Motherboard
    ASUS
    Memory
    2GB
    Graphics Card(s)
    Nvidia 256MB
    Sound Card
    Creative 7.1
    Monitor(s) Displays
    19" Viewsonic and Sony 26" S Series TV
    Screen Resolution
    1920x1080
    Hard Drives
    Sata (1 TB) and IDE (350GB)
    Mouse
    Optical (Wireless)
    Keyboard
    Multimedia (Wireless)
    Internet Speed
    2MB

dinesh

Vista Expert
Vista Guru
Hi kernel, in my case, i have an auto generated IP address which is differnet everytime i restart my modem.
If you have only one ip address assigned to this computer then i doubt it will work.
try resetting your modem while you are in WIN RE.
let me know if it works for you.
Note: I have also tried this above tutorial on 3-5 different computers and ISP and it works just fine. But they all had dynamic ip address.

Sorry buddy, it was my mistake.
I get different IP Address everytime i restart my modem (Dynamic :))..but DHCP server was turned of in modem modem setting.

I turned on DHCP server and everything just worked fine :).

Thanks for your reply.
hi kernel, i m glad that its working for you now...
and thanks for the firefox correction.
the tutorial has been updated for the same. ;)
 

My Computer

System One

  • Manufacturer/Model
    Compaq
    CPU
    intel core 2 duo T 5550 @ 1.83 MHz
    Motherboard
    intel 965 chipset family
    Memory
    2 GB DDR 2 SD RAM @ 667 MHz
    Graphics Card(s)
    On board upto 358 MB RAM
    Sound Card
    Onboard
    Monitor(s) Displays
    15"
    Hard Drives
    160 GB WDC

russellpepper

New Member
4. In the Command Prompt window, type the following command and press the <Enter> key after each command.
C:\
cd windows\system32
wpeutil initializenetwork

I am this far along now what's next?​
 

My Computer

System One

  • Manufacturer/Model
    acer aspire 5315
    Internet Speed
    54 mbps

Brink

Staff member
mvp
Hello Russell, and welcome to Vista Forums.

If this is what you meant, then here you go. ;)

5. Download Firefox by typing the following commands at the C\Windows\System32> prompt (Figure 3) and press the <Enter> key after each command :
NOTE: The download process may take several minutes.
ftp ftp.mozilla.org
anonymous
lcd c:\
cd pub
cd mozilla.org
cd firefox
cd releases
cd 2.0
cd win32
cd en-US
get "Firefox Setup3.0 exe"
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master 3
    Keyboard
    Logitech wireless K800
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD

nadopine

New Member
I'm MS Dos retarted and I can only get X:\windows\system32 command prompt in cmd for my laptops WinRE. Is this okay? It seems to be working as I can get to the end of Step 2 Section 5.

Here's where my problem starts. This is my last 3 lines in command prompt:

ftp> get "Firefox Setup3.0 exe"
200 PORT command successful. Consider using PASV
550 Failed to open file.

Any suggestions on how to get the file to download?

David
 
Last edited:

My Computer

dinesh

Vista Expert
Vista Guru
I'm MS Dos retarted and I can only get X:\windows\system32 command prompt in cmd for my laptops WinRE. Is this okay? It seems to be working as I can get to the end of Step 2 Section 5.

Here's where my problem starts. This is my last 3 lines in command prompt:

ftp> get "Firefox Setup3.0 exe"
200 PORT command successful. Consider using PASV
550 Failed to open file.

Any suggestions on how to get the file to download?

David
You are not typing the command correctly.
its not "ftp> get "Firefox Setup3.0 exe"
Check the spelling and try again.:geek:
 

My Computer

System One

  • Manufacturer/Model
    Compaq
    CPU
    intel core 2 duo T 5550 @ 1.83 MHz
    Motherboard
    intel 965 chipset family
    Memory
    2 GB DDR 2 SD RAM @ 667 MHz
    Graphics Card(s)
    On board upto 358 MB RAM
    Sound Card
    Onboard
    Monitor(s) Displays
    15"
    Hard Drives
    160 GB WDC

nadopine

New Member
How is my spelling any different than Step 2, Section 5, final line? The ftp> is automatically there and I can't get rid of it.

Like I said, I'm command prompt retarded so you can't assume I know what's supposed to be there.

David
 

My Computer

dinesh

Vista Expert
Vista Guru
Step 2, section 5 first line is
ftp ftp.mozilla.org
but its not "ftp> get "Firefox Setup3.0 exe"
 

My Computer

System One

  • Manufacturer/Model
    Compaq
    CPU
    intel core 2 duo T 5550 @ 1.83 MHz
    Motherboard
    intel 965 chipset family
    Memory
    2 GB DDR 2 SD RAM @ 667 MHz
    Graphics Card(s)
    On board upto 358 MB RAM
    Sound Card
    Onboard
    Monitor(s) Displays
    15"
    Hard Drives
    160 GB WDC

nadopine

New Member
Misunderstanding. I get ALL the way through Step 2, Section 5 but the last line gives me the 550 access denied code as stated in my earlier post. The "ftp>" prefix is generated by command prompt. I just input the code you provided after it and press enter.

I hope this is a better explaination of my problem.

David
 

My Computer

dinesh

Vista Expert
Vista Guru
Sorry for the misunderstanding David, well after your post, i have tried all the steps but i did not receive any error throughout. :confused:
 

My Computer

System One

  • Manufacturer/Model
    Compaq
    CPU
    intel core 2 duo T 5550 @ 1.83 MHz
    Motherboard
    intel 965 chipset family
    Memory
    2 GB DDR 2 SD RAM @ 667 MHz
    Graphics Card(s)
    On board upto 358 MB RAM
    Sound Card
    Onboard
    Monitor(s) Displays
    15"
    Hard Drives
    160 GB WDC

nadopine

New Member
I figured it out. Good ol' Google!

You directory is incorrect, at least for my setup

ftp ftp.mozilla.org
anonymous
lcd c:\ (password you're prompted for)
cd pub
cd mozilla.org
cd firefox
cd releases
cd latest-3.0
cd win32
cd en-US
cd "Firefox Setup 3.0.10.exe"

I got this file location from:Index of /pub/mozilla.org

Now my problem is I can't open this executable file. Any suggestions?

Also, I already have Mozilla on my machine, is it required to reinstall it?

David
 
Last edited:

My Computer

i have a questions
i have a oem vista there fore i cant use winre
but i try this tutorial in windows 7 RC 7100
when this window appears

WinRE_01.jpg


i try this step

1. Press the <Windows> key (the key between the <Ctrl> and <Alt> keys) and press the <R> key.
A) The Run window appears.


pc restarts and nothing happened!
have any idea?or i did something wrong?

and ı have allready see command prompt why im doing this step?
 
Last edited:

My Computer

PAccO

New Member
This can be done with hiren's bootcd
nice tutorial tho
 

My Computer

System One

  • Manufacturer/Model
    Multirama™
    CPU
    AMD Athlon Dual Core 4600+ 2.44Ghz
    Motherboard
    Gygabyte GA-M61VME S2
    Memory
    3 GB
    Graphics Card(s)
    Nvidia GeForce 9600 GT CUDA 1 GB VRAM
    Sound Card
    High Definition Speakers
    Monitor(s) Displays
    NEC 17"
    Hard Drives
    LaChiE 750 GB
    Maxtor 500 GB
    Western Digital 500 GB (Inside)
    PSU
    Pegasus 425 W
    Mouse
    Logitech
    Keyboard
    Logitech
    Internet Speed
    24 mbps [=- 1.3 MB/s -=]
    Other Info
    My graphics roxx lol

dinesh

Vista Expert
Vista Guru
i have a questions
i have a oem vista there fore i cant use winre
but i try this tutorial in windows 7 RC 7100
when this window appears

WinRE_01.jpg


i try this step

1. Press the <Windows> key (the key between the <Ctrl> and <Alt> keys) and press the <R> key.
A) The Run window appears.


pc restarts and nothing happened!
have any idea?or i did something wrong?

and ı have allready see command prompt why im doing this step?
You will need to Click on command prompt and follow the tutorial. It wont matter if you have a retail or OEM version. I have tried it on both and worked fine. ;)
 

My Computer

System One

  • Manufacturer/Model
    Compaq
    CPU
    intel core 2 duo T 5550 @ 1.83 MHz
    Motherboard
    intel 965 chipset family
    Memory
    2 GB DDR 2 SD RAM @ 667 MHz
    Graphics Card(s)
    On board upto 358 MB RAM
    Sound Card
    Onboard
    Monitor(s) Displays
    15"
    Hard Drives
    160 GB WDC

truthkid

Tactless SOB
Power User
Great tutorial for those stuck with a pesky virus. Just curious why you use so many change directory commands when the following is simpler

"cd pub/mozilla.org/firefox/releases/2.0/win32/en-US"

Also because I'm behind a proxy so my ftp access is limited, is the firefox exe in this directory guaranteed to stay "Firefox Setup3.0 exe?" If so you couldn't you just use:

get pub/mozilla.org/firefox/releases/2.0/win32/en-US/Firefox Setup3.0 exe
 

My Computer

System One

  • Manufacturer/Model
    Sager NG2096
    CPU
    Intel P8700
    Memory
    4 Gigs
    Graphics Card(s)
    9600M GT
    Monitor(s) Displays
    Samsung PN50A550
    Screen Resolution
    Primary 1680 X 1050, Secondary 1920 X 1080
    Mouse
    Logitech MX Revolution
    Internet Speed
    Satalite :-(
    Other Info
    Running SUSE, Solaris, Kalyware, and BSD through vmware whenever the mood strikes
Top