Removing the Sleep function in the Shutdown menu

ByLine
Here's a way to remove the sleep function in the shutdown menu
Synopsis
This will show how to remove the Sleep option from the Shutdown options.
Here's a way to remove the sleep function in the shutdown menu:

* Click Start, Run
* Type "regedit"
- If you want to disable sleep for all users, go to HKey_Local_Machine\Software\Policies\Microsoft\
- If you want to disable sleep for the current user only, go to HKey_Current_User\Software\Policies\Power\ and skip the next 2 steps.
* In the right pane, rightclick and choose "new","key".
* Type "Power"
* Again, in the right pane, rightclick and choose "new","key".
* Type "PowerSettings"
* Once more; in the right pane, rightclick and choose "new","key".
* Type "abfc2519-3608-4c2a-94ea-171b0ed546ab"
* You will now have the following in the left pane:



* Now, in the right pane, rightclick and choose "DWord (32 bit)-value"
* Type "ACSettingIndex"
* Doubleclick this entry and set it's value to 0 (Hexadecimal)
* It will now look like this:



* Reboot or logoff and logon and sleep is gone from the shutdown menu.

This however, does not remove the sleep option from the new start menu, but it'll be greyed-out.
 

Attachments

  • Shut_Down.png
    Shut_Down.png
    21.1 KB · Views: 167
Last edited by a moderator:

Clay

Member
Hi, I'm new here. Something has disabled the Sleep function in my Vista Ultimate 64 and I want to get it back. Sleep was working fine until yesterday. Now it goes into full Hibernate mode when I hit the Sleep button on the keyboard. In the Start menu, the Sleep function is grayed out now.

I searched but only found this tutorial on how to Disable Sleep Function. So how do I enable it? Do I follow the same instructions as above, except for the final hex value use "1" instead of "0"?
Thanks for the help!
>>>> Clay >>>>
 

My Computer

Hi, I'm new here. Something has disabled the Sleep function in my Vista Ultimate 64 and I want to get it back. Sleep was working fine until yesterday. Now it goes into full Hibernate mode when I hit the Sleep button on the keyboard. In the Start menu, the Sleep function is grayed out now.

I searched but only found this tutorial on how to Disable Sleep Function. So how do I enable it? Do I follow the same instructions as above, except for the final hex value use "1" instead of "0"?
Thanks for the help!
>>>> Clay >>>>

Hi,


I.m.o., the best thing to do to enable the sleepfunction is the following;

Go to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\ and remove the whole 'Power' key in the left pane by rightclicking the word 'Power' and choose remove.
This should work.

Good luck
 
Last edited:

My Computer

System One

  • CPU
    Intel(R) Pentium(R) 4 CPU 3.00
    Motherboard
    AsRock P4i65G
    Memory
    2x 512 MB DDR
    Graphics Card(s)
    NVIDIA GeForce 6600 256MB
    Hard Drives
    Maxtor 6Y160M0 160GB SATA

Clay

Member
Go to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\ and remove the whole 'Power' key in the left pane by rightclicking the word 'Power' and choose remove.
This should work.
I went to HKey_Local_Machine\Software\Policies\Microsoft\ in Regedit and I found no "Power" entry. Now I'm stumped again. Something has disabled my Sleep function. I tried rolling back to a recover point from two days ago when it was working, but that didn't fix it either.

Any other thoughts on how to re-enable the Sleep function?
 

My Computer

Brink

Staff member
mvp
Hi Clay,

You might go through this tutorial also to see if something in there is the cause of your sleep problem. I would check to see if you accidentally cleaned (disabled) the hibernation file in Disk Cleanup, check your sleep settings in the Power Plan options, and the other steps.

http://www.vistax64.com/tutorials/63567-power-options-sleep-mode-problems.html

Have you installed or changed anything before this happened?

Shawn
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master 3
    Keyboard
    Logitech wireless K800
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD

Clay

Member
Hi Clay,

You might go through this tutorial also to see if something in there is the cause of your sleep problem. I would check to see if you accidentally cleaned (disabled) the hibernation file in Disk Cleanup, check your sleep settings in the Power Plan options, and the other steps.

http://www.vistax64.com/tutorials/63567-power-options-sleep-mode-problems.html

Have you installed or changed anything before this happened?

Shawn
Hibernation is working fine. That is sort of the problem. When I press the Sleep key on the keyboard, it actually goes into full hibernation instead. When I look at the Start button options, the Sleep selection is disabled (grayed out, not selectable). The Sleep function was working fine until two days ago (Monday) when I noticed that the computer wasn't waking up when I moved the mouse or touched the keyboard. I now have to hit the front power switch to get it to start back up. Then it does come back out of hibernation, resuming with everything where I left it.

I did install a couple of driver updates the day before Sleep stopped working. So I rolled the system back to the Recover point that was saved the day before the driver update. That still didn't fix it.

In the Power Plan options, I have everything set to Sleep. I think there is even a setting where I tell it to "Never Hibernate".

I will step through the other tutorial to see what I can find. Thanks for the pointer.

>>>> Clay >>>>
 

My Computer

Clay

Member
It is not HKLM but HKCU

Sid.

I did find a "Power" key there, so I deleted it and restarted the system. Didn't make any difference though. I have no Sleep options. Only full Hibernate and Shut Down.

I'll have to step through the other tutorial mentioned above this weekend and see if I can find anything.

Thanks,
>>>> Clay >>>>
 

My Computer

Clay

Member
Last weekend I updated a couple of drivers on my system: the NVIDIA and the audio card. The next day, all the Sleep functions were gone. I eventually reverted to the recovery point prior to the driver updates, but that didn't fix the Sleep functions.

Today I decided that I might as well go ahead and re-install the video and audio driver updates. And the Sleep function magically came back. All is working fine now.

Go figure!

>>>> Clay >>>>
 

My Computer

Bare Foot Kid

R.I.P. August 13th 2014
Hey Cyberstorm77,

This worked like a charm, thanks! (or just like I knew what I was doing :rolleyes: )


Later :shock: Ted
 

My Computer

System One

  • Manufacturer/Model
    * BFK Customs *
    CPU
    Intel C2Q 9550 Yorkfield
    Motherboard
    ASUS P5Q Pro
    Memory
    8GB Dominator 8500C5D
    Graphics Card(s)
    XFX ATI 1GB 4870 XXX
    Sound Card
    Realtek HD 7-1
    Monitor(s) Displays
    1x 47" LCD HDMI & 2x 26" LCD HDMI
    Screen Resolution
    1920x1080P & 1920x1200
    Hard Drives
    2x 500GB 7200RPM 32MB Cache WD Caviar Black
    PSU
    Corsair 620HX
    Case
    CM Cosmos RC-1000
    Cooling
    Tuniq Tower 120, 2x 140mm and 3x 120mm case fans
    Mouse
    Razer Diamondback 3G
    Keyboard
    HP Enhansed Multimedia
    Internet Speed
    18.6Mb/s
    Other Info
    My First Build ;)
Top