• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Security Center Change Settings

#1
I want to disable automatic updates and UAC but each time i do Security Center gives me a problem. Now i don't want to hide notifications and icons but removing the check security center does regarding these 2 problems. A thing like turn off all messages regarding automatic updates and UAC of 7 for example. Thanks.
 

My Computer

System One

  • Operating System
    Windows Vista

Vistaar

Vista Guru
Posts
539
#2
Hello Be4stElectrjc, I can certainly understand why you want to disable automatic updates these days. Forum guru ilikefree has suggested setting the service to manual start (https://www.vistax64.com/windows-up...seems-hang-while-checking-24.html#post1407512). I have not tested that because I use Microsoft Security Essentials, and automatic definition updates would probably be prevented also (whereas setting Windows Update to "never check for updates" does not interfere with definition updates). Anyway, right-clicking the red shield and selecting Exit once per logon does not bother me very much.

On the other hand, I would never think of disabling UAC, which is an important security feature of Vista. By far the safest way to operate, especially when browsing the internet, is to be logged in as a standard user with UAC turned on, and with your administrator account protected by a strong password. If you are determined to disable those warnings, I suppose you can search the forums as easily as I could.
 

My Computer

System One

  • Operating System
    Vista Home Premium x86 SP2
    Manufacturer/Model
    HP Pavilion Elite m9150f
    CPU
    Intel Q6600
    Memory
    3 GB
    Graphics Card(s)
    NVIDIA GeForce 8500 GT
#3
Hi, my Windows Update service is set on manual start already because it takes too much CPU and RAM in relation to the sense of turning it on, looking the actual Vista's situation. "Never check for updates" it's selected too, since there is an update each month until 11 April 2017 i do it manually. No matter, the red shield with the warning appears anyway.
Here i read about disable these warnings from the desktop, but they stay in the security center as red.
 

My Computer

System One

  • Operating System
    Windows Vista

Vistaar

Vista Guru
Posts
539
#4
my Windows Update service is set on manual start already..."Never check for updates" it's selected too,
If I understand ilikefree's suggestion correctly, the "never check for updates" setting is not necessary if the service is set to manual start; and it is definitely that setting that triggers the warnings.
 

My Computer

System One

  • Operating System
    Vista Home Premium x86 SP2
    Manufacturer/Model
    HP Pavilion Elite m9150f
    CPU
    Intel Q6600
    Memory
    3 GB
    Graphics Card(s)
    NVIDIA GeForce 8500 GT
#5
If i use automatic updates on security center it triggers the service to automatic (delayed load) that eats like a hog. From there you can temporarily set the service to manual (service not running) and still have green until the next boot where security center detects that service isn't on automatic (delayed load) and shows the red alert until you set it like it wants. The other 2 options for windows update are yellow, so not useful. The alert is set when you launch windows update, on boot or in OS, it checks the service status and depending on its behaviour its set the color.
 
Last edited:

My Computer

System One

  • Operating System
    Windows Vista

Vistaar

Vista Guru
Posts
539
#6
Sorry, it sounds like ilikefree's suggestion wasn't very good after all. Hopefully someone else will post a better suggestion.
 

My Computer

System One

  • Operating System
    Vista Home Premium x86 SP2
    Manufacturer/Model
    HP Pavilion Elite m9150f
    CPU
    Intel Q6600
    Memory
    3 GB
    Graphics Card(s)
    NVIDIA GeForce 8500 GT

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
US of A

Posts
2,308
#8
Security center is always going to show red if windows updates is disabled and yellow if it is set to alert only. It is green only if WU is set for automatic. I don't know if any other way around that. Personally I disable alerts through security center.
 

My Computers

System One System Two

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
  • Operating System
    Windows 2008 R2 Enterprise
    Manufacturer/Model
    Compaq Presario SR5350F
    CPU
    Pentium 2.0 gHZ Dual core E2160
    Memory
    2 gb
    Screen Resolution
    1440 x 900
    Hard Drives
    300 GB