• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

SendTo Mail recipient... vanished!

#1
Although I see the mapimail link in the SendTo folder, it no longer shows up when I right-click an item.
I created a guest account: in that account, it is still functioning.
I tried to copy the mapimail link of the guest account and paste it in the main account (just in case it was corrupted): nothing!
The possible cause being that I changed the default association of the .mapimail files from "unknown application" to Thunderbird, I tried to restore it to "unknown application", but nothing happened.
I tried some other solutions from other threads as well as from other sites, but I didn't get to a solution.
Can anybody provide some help?
Thank you

DF


Vista Home Premium, SP1
 

My Computer

sidney1st

Member
Vista Guru
#2
Hi DF and welcome to Vista forums!

Open regedit (click Start, type in the search bar: regedit and press Enter)
What do you have in this key?
HKEY_CLASSES_ROOT\CLSID\{9E56BE60-C50F-11CF-9A2C-00A0C90A90CE}\InProcServer32
 

My Computer

#3
Thank you for the answer.
Here is what I have:

Nome chiave: HKEY_CLASSES_ROOT\CLSID\{9E56BE60-C50F-11CF-9A2C-00A0C90A90CE}\InProcServer32
Nome classe: <NESSUNA CLASSE>
Ora ultima scrittura: 02/11/2006 - 14.53
Valore 0
Nome <Senza nome>
Tipo REG_EXPAND_SZ
Dati %SystemRoot%\System32\sendmail.dll

Valore 1
Nome ThreadingModel
Tipo REG_SZ
Dati Apartment


Does it tell you anything?
Thanks

DF
 

My Computer

#5
Here it is:

Nome chiave: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.mapimail\OpenWithProgids
Nome classe: <NESSUNA CLASSE>
Ora ultima scrittura: 17/06/2008 - 12.19
Valore 0
Nome CLSID\{9E56BE60-C50F-11CF-9A2C-00A0C90A90CE}
Tipo REG_NONE
Dati
 

My Computer

sidney1st

Member
Vista Guru
#6
OK, then open thunderbird and there is surely an option to make it your default email client though i do not know thunderbird.
Then check that it is really your default prog, for example click on a mailto link, it should open your default account in thunderbird.
Then verify that the thunderbird link is in:
"C:\Users\username\AppData\Roaming\Microsoft\Windows\SendTo\"
You should have something like thunderbird.lnk in there.
 

My Computer

#7
Dear Sydney,
thunderbird is my default mail client. Everything functions fine (mailto: etc.), except for the "mail recipient" that disappeared from the right click menu.
If I paste a Thunderbird link in SendTo, it obviously functions as far as it opens Thunderbird, but without creating a new message and attaching the file I clicked.
The Mapimail file is correctly in SendTo, but does not show up anymore when I right click.
I tried also a step-back in system configuration, but apparently it did not help.
I did not notice when exactly the thing happened.
What I did recently is to change the default mail client in regedit, so that I could send e-mail directly from Acrobat (and it functioned), and to set mapimail default association from "unknown application" to "mozilla thunderbird". Could this have been the cause for the sudden vanishing of the Mail Recipient in right click menu? Could it depend from any Outlook file that I inadvertently uninstalled (I don't think this is the case, since the right click functions as usual in other newly created accounts)?
Please help me!!!
Thank you so much

DF
 

My Computer

sidney1st

Member
Vista Guru
#10
Well, there is a mess in your folder.
You should have a desktop.ini where the mail recipient should be.
The "destinario pasta" should be removed.
Remove also the thunderbird link as if i understand you put it there manually.
Go in the sendto folder of the users/administrator account, copy the desktop.ini file and paste it in your "daniele" sendto folder.
reboot and tell me now what you have in your sento folder.
 

My Computer

#11
Dear Syd,
meanwhile I played my last card, going 2 steps back in the System configuration, and it FUNCTIONED: Mail recipient has been restored.
Now, obviously in regedit the default Mail client has gone back to Outlook:

Nome chiave: HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail
Nome classe: <NESSUNA CLASSE>
Ora ultima scrittura: 26/04/2008 - 23.44
Valore 0
Nome LastUserInitiatedDefaultChange
Tipo REG_BINARY
Dati
00000000 df d6 4b 76 bd 6f c8 01 - ßÖKv½oÈ.

Valore 1
Nome <Senza nome>
Tipo REG_SZ
Dati Microsoft Outlook

Valore 2
Nome PreFirstRun
Tipo REG_SZ
Dati

Thus for instante in Acrobat I can no longer send files per e-mail directly.
Now, I fear that if I change that value again to Thunderbird, the problem will come out again... what should I do? Try and eventually go back once more in System configuration?
Thank you very very much and sorry for the huge loss of time

DF
 

My Computer

sidney1st

Member
Vista Guru
#14
Well, desktop.ini is back :)
So now start thunderbird, in the settings make it so it is is not anymore your default email client, apply and close.
Open it again, make it your default email client, apply and close.
Verifiy in the vista settings that thunderbird is the email prog by default, if not change the settings and normally it should work.
 

My Computer