Sony Vaio Model PCG5K7P Webcam Utility Wanted

mojo53

New Member
My son has an old Sony Vaio laptop with Vista Home Premium installed which was totally overloaded with every app and junk file possible and kept crashing all the time so i reformatted and clean installed Vista Ultimate x86 as he has lost all recovery disks so the recovery partion is gone as well.
I have managed to get everything working except the webcam and i have searched for hours and found nothing that works and Sony don't even recognize the model number PCG5K7P sold in Australia.
So the big question is does anyone know where to find the utility or a working fix to get it going



The only reference i have is the attached shot in Device Manager which i have downloaded several versions of the net all of which fail to install for whatever reasons, maybe something else is missing?
Thank you for any help.
 

Attachments

My Computer

System One

  • Manufacturer/Model
    Sony Vaio Laptop PCG-5K7P
    CPU
    Intel Core 2 Duo [email protected]
    Memory
    2 Gig
    Graphics Card(s)
    ATI Mobility Radeon x2300
    Sound Card
    Onboard Realtek High Def
    Screen Resolution
    1280x800
    Hard Drives
    Toshiba MK2546GSx 200 ATA Partitioned C:70 E:116 Recovery Partition Blown Away No Rescue Disks
    Other Info
    Upgraded from Vista Home x86 (Totally Corrupt) to Vista Ultimate x86 no driver disks available running on whatever Free drivers i can find on the internet Obviously not from $Sony$

wither 3

Vista Guru
Gold Member

My Computer

System One

  • Operating System
    Vista Home Premium 64 bit SP2
    Manufacturer/Model
    Cyberpower
    CPU
    Intel Quad CPU Q6700 2.67 GHZ
    Motherboard
    NVIDIA 780i
    Memory
    4 GB
    Graphics Card(s)
    MSI GTX 560 TI Twin Frozr
    Sound Card
    Sound Blaster SB Audigy
    Monitor(s) Displays
    Viewsonic VG2436
    Screen Resolution
    1920x1080p
    Hard Drives
    Samsung HD 105SI
    WDC WD20
    Case
    Apevia XJupiter
    Cooling
    air
    Mouse
    Logitech MX 600
    Keyboard
    Logitech MX 3200
    Internet Speed
    30 Mbps
Is it really safe to download drivers from 2nd party sites? It's not like there's any other option but it's concerning to me at least, specially drivers from manufactures and not Microsoft.
 

My Computer

System One

  • Operating System
    Win10
    Manufacturer/Model
    Toshiba C55-B5256
    CPU
    • Intel® Core™ i5-4210U Processor @ 1.70 GHz.
    Motherboard
    ^3M Cache, up to 2.70GHz with Intel® Turbo Boost Technology
    Memory
    8 GB DDR3

wither 3

Vista Guru
Gold Member
I don't know what "safe" means in regards to driver. I don't know if you have an anti-virus program or malwarebytes installed.

On the other hand, what is the alternative here?
 

My Computer

System One

  • Operating System
    Vista Home Premium 64 bit SP2
    Manufacturer/Model
    Cyberpower
    CPU
    Intel Quad CPU Q6700 2.67 GHZ
    Motherboard
    NVIDIA 780i
    Memory
    4 GB
    Graphics Card(s)
    MSI GTX 560 TI Twin Frozr
    Sound Card
    Sound Blaster SB Audigy
    Monitor(s) Displays
    Viewsonic VG2436
    Screen Resolution
    1920x1080p
    Hard Drives
    Samsung HD 105SI
    WDC WD20
    Case
    Apevia XJupiter
    Cooling
    air
    Mouse
    Logitech MX 600
    Keyboard
    Logitech MX 3200
    Internet Speed
    30 Mbps

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
Is it really safe to download drivers from 2nd party sites? It's not like there's any other option but it's concerning to me at least, specially drivers from manufactures and not Microsoft.
Specialty devices like webcams aren't going to have drivers from Microsoft unless it is a M$ webcam. You have to use manufacturer's drivers. The question is can you trust them from a third party site. Technically a site such as the provided link is a third party site. If SIW2 suggested it then I would trust it however that was almost 3 years ago. Things might have changed since then.
 

My Computer

System One

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
    Other Info
    N/A

wither 3

Vista Guru
Gold Member
You know, I didn't look at the age of this thread. My last sentence applied to the original problem.
 

My Computer

System One

  • Operating System
    Vista Home Premium 64 bit SP2
    Manufacturer/Model
    Cyberpower
    CPU
    Intel Quad CPU Q6700 2.67 GHZ
    Motherboard
    NVIDIA 780i
    Memory
    4 GB
    Graphics Card(s)
    MSI GTX 560 TI Twin Frozr
    Sound Card
    Sound Blaster SB Audigy
    Monitor(s) Displays
    Viewsonic VG2436
    Screen Resolution
    1920x1080p
    Hard Drives
    Samsung HD 105SI
    WDC WD20
    Case
    Apevia XJupiter
    Cooling
    air
    Mouse
    Logitech MX 600
    Keyboard
    Logitech MX 3200
    Internet Speed
    30 Mbps
Top