• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Soundblaster Live!

#1
Howdy,

I have a regular Soundblaster Live! soundcard (not SBLive! 5.1) with the expansion daughter card connected to the orignal Creativelabs 4.1 speaker setup. The card is on black PCB and has gold-plated connectors. This is from back in the days when this combo was the top of the line. Currently I have Vista x32 and am considering moving to x64 to use the full 4GB of RAM I have. However I am concerned there are no drivers for this. Right now I am using the modified KxDrivers 3538m which I get full quadrophonic sound and can adjust it anyway I want like the creative control panels. I don't believe this is compatible with x64. All the "fixes" I see on a simple Google search are for SBLive! 5.1,Audigy,X-Fi, etc. Don't wantt o bother with a new sound card when the old one works perfectly.
 

My Computer

#3
Thanks the tech-geek in me won over and I installed it anyways. Suprisingly Windows Update now provides a generic SBLive! driver for all those users. No control panel no equalizer control but there is a generic 4.1,5.1,7.1 speaker setup which is good enough for me. I was never that much into EAX 9999.0 so as long as it works. This SBLive! has also gone into about 8 machines I have owned over the years.
 

My Computer

#5
Hi, this is my Vista32/64 mod driver for SB live 4.1/5.1 cards series, enjoy¡¡

Sound Blaster Live series 4.1 - 5.1 vista 32/64 driver (based on sb x-fi driver)


This Driver have Full OpenAL support, Surround sound, Louder volume, audio console functional, Microsoft enhancements (These enhancements allow highly advanced Bass Management Control, Speaker Fill similar to CMSS, but MS sounds better, Room Correction and Loudness Equalization) and same XP´sound quality.
Eax work with Alchemy¡
1-Uninstall old driver
2-Run setup, if ask the driver not whql,install anyway the driver work just fine reboot
3-Install Audio Console reboot, this is important to surround sound work, if not install audio console the sound only pass through two front speakers
4-If you hear distortion sound, change speakers to 4 or 5.1 (preferably use audio console if show all white use windows mixer but leave audio console installed to surround sound work) ; or change sample rate option in panel control, 48000hz 16bit work for me, if you can´t hear any sound after install the driver or change speaker setting, only mute and unmute volume in windows mixer and this fix the problem.
5-The sounds in vista enviroment have only two channel, test multichannel sounds in games like Bioshock or Prey

Note: For multichannel sounds in windows vista environment, you have to enable Speaker Fill option in control panel - sound enhancements setting.
I test multichannel 4 and 5.1 sounds successfully in Bioshock demo.

Other info
Audio console work¡¡ EAX work in games¡, Winamp and EAX´s effect in audio console work too¡
For this,use Creative_Alchemy_Universal_1.00.04 or Creative_ALchemy_1.00.03 both Daneil_K mod.
Creative MediaSource Player/Organizer 5.10.38 work too¡
Winamp 5.5 work perfect with ALchemy Universal 1.00.04 for SB Live! / Audigy
have full support hardware acceleration and multi speakers, the sound is very good¡¡

Instruction for winamp and other players:
copy dsound.dll´s ALchemy directory to Winamp folder. enjoy¡

COPYRIGHT NOTICE: The included files are property of Creative Labs, Inc.

The files:

Sound Blaster Live series 4.1 - 5.1 vista 32/64 driver
http://rapidshare.com/files/64356124/SBAX_2_12_0001_20.zip

Creative audio console - Install this to surround sound work
http://rapidshare.com/files/65598530/AudCon.zip


----------------------------------------------------------------

Other files like ALchemy and Vista gameport driver
Creative ALchemy Universal 1.00.04 for SB Live! / Audigy
http://forums.creative.com/creativelabs/board/message?board.id=Vista&message.id=18972

Gameport support pack for Vista gameport driver
http://forums.creative.com/creativelabs/board/message?board.id=Vista&message.id=13336

Creative MediaSource Player/Organizer 5.10.38
http://rapidshare.com/files/67342817/CMS5_5.10.38.exe

----------------------------------------------------------------

Read other sb live driver post:
http://forums.creative.com/creativelabs/board/message?board.id=Vista&message.id=23567

http://forums.creative.com/creativelabs/board/message?board.id=Vista&message.id=19194

http://forums.creative.com/creativelabs/board/message?board.id=Vista&message.id=22938

----------------------------------------------------------------

All Tested with SB Live Value Model: CT4830 and Windows Vista ultimate 32/64bits
Full System Setup:
ATHLON 64 X2 4400+ Core Brisbane
K9N NEO V1.0 bios v1.6
2Gb Dual Channel OCZ Platinum Rev.2 800mhz
WD WD1600AAJS 160Gb SATAII
DVD-RW LG GSA-H42N
Zogis Geforce 7950GT 512MB PCIE
Sound Blaster Live Value
ATV-TUNER-F Advantek
Thanks to Daniel_K, and all user to support sb live series¡¡¡¡¡¡
Sound Blaster Live for ever ¡¡¡¡¡¡¡¡¡¡
 

My Computer

peto

New Member
#6
Assuming that Vista recognizes your card and it works fine with distortion, then the following should work well.
1. Go to Start > Control Panel and click on Classic
View.
2. Double-click on Sound and single click on
speakers.
3. With Speakers now hilighted, click on the
Configure button on the bottom left.
4. Assuming you have two speakers and subwoofer,
choose 7.1 Surround and click next.
5. On the next screen, uncheck everything but the
subwoofer and click Next.
6. This screen leave only the Front left and right
option checked.
7. On the next screen, click Finished and back at the
Sound screen, just click OK.
8. Enjoy the sound!
 

My Computer

#7
:cry:
Assuming that Vista recognizes your card and it works fine with distortion, then the following should work well.
1. Go to Start > Control Panel and click on Classic
View.
2. Double-click on Sound and single click on
speakers.
3. With Speakers now hilighted, click on the
Configure button on the bottom left.
4. Assuming you have two speakers and subwoofer,
choose 7.1 Surround and click next.
5. On the next screen, uncheck everything but the
subwoofer and click Next.
6. This screen leave only the Front left and right
option checked.
7. On the next screen, click Finished and back at the
Sound screen, just click OK.
8. Enjoy the sound!
Peto i Specialy Signed in just to be able to Thank you !!!

Thank you very much for posting this, i followed the steps and my sound is perfect with the Windows Update-driver and the distortion is now gone.
I was blaming Microsoft al the time, why release such a bad driver, but it is a great driver only the Settings must be changed.

Thanks again, you made a men happy here :D !!!
 

My Computer

Cartel

New Member
canada ca_british_columbia
#8
I found any drivers other than the 2002 drivers make snap, crackle, pop sounds.

If you want crystal clear sound, with no scratchy crud, I suggest you follow this link.

Make sure you remove all previous divers and follow my instuctions.

I've been running this way since RC1 and never had any issues.

Remember, no creative driver for Live! supports more than 2GB of ram.

Very important!

Vista SB0100 The right Way - Windows Vista - Creative Labs
 

My Computer

System One

  • Manufacturer/Model
    ME!
    CPU
    AMD FX-60
    Motherboard
    ASUS A8V-Deluxe Rev.2.00
    Memory
    2GB OCZ PC3200 EL Platinum
    Graphics Card(s)
    Sapphire HD3850 512 AGP
    Sound Card
    HT Omega Claro
    Monitor(s) Displays
    ViewSonic G220fb
    Screen Resolution
    1600x1200@85hz
    Hard Drives
    WD Raptor 150GB Seagate Barracuda 7200.10 160GB
    PSU
    Enermax EG465P-VE FMAII 460W ATX V2.2
    Cooling
    Zalman 9700NT
    Mouse
    Microsoft SideWinder
    Internet Speed
    http://www.speedtest.net/result/369540816.png
#9
Naimadekar your zipped driver package made my Kaspersky squeal like a pig on acid!

Maybe someone else has had this and can confirm it has a worm..

detected: riskware Worm.P2P.generic Running process: C:\WINDOWS\SYSTEM32\OALINST.EXE
 

My Computer

System One

  • CPU
    P4 3GHZ
    Motherboard
    Gigabyte
    Memory
    2gb DDR3200
    Graphics Card(s)
    nVidia5200
    Hard Drives
    External 360GB
    Internals x3
    120GB
    129GB
    200GB
#10
Hi,

I have Soundblaster Live 5.1. Back in the day when i used XP, I could just simply plug my headphones in the 6.35mm jack on the front control panel of the soundcard with all the cool gadgets etc and the sound would automatically channel into the headphones. One day it stopped working, so i thought maybe i need a new 6.35mm adapter. I bought one and it still didnt work. Now i got a new computer with Vista, but I kept the same soundcard. I realised there are no SBLive! drivers for vista. I got my speakers working fine. But my headphones still doesnt work on the front. The only way to get my headphones to work is if I unplugg my speakers from the green connector in the back and then plug my headphones through that. But thats kinda of annoying and not good for my speakers. Does anyone know how I can get the 6.35 on the front to work again. Is it a hardware or software issue?

Cheers,
Joronamo.
 

My Computer

#11
I know this may sound silly but have you tried turning up the volume for the headphones? It's situated next to the 3.5mm jack plugin.

Just a thought :D

Since I made this post I have moved on to the Audigy 4 with external control box - Great bit of kit and ideal for my recording studio.
 

My Computer

System One

  • CPU
    P4 3GHZ
    Motherboard
    Gigabyte
    Memory
    2gb DDR3200
    Graphics Card(s)
    nVidia5200
    Hard Drives
    External 360GB
    Internals x3
    120GB
    129GB
    200GB
#12
Hey mate,

Hmm there is no volume next to headphone plugin. Im talking about the back of my soundcard not the front with all the gadgets which dont seem to work anymore - im presuming because soundblaster has no vista support.

Cheers,
Joronamo.
 

My Computer

#13
Hey mate,

Hmm there is no volume next to headphone plugin. Im talking about the back of my soundcard not the front with all the gadgets which dont seem to work anymore - im presuming because soundblaster has no vista support.

Cheers,
Joronamo.
If you go onto the Creative site I'm pretty much sure after a lot of complaints Creative have released a Vista driver..

I also ditched Vista through the problems the OS gave me.
 

My Computer

System One

  • CPU
    P4 3GHZ
    Motherboard
    Gigabyte
    Memory
    2gb DDR3200
    Graphics Card(s)
    nVidia5200
    Hard Drives
    External 360GB
    Internals x3
    120GB
    129GB
    200GB
#14
@ peto - You're a life saver sir or ma'am. I just spent about an hour or more searching forums and trying different drivers with no change in the terrible quality. I rolled back to the drivers vista used to begin with, followed your instructions and I have my great audio quality back from the deep dark depths of vista.

Thank you and good day.
 

My Computer

#15
Actually you can still use your old Soundblaster Live! or Value under Windows Vista using your Win XP driver "LiveDrvUni-Pack(our ENG)" which can be downloaded at the Soundblaster Website. Just follow these simple steps:

1) Do not install the "LiveDrvUni-Pack(ENG)" because it can't detect your card, instead, extract it using a simple extractor called "7-Zip" to your preferred sub-folder;

2) Go to device manager and under the "other devices" you can find "multimedia device". Point your mouse to it and press right click button to pop-up a menu then choose "update driver software...";

3) Once you click the "update driver software..." another menu will come out and choose under "browse my computer for driver software" then browse the folder where you extracted the "LiveDrvUni-Pack(our ENG)" then choose that folder where you extracted the said driver then press "ok";

4) Be sure you check the box which says "include subfolders", then click next and leave it until it installs your SBLive soundcard drivers;

5) Since there's no surround mixer that can be installed under Windows Vista with this soundcard, you can adjust your sound setup or preferences using your control panel and locate the "sound" and from there you can make your SBLive as your default soundcard and do some tweaking.

That's it. Hope this would help, Bye and good luck!
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)