Superfetch - Change Preload Data

ByLine
How to Change What Superfetch will Preload in Vista
Synopsis
Superfetch monitors which applications you use the most and preloads these into your system memory (RAM) so they'll be ready when you need them. This will show you how to change Superfetch to preload only the Boot files, Program files, or the default both Boot and Program files into memory.
How to Change What Superfetch will Preload in Vista

information   Information
Superfetch is a new improved feature in Vista that monitors which applications you use the most and preloads these into your system memory (RAM) so they'll be ready when you need them. This will show you how to change Superfetch to preload only the Boot files, Program files, or the default both Boot and Program files into memory.
Note   Note
The Boot files are the startup programs, system files, and drivers loaded during the startup (boot) of Vista. The Program files are the programs you or Vista open and close in Vista. Test to see what works best for you.





OPTION ONE
Through a REG File Download

1. To Allow Only Boot Files to Preload
A) Click on the download button below to download the file below.​
Only_Boot_Files.reg
download

B) Go to step 4.​

2. To Allow Only Program Files to Preload
A) Click on the download button below to download the file below.​
Only_Programs.reg
download

B) Go to step 4.​

3. To Allow Both Boot and Program Files to Preload
NOTE: This is the default setting for Superfetch if you want to undo any changes.
A) Click on the download button below to download the file below.​
Boot_and_Programs_Files.reg
download

4. Click on Save, and save the .reg file to the Desktop.​
5. Right click on the downloaded .reg file and click on Merge.​
6. Click on Run, Continue (UAC), Yes, and then OK when prompted.​
8. Log off and log on, or restart the computer to apply the changes.​
9. When done, you can delete the downloaded .reg file if you like.​





OPTION TWO
Manually Through Registry Editor

1. Open the Start Menu.​
2. In the white line (Start Search) area, type regedit and press Enter.​
3. Click on Continue in the UAC prompt.​
4. In regedit, navigate to the location below. (See screenshot below)​
Code:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters
Modify.jpg

5. In the right pane, right click on EnablePrefetcher and click on Modify. (See screenshot above)​
6. To Disable Prefetcher
A) Type 0 (number zero) and click on OK. (See screenshot below step 9)​
B) Go to step 10.​

7. To Allow Only Program Files to Preload
A) Type 1 and click on OK. (See screenshot below step 9)​
B) Go to step 10.​

8. To Allow Only Boot Files to Preload
A) Type 2 and click on OK. (See screenshot below step 9)​
B) Go to step 10.​

9. To Allow Both Boot and Program Files to Preload
NOTE: This is the default setting for Superfetch if you want to undo any changes.
A) Type 3 and click on OK. (See screenshot below)​
Modify.jpg

10. Close regedit.​
11. Log off and log on, or restart the computer to apply the changes.​
That's it,
Shawn


 
Last edited:
Shawn Brink

Comments

Shawn are you sure the key is EnableSuperfetch or EnablePrefetcher?
I tried the download .reg file to set it to only do boot files and \windows\prefetch
kept showing applications as I ran them.

However I found another article and when I followed it and set EnablePrefetcher
to '2' it seemed to work as expected. What I was doing was setting Superfetch
service to Automatic but stopping it 10 or 15 minutes after booting so it could cache the bootup without running in the background all the time. So far this boot only caching seems to have quieted it down.

It would be nice if I didn't have to remember to shut the thing off manually. :)
 
Thank you MilesAhead for catching this. This link from MSDN confirms what you suspected.

Disabling Prefetch

The tutorial has been updated for this correct setting now.

Thank you again,
Shawn
 
Thank you MilesAhead for catching this. This link from MSDN confirms what you suspected.

Disabling Prefetch

The tutorial has been updated for this correct setting now.

Thank you again,
Shawn
You're welcome. Thanks for all the good info on system configuration for Vista. I'm becoming optimistic that I can boot this thing up and run programs instead of manually turning stuff on and off just to keep it running smoothly. :)
 
I shutdown each night and when not in use. Is prefetching taking extra cycles and disk activity away from my applications with no real benefit of prefetching?
 
Hi Stanley,

Welcome to Vista Forums.

The boot files are what Vista loads during startup. This is usually device drivers and the startup programs (Ex: Firewall, Antivirus, etc...).

The Program files option are the ones you run after Vista has started to the desktop.

Hope this helps,
Shawn
 
If a particular service is loaded during startup, then yes.

Superfetch usually does a great job on improving performance with both options set to be enabled though.

Shawn
 
If a particular service is loaded during startup, then yes.

Superfetch usually does a great job on improving performance with both options set to be enabled though.

Shawn
Hmm as an experiment I may reenable Superfetch default settings. Could be the hidden scheduled task "walk start pages" was the culprit afa running my HD during idle times.
 
Hi MilesAhead,

Did you already check the usual suspects of: Search Index and Disk Defragmenter?

Shawn
 
Hi MilesAhead,

Did you already check the usual suspects of: Search Index and Disk Defragmenter?

Shawn
Yes, plus I turned off local shadowing of network files and media player indexing etc.. What really quieted the HD down after that was killing that
Walk Start Pages in hidden scheduled tasks. I use locate32 for searches and run its indexer manually. Also any ad/virus scanners or Sandboxie, I have their services set to manual.

I have to say though, with Superfetch set to only cache boot files my prefetch folder seems to be holding at a steady 8 MB. Maybe I shouldn't fix it again if it isn't broken? :)
 
MilesAhead,

I do not have that hidden Walk Start Pages task. What is it a part of?

Yeah, the prefetch shouldn't change much with just the boot files since they usually do not change often. ;)

LOL, you can't fix it unless you break it though. :geek:

Shawn
 
MilesAhead,

I do not have that hidden Walk Start Pages task. What is it a part of?

Yeah, the prefetch shouldn't change much with just the boot files since they usually do not change often. ;)

LOL, you can't fix it unless you break it though. :geek:

Shawn
I didn't know it was there. I kept seeing my drive run on when idle and when
I looked in Process Monitor the shell was accessing every file. I have the
ntfs file system "last accessed" disabled so I didn't know what it was. I kept
looking in Scheduled Tasks in Winpatrol and it showed nothing. I didn't see it
until I went into Task Scheduler and checked Show Hidden Tasks. Then under
Shell tasks it showed Walk Start Pages. It seems MS has about a dozen ways
it wants to index your files whether you like it or not. So far I've turned off
shadowing of network files, Media Player file indexing, Windows Search Indexing
service and disabled just about every Lan service that won't break the network
connection. Plus I was turning off Superfetch manually. Oh and I have a little
app killer that kills mobsync.exe as soon as it tries to pop up.

Even after all that, Walk Start Pages was getting me!!! Sheesh!!!
My drive is nice and quiet now though. But it took me like 14 months
to get there!!!

I've heard from another Vista user that he doesn't have this and he's running SP1 so maybe they backed off it due to user feedback. He claims his HD quieted down once
he let it index what it wanted for a few hours. But my system runs good so I don't
want to put SP1 on. I did only a few of the updates like the slow shell file move fixes and the update update(ok so it's too easy to comment on an "update" update
so I'll leave it alone) :)

btw I see HP machines coming out with 6 GB ram and 64 bit Vista preinstalled so I think I'll be making the move to 64 bit in the near future. :)
 
S
Hi everyone. I've been looking for a solution for an issue I got with Superfetch in Vista X64 SP1, and finally i found a forum where this one's been treated.

As far as I know, Superfetch preloads boot files & aplications on RAM for later use... But, i've noticed it preloads NOT only this type of files... It makes the same with several type of files I've accesed lately, like *.mp3, *.rar, *.pdf, *.avi... and preloads all these too.

This is really an annoying issue when I access these files when they got high size, like 500MB-1GB.

Why Superfetch does it? Is there any option or any register edition to change this and make Vista don't preload these type of files?

Thanks for your attention.
 
Hi Sprocket,

Welcome to Vista Forums. :party:

Sorry, but you cannot specify individual files or file types to not preload. You cab only specify it to preload the program files, boot files, or the default of both.

Superfetch does this because it learns what you usually run and tries to have it preloaded in memory when it thinks you will need it to help your computer run faster by having it the faster RAM memory ready and not having to load it from the slower hard drive when you actually use it. If you do not use it, then Superfetch will dump it when it runs low on memory and is loading something else automatically.

As the saying goes, empty unused RAM is wasted RAM. You might as well use it and gain some performance from it. ;)

Hope this helps,
Shawn
 
Hi everyone. I've been looking for a solution for an issue I got with Superfetch in Vista X64 SP1, and finally i found a forum where this one's been treated.

As far as I know, Superfetch preloads boot files & aplications on RAM for later use... But, i've noticed it preloads NOT only this type of files... It makes the same with several type of files I've accesed lately, like *.mp3, *.rar, *.pdf, *.avi... and preloads all these too.

This is really an annoying issue when I access these files when they got high size, like 500MB-1GB.

Why Superfetch does it? Is there any option or any register edition to change this and make Vista don't preload these type of files?

Thanks for your attention.
As alternative to changing the configuration you can just stop the service manually, say 10 minutes after bootup. You could make a batch file like SuperOff.bat with this line in it:

start /MIN cmd /C sc stop SysMain

(hmm you can always tell a Dos old timer... guess it's been .cmd for
awhile now... so name it SuperOff.cmd instead.)

The "start /MIN" part just opens a minimized command window so that
you don't get a black command window hanging on your desktop if there's a few seconds of delay before the service responds. I don't use UAC so you might need to make a shortcut with Run As Administrator or something to avoid UAC prompts.
 
Last edited:
S
Thanks for your attention. Finally I decided deactivating Superfetch service for a few days so I can compare the OS's speed & HD activity.

Firstly I've noticed that HD finally stops reading after loading boot files (about 30 seconds), but compared with "Superfetch activated", now apps take more time to load (logically).

Now I have to evaluate my prefs:

  1. Vista loading with less HD activity on it and more time for loading apps, or...
  2. Vista loading with 5 minutes HD activity and faster apps loading.
I think for 24/7 working PCs, option 2 is better, but for PCs with some ON/OFF cycles the same day, option 2 is better...
 
Top