• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Superfetch has stopped working

#1
Not really sure what I should do.

I'm running Windows Vista Home Premium 64-bit
My computer is an HP Pavilion a600f

When I start up I get this message:
Superfetch has stopped working.
Problem signature:
Problem Event Name: APPCRASH
Application Name: svchost.exe_SysMain
Application Version: 6.0.6001.18000
Application Timestamp: 47919291
Fault Module Name: sysmain.dll
Fault Module Version: 6.0.6002.18005
Fault Module Timestamp: 49e04208
Exception Code: c0000005
Exception Offset: 0000000000028ff5
OS Version: 6.0.6002.2.2.0.768.3
Locale ID: 1033
Additional Information 1: 570e
Additional Information 2: f87d907f6c95b3755cbb4bbb0beffc03
Additional Information 3: 2633
Additional Information 4: 00b160c131b062ec9ae01ef07ef1effe

Here's what I have done so far:

First I ran chkdsk /f /r -- solved nothing.

Then I did a memory diagnostic -- it found a memory error. But it was a simple fix -- just had to reseat my memory. I thought "Okay, this should solve the problem."

But it didn't. So I ran chkdsk /f again (not sure if I should do /r or not again. It takes forever, and I'd like to know if that'd solve my problem or not before I try again).

So at this point, I'm not really sure what to do. I've read somewhere to delete the files in the prefetch folder, but I was also told this probably wouldn't work for me.

Any help would be greatly appreciated.
 
#3
Okay. I looked in eventvwr, and the first error seems to be this:

Faulting application svchost.exe_SysMain, version 6.0.6001.18000, time stamp 0x47919291, faulting module sysmain.dll, version 6.0.6002.18005, time stamp 0x49e04208, exception code 0xc0000005, fault offset 0x0000000000028ff5, process id 0xf48, application start time 0x01cc71539ce261e9.

I also did sfc/scannow and it could not fix two errors (I'm not sure if either of these are the problem or not)

2011-09-12 11:03:20, Info CSI 000002dc [SR] Cannot repair member file [l:24{12}]"settings.ini" of Microsoft-Windows-Sidebar, Version = 6.0.6002.18005, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch

2011-09-12 11:03:20, Info CSI 000002da [SR] Cannot repair member file [l:32{16}]"imaadp32.acm.mui" of Microsoft-Windows-Audio-ACMCoreCodecs.Resources, Version = 6.0.6000.16386, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"en-US", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file is missing

I don't have a Vista Installation CD (The computer didn't come with one) so I'm not really sure what I should do at this point.
 
#5
I'm not sure if I have a recovery partition or not... I think I do -- but I'm not sure.

Question in the meantime though -- is it safe to run my computer still? I got the memory error fixed, and so far, my computer has no trouble running outside of the Superfetch error when I log on. (Other services have problems at startup, but work fine otherwise).