• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Toshiba (TSST) TS-L632 / HL-DT-ST DVDRAM GSA-T40N ATA Device

#1
Lets try this again.


I can't believe the page stepped back that far into it,
Toshiba (TSST) TS-L632 / HL-DT-ST DVDRAM GSA-T40N ATA Device

Hello,

I am looking for some perspective on an issue I am having. I have a Toshiba A305-6860 and it has been having driver issues for a little while. I just now got done doing an out of the box restore and the same issue is there, which hasn't happened before. The main current issues is with the optical drive driver. When the computer was new a while ago it had vista x64 hp installed. the optical drive then was called the Toshiba (TSST) TS-L632 it worked well, needed an update to take care of some 301 error but still worked after that. since i first got the pc i have had 7 on it, from the first beta released up to the RC 7100, which was the last installed OS before today's out of box install. before I had done the restore the DVD was showing in device manager as a HL-DT-ST DVDRAM GSA-T40N ATA Device, since that has changed the drive only does some things, it was able to burn, but not able to read dvd's, in particular my new RTM 7600 copy of 7. It will however run the restore DVD's. Does anyone have any thing to add perhaps? I have tried every combination of uninstall/reboot/install, etc. I do not know why or when the device changed drivers, but roll back is not a highlighted option. I think I am going to try and wipe this drive clean and try again, but with the DVD not working with this DVD i cannot boot from it to do an install either, although it has worked on 2 other pcs.

any advice would be appreciated! Thanks for taking the time to read this mess.....

dave



 
Last edited:

My Computer

System One

  • Manufacturer/Model
    Toshiba A305 S6860 Satellite Notebook, Custom PC, Custom PC
    CPU
    Intel Centrino , AMD Athlon 64 3400+ 2.29 Ghz, Same @ 2.4Gz
    Motherboard
    Factory Board, Gigabyte GA-K8NNXP, MSI MS-6741
    Memory
    4gb, 1.5gb, 2gb
    Graphics Card(s)
    Intel 965, ATI 1600x, ATI All in Wonder 9600
    Sound Card
    HD Audio, Sound Blaster Audigy 2zs, Turtle Beach Riviera
    Monitor(s) Displays
    Laptop Panel, Acer x223w, Acer AL1916w
    Screen Resolution
    1280 x 800, 1680 x 1050, 1440 x 900
    Hard Drives
    1 Seagate 500 GB, 3 Seagate 320 GB, 2 200 GB Maxtor. Few others..
    Mouse
    MS Wireless Lasers
    Internet Speed
    16 MB/s Comcast Cable

archie123

I Tunes hates Me
Vista Guru
Gold Member
#2
i have to ask................is it compatible with windows 7?
 

My Computer

System One

  • Manufacturer/Model
    Custom Build
    CPU
    Intel Q9550 @ 4Gig / Titan Fenir
    Motherboard
    XFX 780i
    Memory
    4GB OCZ PC2-8500C5 DDR2
    Graphics Card(s)
    Gainward GTX260/216 SLI
    Sound Card
    Creative X-FI Xtreme Gamer
    Monitor(s) Displays
    Dell UltraSharp 2209WA 22"
    Screen Resolution
    1680x1050
    Hard Drives
    western digital raptor 10000rpm sata
    PSU
    OCZ Modstream 700w
    Cooling
    Titan Fenir
    Mouse
    Logitech G5 Gamer
    Keyboard
    Razer Reclusa
    Internet Speed
    8mb
#3
Sure is! It has ran on 7 before through several beta's.
 

My Computer

System One

  • Manufacturer/Model
    Toshiba A305 S6860 Satellite Notebook, Custom PC, Custom PC
    CPU
    Intel Centrino , AMD Athlon 64 3400+ 2.29 Ghz, Same @ 2.4Gz
    Motherboard
    Factory Board, Gigabyte GA-K8NNXP, MSI MS-6741
    Memory
    4gb, 1.5gb, 2gb
    Graphics Card(s)
    Intel 965, ATI 1600x, ATI All in Wonder 9600
    Sound Card
    HD Audio, Sound Blaster Audigy 2zs, Turtle Beach Riviera
    Monitor(s) Displays
    Laptop Panel, Acer x223w, Acer AL1916w
    Screen Resolution
    1280 x 800, 1680 x 1050, 1440 x 900
    Hard Drives
    1 Seagate 500 GB, 3 Seagate 320 GB, 2 200 GB Maxtor. Few others..
    Mouse
    MS Wireless Lasers
    Internet Speed
    16 MB/s Comcast Cable

archie123

I Tunes hates Me
Vista Guru
Gold Member
#4
and now another stupid question...........did it stop working after you upgraded to a newer version?
 

My Computer

System One

  • Manufacturer/Model
    Custom Build
    CPU
    Intel Q9550 @ 4Gig / Titan Fenir
    Motherboard
    XFX 780i
    Memory
    4GB OCZ PC2-8500C5 DDR2
    Graphics Card(s)
    Gainward GTX260/216 SLI
    Sound Card
    Creative X-FI Xtreme Gamer
    Monitor(s) Displays
    Dell UltraSharp 2209WA 22"
    Screen Resolution
    1680x1050
    Hard Drives
    western digital raptor 10000rpm sata
    PSU
    OCZ Modstream 700w
    Cooling
    Titan Fenir
    Mouse
    Logitech G5 Gamer
    Keyboard
    Razer Reclusa
    Internet Speed
    8mb
#5
see thats the funny part. i happened somewhere inbetween. it must have been a windows update. I know for sure it was a TSST earlier on. Changing to a completely different component/device name is strange.

I have pulled the drive out of the computer to clean it, also check model # on the unit itself. I will post an update if it just needed some serious cleaning. which can be the only bit of saving grace I have left.

Just don't get it.

This computer has another issue, but I think it is because the device is now broken. A new Sandisk product is the culprit. an extreme III 4 GB drive did it. It is one of the new models that came out a few months ago, great idea except for it tearing apart laptop memory card reader pins!!!

The SDHC card folds in half to allow you to insert into USB, which is great. but now this card reader will never work again.

Dammit.
 

My Computer

System One

  • Manufacturer/Model
    Toshiba A305 S6860 Satellite Notebook, Custom PC, Custom PC
    CPU
    Intel Centrino , AMD Athlon 64 3400+ 2.29 Ghz, Same @ 2.4Gz
    Motherboard
    Factory Board, Gigabyte GA-K8NNXP, MSI MS-6741
    Memory
    4gb, 1.5gb, 2gb
    Graphics Card(s)
    Intel 965, ATI 1600x, ATI All in Wonder 9600
    Sound Card
    HD Audio, Sound Blaster Audigy 2zs, Turtle Beach Riviera
    Monitor(s) Displays
    Laptop Panel, Acer x223w, Acer AL1916w
    Screen Resolution
    1280 x 800, 1680 x 1050, 1440 x 900
    Hard Drives
    1 Seagate 500 GB, 3 Seagate 320 GB, 2 200 GB Maxtor. Few others..
    Mouse
    MS Wireless Lasers
    Internet Speed
    16 MB/s Comcast Cable
#6
I cleaned the hell out of the drive and now it is working. While I had the drive out the GSA-T40N does match up on the top of the component, so I guess the most recent update maybe changed the name of the device? I don't know, makes no sense to me but it works so its all good.
 

My Computer

System One

  • Manufacturer/Model
    Toshiba A305 S6860 Satellite Notebook, Custom PC, Custom PC
    CPU
    Intel Centrino , AMD Athlon 64 3400+ 2.29 Ghz, Same @ 2.4Gz
    Motherboard
    Factory Board, Gigabyte GA-K8NNXP, MSI MS-6741
    Memory
    4gb, 1.5gb, 2gb
    Graphics Card(s)
    Intel 965, ATI 1600x, ATI All in Wonder 9600
    Sound Card
    HD Audio, Sound Blaster Audigy 2zs, Turtle Beach Riviera
    Monitor(s) Displays
    Laptop Panel, Acer x223w, Acer AL1916w
    Screen Resolution
    1280 x 800, 1680 x 1050, 1440 x 900
    Hard Drives
    1 Seagate 500 GB, 3 Seagate 320 GB, 2 200 GB Maxtor. Few others..
    Mouse
    MS Wireless Lasers
    Internet Speed
    16 MB/s Comcast Cable

archie123

I Tunes hates Me
Vista Guru
Gold Member
#7
I cleaned the hell out of the drive and now it is working. While I had the drive out the GSA-T40N does match up on the top of the component, so I guess the most recent update maybe changed the name of the device? I don't know, makes no sense to me but it works so its all good.
Ha ha how odd the device name is coded into the device firmware how the hell has it managed to change that?? Computers.......dont you just love em ;)

Gald its sorted :) keep it bloody clean next time ;)
 

My Computer

System One

  • Manufacturer/Model
    Custom Build
    CPU
    Intel Q9550 @ 4Gig / Titan Fenir
    Motherboard
    XFX 780i
    Memory
    4GB OCZ PC2-8500C5 DDR2
    Graphics Card(s)
    Gainward GTX260/216 SLI
    Sound Card
    Creative X-FI Xtreme Gamer
    Monitor(s) Displays
    Dell UltraSharp 2209WA 22"
    Screen Resolution
    1680x1050
    Hard Drives
    western digital raptor 10000rpm sata
    PSU
    OCZ Modstream 700w
    Cooling
    Titan Fenir
    Mouse
    Logitech G5 Gamer
    Keyboard
    Razer Reclusa
    Internet Speed
    8mb