Unassociate File Extension Type

ByLine
How to Unassociate a File Extension Type in Vista and Windows 7
Synopsis
This will show you how to set a file extension to be associated with nothing instead of some default program without having to delete the file extension unless you wanted to.
How to Unassociate a File Extension Type in Vista and Windows 7

information   Information
This will show you how to set a file extension to be associated with nothing for all users instead of some default program without having to delete the file extension unless you wanted to.

Note   Note
This is a standalone EXE program that does not install to your computer.

CREDIT TO:

Ramesh Srinivasan -www.winhelponline.com/articles/231/1/






Here's How:
1. Download the free unassoc.zip file and save it to your desktop.​
2. Right click on unassoc.zip (On Desktop) and click Open.​
3. Extract both files to the desktop. (See screenshot below)​
4. Click on the Unassoc.exe icon to run the program.​
NOTE: I would recommend that you put these two files in a new folder and save them in your C:\Program Files folder, then make a shortcut for the Unassoc.exe to use.
Zip_Contents.jpg

5. Click on Continue in the UAC prompt.​
6. To Unassociate a File Extension Type
A) Click on a file extension type from the list in the left pane to select it. (See screenshot below step 7)​
B) Click on Remove file association (User).​

7. To Delete a File Extension Type
A) Click on a file extension type from the list in the left pane to select it. (See screenshot)​
B) Click on Delete file type.​
Unassociate.jpg


8. Close program when done.​
That's it,
Shawn




 
Last edited by a moderator:
Shawn Brink

Comments

Hi, I have been trying desperately for 3 hours to remove the association of the file type .INS from the program "Inspiration" (Document Mapping) so that I can run an .INS file as an "install shield script" file. I tried your tutorial and, sure enough, in the control panel, the ".INS" file type is no longer associated with Inspiration. However, when I look at my downloaded copy of a new program that I want to install that includes the .INS file type, it is still associated with Inspiration! It is EVIL! Can you help me? Thanks!
 
Sorry, me again, I just realized that I deleted the file extension instead of unassociating it. Is there any way I can fix this??? Thanks, --e.
 
When I run the program and find the file I want to unassociate the Remove file association (User) is grayed out. What else can I do do unassociate.
 
Hello Bluefire, and welcome to Vista Forums.

You might download and double click on the REG file I attached below, then restart the computer to see if it may help. It will remove the registry entries for the .blob file extension to hopefully unassociate it for you.

Hope this helps,
Shawn
 

Attachments

When I run the program and find the extention .dat (which I want to unassociate) the Remove file association (User) is grayed out, what can I do?
 
Sorry, it doesn't work, it appears "Impossibile importare C:\...\Default.reg: non tutti i dati sono stati scritti correttamente sul registro. Alcune chiavi sono utilizzate dal sistema o da altri processi."

Which means: "It is impossible to merge C:\...\Default.reg: there are some data which are not correctly written on the register. Some keys are being used by the system or some other process."
 
Hi Robs,

Try doing this:


  1. Open your start menu
  2. In the search box, type regedit.exe
  3. Right click on the search regedit.exe and select Run as administrator
  4. Navigate to: HKEY_CLASSES_ROOT/.dat
  5. Click the on a key you want to take ownership of.
  6. On the Edit menu, click Permissions.
  7. Click Advanced, and then click the Owner tab.
  8. Under Change owner to, click the new owner, and then click OK.
  9. Repeat for the other keys in that folder
  10. Try running that .reg file again, as instructed by Brink
 
Top