• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Unknown Device on Microsoft ACPI Compliant Embedded Controller?!?!

krunal

New Member
Messages
25
Location
India
#1
Hi all,

i have updated my system to ultimate x64 sp1.

now in device manager, i found one unknown device(which is shown in Other Devices in Device manager), i tried most of drivers for it.

but not able to get it. i even do not know what device it is.

Please refer attached images. :)

screen1.jpg

screen2.jpg

thanks,
krunal
 

My Computer

System One

  • Manufacturer/Model
    Lenovo Y410 45Q
    CPU
    Intel Core 2 Duo
    Motherboard
    Intel
    Graphics Card(s)
    Nvidia GeForce 8400M GS
    Screen Resolution
    1280x800
    Hard Drives
    160 GB SATA

johngalt

Antidisestablishmentarian
Vista Guru
Messages
3,912
Location
3rd Rock
#2
DId you *upgrade* from 32bit to 64bit?
 

My Computers

System One System Two

  • Show second system?
    Yes
    Operating System
    Windows 10 Insider Preview current build
    Manufacturer/Model
    The Beast Model V
    CPU
    Intel Core i7 965 EE @ 3.6 GHz
    Motherboard
    eVGA X58 Classified3
    Memory
    3 * 4GB Mushkin Enhanced Redline CL7 DDR3 1600 MHz (PC3-12800)
    Graphics Card(s)
    eVGA GTX 970 + eVGA GTX 560 Ti 448 Core Classified (PhysX)
    Sound Card
    Realtek HD Audio (onboard)
    Monitor(s) Displays
    2 * Lenovo LT2323pwA
    Screen Resolution
    2 * 1920 x 1080
    Hard Drives
    SanDisk Ultra SDSSDHII-960G-G25 SATA III SSD (System)
    Crucial MX100 CT256MX100SSD1 SATA III SSD (User Tree)
    2 * Seagate Barracuda 7200.12 ST31000528AS SATA II
    Seagate ST1500DL001 7200 RPM SATA II
    Intel SSDSA2M080G2GC SATA II SSD
    PSU
    ThermalTake BlackWidow 850W
    Case
    ThermalTake Level 10 GT
    Cooling
    Corsair H100 (CPU) + Air (2 * 210 mm + 3 * 120mm fans)
    Mouse
    Logitech MX Master
    Keyboard
    Logitech G15 (gen 2)
    Internet Speed
    300+ Mbps downstream / 30+ Mbps upstream
  • Operating System
    Windows 10 Insider Preview (current)
    Manufacturer/Model
    Dell Inspiron 3521
    CPU
    Intel(R) Celeron(R) CPU 1007U @ 1.50GHz
    Motherboard
    Dell
    Memory
    8 GB
    Graphics card(s)
    Intel(R) HD Graphics
    Sound Card
    Intel(R) Display Audio | Realtek Audio
    Monitor(s) Displays
    Inspiron 15"
    Screen Resolution
    1680 * 1050
    Hard Drives
    INTEL SSDSC2CW180A
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master | Synaptics TouchPad
    Keyboard
    Dell
    Internet Speed
    300+ Mbps downstream | 30+ Mbps upstream

krunal

New Member
Messages
25
Location
India
#3
nope,

i have installed 64bit.

krunal
 

My Computer

System One

  • Manufacturer/Model
    Lenovo Y410 45Q
    CPU
    Intel Core 2 Duo
    Motherboard
    Intel
    Graphics Card(s)
    Nvidia GeForce 8400M GS
    Screen Resolution
    1280x800
    Hard Drives
    160 GB SATA

johngalt

Antidisestablishmentarian
Vista Guru
Messages
3,912
Location
3rd Rock
#4
According to what the second one looks like (and this is the really weird part0 it looks like you have installed Virtual PC 2004....which is not Vista compatible.

You need Virtual PC2007....

But I suspect that is not the case either - so I suggest you make sure you have *all* drivers for your hardware installed, motherboard, chipset, etc....
 

My Computers

System One System Two

  • Show second system?
    Yes
    Operating System
    Windows 10 Insider Preview current build
    Manufacturer/Model
    The Beast Model V
    CPU
    Intel Core i7 965 EE @ 3.6 GHz
    Motherboard
    eVGA X58 Classified3
    Memory
    3 * 4GB Mushkin Enhanced Redline CL7 DDR3 1600 MHz (PC3-12800)
    Graphics Card(s)
    eVGA GTX 970 + eVGA GTX 560 Ti 448 Core Classified (PhysX)
    Sound Card
    Realtek HD Audio (onboard)
    Monitor(s) Displays
    2 * Lenovo LT2323pwA
    Screen Resolution
    2 * 1920 x 1080
    Hard Drives
    SanDisk Ultra SDSSDHII-960G-G25 SATA III SSD (System)
    Crucial MX100 CT256MX100SSD1 SATA III SSD (User Tree)
    2 * Seagate Barracuda 7200.12 ST31000528AS SATA II
    Seagate ST1500DL001 7200 RPM SATA II
    Intel SSDSA2M080G2GC SATA II SSD
    PSU
    ThermalTake BlackWidow 850W
    Case
    ThermalTake Level 10 GT
    Cooling
    Corsair H100 (CPU) + Air (2 * 210 mm + 3 * 120mm fans)
    Mouse
    Logitech MX Master
    Keyboard
    Logitech G15 (gen 2)
    Internet Speed
    300+ Mbps downstream / 30+ Mbps upstream
  • Operating System
    Windows 10 Insider Preview (current)
    Manufacturer/Model
    Dell Inspiron 3521
    CPU
    Intel(R) Celeron(R) CPU 1007U @ 1.50GHz
    Motherboard
    Dell
    Memory
    8 GB
    Graphics card(s)
    Intel(R) HD Graphics
    Sound Card
    Intel(R) Display Audio | Realtek Audio
    Monitor(s) Displays
    Inspiron 15"
    Screen Resolution
    1680 * 1050
    Hard Drives
    INTEL SSDSC2CW180A
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master | Synaptics TouchPad
    Keyboard
    Dell
    Internet Speed
    300+ Mbps downstream | 30+ Mbps upstream

krunal

New Member
Messages
25
Location
India
#5
i tried all drivers from lenovo driver cd. but it may be possible that some drivers are not for 64. so thats y some problem :(

and one thing i havnt using virtual pc. i have fresh installed vista ultimate x64.

thanks,
krunal
 

My Computer

System One

  • Manufacturer/Model
    Lenovo Y410 45Q
    CPU
    Intel Core 2 Duo
    Motherboard
    Intel
    Graphics Card(s)
    Nvidia GeForce 8400M GS
    Screen Resolution
    1280x800
    Hard Drives
    160 GB SATA

johngalt

Antidisestablishmentarian
Vista Guru
Messages
3,912
Location
3rd Rock
#6
That is what I thought - and that is the problem with taking an OEM machine and upgrading it to x64 or downgrading it to XP - you have to make sure all your drivers are available *before* upgrading.

But, have you contacted Lenovo, since *they* are the ones that made it?
 

My Computers

System One System Two

  • Show second system?
    Yes
    Operating System
    Windows 10 Insider Preview current build
    Manufacturer/Model
    The Beast Model V
    CPU
    Intel Core i7 965 EE @ 3.6 GHz
    Motherboard
    eVGA X58 Classified3
    Memory
    3 * 4GB Mushkin Enhanced Redline CL7 DDR3 1600 MHz (PC3-12800)
    Graphics Card(s)
    eVGA GTX 970 + eVGA GTX 560 Ti 448 Core Classified (PhysX)
    Sound Card
    Realtek HD Audio (onboard)
    Monitor(s) Displays
    2 * Lenovo LT2323pwA
    Screen Resolution
    2 * 1920 x 1080
    Hard Drives
    SanDisk Ultra SDSSDHII-960G-G25 SATA III SSD (System)
    Crucial MX100 CT256MX100SSD1 SATA III SSD (User Tree)
    2 * Seagate Barracuda 7200.12 ST31000528AS SATA II
    Seagate ST1500DL001 7200 RPM SATA II
    Intel SSDSA2M080G2GC SATA II SSD
    PSU
    ThermalTake BlackWidow 850W
    Case
    ThermalTake Level 10 GT
    Cooling
    Corsair H100 (CPU) + Air (2 * 210 mm + 3 * 120mm fans)
    Mouse
    Logitech MX Master
    Keyboard
    Logitech G15 (gen 2)
    Internet Speed
    300+ Mbps downstream / 30+ Mbps upstream
  • Operating System
    Windows 10 Insider Preview (current)
    Manufacturer/Model
    Dell Inspiron 3521
    CPU
    Intel(R) Celeron(R) CPU 1007U @ 1.50GHz
    Motherboard
    Dell
    Memory
    8 GB
    Graphics card(s)
    Intel(R) HD Graphics
    Sound Card
    Intel(R) Display Audio | Realtek Audio
    Monitor(s) Displays
    Inspiron 15"
    Screen Resolution
    1680 * 1050
    Hard Drives
    INTEL SSDSC2CW180A
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master | Synaptics TouchPad
    Keyboard
    Dell
    Internet Speed
    300+ Mbps downstream | 30+ Mbps upstream

krunal

New Member
Messages
25
Location
India
#7
Yes, i go thru the support site, for latest drivers and softwares. but it seems that they providing it for 32 vista only.

so i have to try other drivers for 64.

thanks,
krunal
 

My Computer

System One

  • Manufacturer/Model
    Lenovo Y410 45Q
    CPU
    Intel Core 2 Duo
    Motherboard
    Intel
    Graphics Card(s)
    Nvidia GeForce 8400M GS
    Screen Resolution
    1280x800
    Hard Drives
    160 GB SATA

johngalt

Antidisestablishmentarian
Vista Guru
Messages
3,912
Location
3rd Rock
#8
Well, you have to *identify* what the 'device' is before you can use a driver....
 

My Computers

System One System Two

  • Show second system?
    Yes
    Operating System
    Windows 10 Insider Preview current build
    Manufacturer/Model
    The Beast Model V
    CPU
    Intel Core i7 965 EE @ 3.6 GHz
    Motherboard
    eVGA X58 Classified3
    Memory
    3 * 4GB Mushkin Enhanced Redline CL7 DDR3 1600 MHz (PC3-12800)
    Graphics Card(s)
    eVGA GTX 970 + eVGA GTX 560 Ti 448 Core Classified (PhysX)
    Sound Card
    Realtek HD Audio (onboard)
    Monitor(s) Displays
    2 * Lenovo LT2323pwA
    Screen Resolution
    2 * 1920 x 1080
    Hard Drives
    SanDisk Ultra SDSSDHII-960G-G25 SATA III SSD (System)
    Crucial MX100 CT256MX100SSD1 SATA III SSD (User Tree)
    2 * Seagate Barracuda 7200.12 ST31000528AS SATA II
    Seagate ST1500DL001 7200 RPM SATA II
    Intel SSDSA2M080G2GC SATA II SSD
    PSU
    ThermalTake BlackWidow 850W
    Case
    ThermalTake Level 10 GT
    Cooling
    Corsair H100 (CPU) + Air (2 * 210 mm + 3 * 120mm fans)
    Mouse
    Logitech MX Master
    Keyboard
    Logitech G15 (gen 2)
    Internet Speed
    300+ Mbps downstream / 30+ Mbps upstream
  • Operating System
    Windows 10 Insider Preview (current)
    Manufacturer/Model
    Dell Inspiron 3521
    CPU
    Intel(R) Celeron(R) CPU 1007U @ 1.50GHz
    Motherboard
    Dell
    Memory
    8 GB
    Graphics card(s)
    Intel(R) HD Graphics
    Sound Card
    Intel(R) Display Audio | Realtek Audio
    Monitor(s) Displays
    Inspiron 15"
    Screen Resolution
    1680 * 1050
    Hard Drives
    INTEL SSDSC2CW180A
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master | Synaptics TouchPad
    Keyboard
    Dell
    Internet Speed
    300+ Mbps downstream | 30+ Mbps upstream

krunal

New Member
Messages
25
Location
India
#9
hmmmm, i have done driver scan from driveragent site. and it shows lots of new drivers available for my system and download is not free .. sad.

krunal
 

My Computer

System One

  • Manufacturer/Model
    Lenovo Y410 45Q
    CPU
    Intel Core 2 Duo
    Motherboard
    Intel
    Graphics Card(s)
    Nvidia GeForce 8400M GS
    Screen Resolution
    1280x800
    Hard Drives
    160 GB SATA

johngalt

Antidisestablishmentarian
Vista Guru
Messages
3,912
Location
3rd Rock
#10
Like I said = you need to go to the Lenovo site. If there are no new drivers there then start looking up your motherboard manufacturer and see if there are BIOS updates, drivers etc for Windows Vista 64bit.
 

My Computers

System One System Two

  • Show second system?
    Yes
    Operating System
    Windows 10 Insider Preview current build
    Manufacturer/Model
    The Beast Model V
    CPU
    Intel Core i7 965 EE @ 3.6 GHz
    Motherboard
    eVGA X58 Classified3
    Memory
    3 * 4GB Mushkin Enhanced Redline CL7 DDR3 1600 MHz (PC3-12800)
    Graphics Card(s)
    eVGA GTX 970 + eVGA GTX 560 Ti 448 Core Classified (PhysX)
    Sound Card
    Realtek HD Audio (onboard)
    Monitor(s) Displays
    2 * Lenovo LT2323pwA
    Screen Resolution
    2 * 1920 x 1080
    Hard Drives
    SanDisk Ultra SDSSDHII-960G-G25 SATA III SSD (System)
    Crucial MX100 CT256MX100SSD1 SATA III SSD (User Tree)
    2 * Seagate Barracuda 7200.12 ST31000528AS SATA II
    Seagate ST1500DL001 7200 RPM SATA II
    Intel SSDSA2M080G2GC SATA II SSD
    PSU
    ThermalTake BlackWidow 850W
    Case
    ThermalTake Level 10 GT
    Cooling
    Corsair H100 (CPU) + Air (2 * 210 mm + 3 * 120mm fans)
    Mouse
    Logitech MX Master
    Keyboard
    Logitech G15 (gen 2)
    Internet Speed
    300+ Mbps downstream / 30+ Mbps upstream
  • Operating System
    Windows 10 Insider Preview (current)
    Manufacturer/Model
    Dell Inspiron 3521
    CPU
    Intel(R) Celeron(R) CPU 1007U @ 1.50GHz
    Motherboard
    Dell
    Memory
    8 GB
    Graphics card(s)
    Intel(R) HD Graphics
    Sound Card
    Intel(R) Display Audio | Realtek Audio
    Monitor(s) Displays
    Inspiron 15"
    Screen Resolution
    1680 * 1050
    Hard Drives
    INTEL SSDSC2CW180A
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master | Synaptics TouchPad
    Keyboard
    Dell
    Internet Speed
    300+ Mbps downstream | 30+ Mbps upstream

hypedawg39

New Member
Messages
4
#13
Click on the unknown driver and then update the driver, instead of automatically updating the driver, chose the search from a specific location option and when you do chose the battery option and then chose the acpi compliant option. Problem solved.

If you have any questions hit me up at hypedawg39@yahoo.com
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)