• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Unknown devices in device manager

#1
Hi All,

I installed new software to use USB port to connect the board and program that board During this installation some things went wrong and all my USB port are not responding or not working at all...

When i checked the Device Manager it shows like Other device -> Unknown device..

I install the chipset from Toshiba download and still I can’t solve the prob....

my USB all port not working..
my WiFi is not working..
my Camera is not working...

i use..

Toshiba satellite L300-110 SYSTEM UNIT
Model No: PSLB0E

OS - Vista 32 Ultimate x86

i try to update the driver for that unwknown device from Device Manager but it show the eorror like..

windows found driver for your device but encounter an problem while attempting to install it..

inter(R) ICH8 family USB Universal Host Controller 2834

an error occur during installing of the driver

The driver installing file for this device is missing a necessary entry. this may be bcz of INF was written for win95 or later, contact ur hardware vendor.. .
.

and also i check the Unknown device-> property it show error code (code28)....

i uninstalled that new software and i try to install the chip set from Toshiba but no change...still it show the same error message as above....

when i try to install the driver for camera inbuilt in system it stop installing and show error and exit the installation..

as i installed lot of driver i dont have old restore point to restore my system too....

i dont have backup for my system also...

any suggestion pls...
 
#3
i can find all detail and when i download and install that driver it stop installing saying unknown error and exit installing if i uninstall this unknown device and install chip set driver it install successfully and when i scan for hardware chage or restart the system it say the message like what i mention before in bold letters i have prob in INF file how can i slove it.... i suspect like what all drive i downlad it have only x64 but my computer say ACPI x86- based PC so i think i should try for x86 avilable driver...

what is ur sugetion pls?
 

wither 3

Vista Guru
Gold Member
#6
Since the software appears to have corrupted your system, restoring the system to before installing the software should fix that problem and give you time to investigate the problem with the software before trying to install it again.
 
#7
Hi thanks for your reply....

i installed lot of driver after i install that software and i came to know the device are not working only when i restart my system in evening...so i cont find the old restore point before that software is installed bcz i think vista have only few latest restore point.....

what u think?
 

Patonb

Vista Guru
Gold Member
#10
Oh nutz... You have clicked the "Choose different Restore Point" correct?
Then "Show Older than 5 days"?

If you have, you're out of luck.

If you haven't tried yet, I would uninstall your recent programs. Then in the hardware monitor, uninstall the USB devices.
This might be best done in "Safe Mode"
 
#12
fine... as my hard disk run out of space it have only few recent restore point and i cont find the restore point before i install that software...

what to do now?

vista repair can work?

i dont want to disturb my OS i have only one OS installed in my system.....

i dont want to install new OS bcz i have lot of information in running OS so i am try to fix it....
 
Last edited:

wither 3

Vista Guru
Gold Member
#13
My point is that the installation of software, such as drivers, results in many temporary files. If there's no hard disk space for them, then the installation will fail.
You're going to have to transfer files to another drive to free up the space. If you run the Windows Disk Cleanup utility from Accessories and reboot, you will get some space back.