• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

USB mouse stopped working after Silverlight 3.0 install on a clean Vista x64

irenab

New Member
Messages
2
#1
I need help with now a reproducible problem.
I have 2 identical HP Pavilion dv4 laptops running Vista Home Premium x64.
After installing Silverlight plugin on a clean machine, the USB mouse stopped working with all of my mice.
Uninstall of Silverlight is not helping. It seems like Silverlight somehow corrupts the drivers (or maybe some other problem) that prevent the USB mouse from working.
The touch mouse is still OK.

I've been struggling with this for a while and spent ton of time without any progress.
I do need to use Silverlight in my work and I have to have an external mouse.
Please, help. This problem makes my two laptops useless. And they are fairly new (few months old).

Thanks a lot!!
 

My Computer

Messages
3,375
#2
Hi,

What does Device Manager look like? Have you tried to update your mouse drivers from Device Manager? If you have, why is this not working, is there an error message? With an error message etc. as a starting block, we may be able to help you. I will continue to look into this for you, but an error message would be very helpful. Did you silverlight install go well or did it crash half way through?

Hope your problem is fixed soon,

Richard
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS 420
    CPU
    Intel Core 2 Quad Q9300 2.50GHz
    Motherboard
    Stock Dell 0TP406
    Memory
    4 gb (DDR2 800) 400MHz
    Graphics Card(s)
    ATI Radeon HD 3870 (512 MBytes)
    Sound Card
    Onboard
    Monitor(s) Displays
    1 x Dell 2007FP and 1 x (old) Sonic flat screen
    Screen Resolution
    1600 x 1200 and 1280 x 1204
    Hard Drives
    1 x 640Gb (SATA 300)
    Western Digital: WDC WD6400AAKS-75A7B0

    1 x 1Tb (SATA 600)
    Western Digital: Caviar Black, SATA 6GB/S, 64Mb cache, 8ms
    Western Digital: WDC WD1002FAEX-00Z3A0 ATA Device
    PSU
    Stock PSU - 375W
    Case
    Dell XPS 420
    Cooling
    Stock Fan
    Mouse
    Advent Optical ADE-WG01 (colour change light up)
    Keyboard
    Dell Bluetooth
    Internet Speed
    120 kb/s
    Other Info
    ASUS USB 3.0 5Gbps/SATA 6Gbps - PCI-Express Combo Controller Card (U3S6)

mdcorman

New Member
Messages
2
#3
you say your running 64 bit. make sure that the drivers are for 64 NOT 32
Another thing see if you can go back to archives and install an older version of SILVERLIGHT. (old saying is if it was working that if it works don't update)
 

My Computer

irenab

New Member
Messages
2
#4
Thank you for reply.
The story here goes a bot longer but I tried to save you the details. So here are some more details.

the problem started to occur in mid December when the USB mouse stopped working. I tried to reinstall drivers but it didn't help. After many experiments we narrowed it down to a particular Windows update which failed. We rolled it back and the mouse started to work again.
I was happy we found a reason. So I disabled automatic updates and gave this laptop to my daughter to play with while I was helping her (she is 5 y.o. and the only game she had a chance to play with was Shidonni - Safe virtual world for kids redirect which requires Silverlight 3.0).

Note, the computer was a completely clean Vista x64 reinstall, working perfectly with the USB mouse. After working on this website (which required Silverlight 3.0) for about 30 min, the problem came back and the mouse stopped working.

This drove me nuts. After a month of struggling, paying money to sysadmins and spending a lot of time looking for a fix, I am still left with two laptops having identical problems and making the system unusable.

I looked all over the web but I couldn't find anyone else with exactly the same problem. People complain on other USB peripherals stopped working and I wasn't sure it applied to my situation.
 

My Computer

zrgn

New Member
Messages
1
#5
I just recently experienced the same type of thing after a silverlight update. The USB mouse still works but is choppy. I did a system restore to a time just before the silverlight update was applied and now everthing is good again.

Alan

Windows 7 64-bit
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)