USB not detecting devices

RiverRun84

New Member
i googled and searched for this. but i can't find anything similar to my problem. sorry is this is a repeat.

my laptop is a few years old (behind the times)
make & model: Acer Aspire 4315-2490
using windows vista basic.

about a year and a half ago, 2 of my 3 usb ports stoped deteting ANYTHING. the 2 that don't work are on the right side of my laptop with the working one on the left. i plug a flash drive in and light on flash drive doesn't even come on. it's like my computer is acting like i'm not pluging in anything at all. i just did a system restore to factory settings last night. they still are not working.
 

My Computer

niemiro

Banned
Hi,

Sorry, but it sounds as though you have a physical hardware problem. Without opening up the computer and doing advanced and expensive repairs, there is no way of fixing this. You will just have to live with 1 USB port. You could however buy yourself small USB splitter so you can have more than 1 USB device plugged in at once.

Sorry again,

Richard
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS 420
    CPU
    Intel Core 2 Quad Q9300 2.50GHz
    Motherboard
    Stock Dell 0TP406
    Memory
    4 gb (DDR2 800) 400MHz
    Graphics Card(s)
    ATI Radeon HD 3870 (512 MBytes)
    Sound Card
    Onboard
    Monitor(s) Displays
    1 x Dell 2007FP and 1 x (old) Sonic flat screen
    Screen Resolution
    1600 x 1200 and 1280 x 1204
    Hard Drives
    1 x 640Gb (SATA 300)
    Western Digital: WDC WD6400AAKS-75A7B0

    1 x 1Tb (SATA 600)
    Western Digital: Caviar Black, SATA 6GB/S, 64Mb cache, 8ms
    Western Digital: WDC WD1002FAEX-00Z3A0 ATA Device
    PSU
    Stock PSU - 375W
    Case
    Dell XPS 420
    Cooling
    Stock Fan
    Mouse
    Advent Optical ADE-WG01 (colour change light up)
    Keyboard
    Dell Bluetooth
    Internet Speed
    120 kb/s
    Other Info
    ASUS USB 3.0 5Gbps/SATA 6Gbps - PCI-Express Combo Controller Card (U3S6)
Top