User Profile Folders - Prevent or Allow Location Change

ByLine
How to Prevent or Allow User Profile Folders Location Change in Vista
Synopsis
This will show you how to allow or prevent the default locations of the C:\Users\(user name) Personal User folders from being changed for all user accounts. These are the Contacts, Desktop, Documents, Downloads, Favorites, Links, Music, Pictures, Save Games, Searches, and Videos folders.
How to Prevent or Allow User Profile Folders Location Change in Vista

information   Information
This will show you how to allow or prevent the default locations of the C:\ Users\(user name) Personal User folders from being changed for all user accounts on the computer. These are the Contacts, Desktop, Documents, Downloads, Favorites, Links, Music, Pictures, Save Games, Searches, and Videos folders.
Note   Note
This is allowed by default in Vista.

EXAMPLE: Personal User Profile FoldersNOTE: Location is at C:\Users\(User Name)
User_Folders.jpg
EXAMPLE: Music Folder Properties Set to Allow and Prevent Location Change
NOTE:
When prevented the Target location field is still there, but you cannot change it.

Allowed_Properties.jpg Prevented_Properties.jpg





OPTION ONE
Through the Local Group Policy Editor

1. Open the all users, specific users or groups, or all users except administrators Local Group Policy Editor for how you want this policy applied.​
2. In the left pane, click on User Configuration, Administrative Templates, and Desktop. (See screenshot below)​
Group_Policy.jpg

3. In the right pane, right click on Prohibit User from Manually redirecting Profile Folders and click on Properties. (See screenshot above)​
4. To Allow User Profile Folders Location Change -
A) Select (dot) Disabled or Not Configured and click on OK. (See screenshot below step 5A)​
B) Go to step 6.​

5. To Prevent User Profile Folders Location Change -
A) Select (dot) Enabled and click on OK.​
GP_Properties.jpg

6. Close the Local Group Policy Editor window. Your done.​





OPTION TWO
Using a REG File Download

1. To Allow User Profile Folders Location Change
A) Click on the Download button below to download the file below.​
Allow_User_Folders_Location_Change.reg
download

B) Go to step 3.​

2. To Prevent User Profile Folders Location Change
A) Click on the Download button below to download the file below.​
Prevent_User_Folders_Location_Change.reg
download

3. Click on Save, and save the .reg file to the Desktop.​
4. Right click on the downloaded .reg file and click on Merge.​
5. Click on Run, Continue (UAC), Yes, and then OK when prompted.​
6. When done, you can delete the downloaded .reg file if you like.​




OPTION THREE
Manually in Registry Editor

1. Open the Start Menu.​
2. In the white line (Start Search) area, type regedit and press Enter.​
3. Click the Continue button for the UAC prompt.​
4. In regedit, go to: (See screenshot below)​
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
reg1.jpg

5. To Prevent User Profile Folders Location Change
A) In the right pane, right click on a empty area and click on New and DWORD (32-bit) Value. (See screenshot above)​
B) Type DisablePersonalDirChange and press Enter.​
C) Right click on DisablePersonalDirChange and click on Modify. (See screenshot below)​
Reg2.jpg

D) Type 1 and click on OK. (See screenshot below)​
Modify.jpg

E) The registry will now look like this. (See screenshot below)​
Reg3.jpg

F) Go to step 7.​

6. To Allow User Profile Folders Location Change
A) In the right pane, right click on DisablePersonalDirChange and click on Delete. (See screenshot above)​
B) Click on Yes to confirm deletion.​

7. Close regedit.​
That's it,
Shawn


 
Last edited:
Shawn Brink

Comments

I am at my wits end.

My wife's 500 GB HDD is full, primarily with pictures. I bought a new 1 TB hard drive; it is installed and formatted correctly. But when I go to change the location of the Pictures folder, the Restore Default/Move/Find Target buttons are not there. Here is what I have tried:
  1. I found your excellent tutorial and followed the instructions in Option 3, except the "DisablePersonalDirChange" value was not in the registry. I tried creating this entry and setting the value to "0" hoping this would trick the computer into letting me change it. No luck. I set it to "1" and naturally couldn't make the changes. Then I changed it back to "0", but nothing changed.
  2. I tried Option 2. Also no luck.
  3. Then I found the tutorial on "How to Change a Personal User Folder Location in Vista."
    1. Method 1 was out of the question because, as noted earlier, the Move button is not there.
    2. I thought Method 2 would be my salvation, but I ran into some problems. First, I don't have User Shell Folders; I do have Shell Folders, but it has the following entry: "!Do not use this registry key. Use the SHGetFolderPath or SHGetKnownFolderPath function instead." I can't find either of those two entries. On a whim, I tried editing the location per the tutorial's instructions anyway, but to no avail.
  4. I followed the rest of the discussion in this thread, and didn't find anything that relates to this problem.
Any help you can give will be greatly appreciated. I've spent way too much time on this "simple" process.
 
Top